1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Usergroup promotions problem - maybe trophy count issue?

Discussion in 'Troubleshooting and Problems' started by Stuart Wright, Sep 15, 2015.

  1. Stuart Wright

    Stuart Wright Well-Known Member

    Hello,
    we have usergroup promotions which are determined by a few factors, but in this particular issue, we have a member
    https://www.avforums.com/members/mrsossidge.106304/
    who has 136 trophy points https://www.avforums.com/members/mrsossidge.106304/trophies
    MrSossidge has posted 2,799 messages (at the time of writing), has been registered over 9 years and has 886 positive post ratings.

    Our primary usergroup is Novice Member. This is usergroup 1.
    They get promoted to Standard Member, usergroup 2, when they have
    • at least 1 message
    • registered at least 1 day
    • received at least 3 positive post ratings
    MrSossidge has this secondary usergroup.

    They get promoted to Active Member, usergroup 3, when they have
    • at least 50 messages
    • registered at least 1 day
    • received at least 3 positive post ratings
    MrSossidge does not have this usergroup, even after running a rebuild of trophies and user promotions earlier today.

    They get promoted to Well-known Member, usergroup 4, when they have
    • at least 50 messages
    • at least 75 trophy points
    • registered at least 1 day
    • received at least 3 positive post ratings
    MrSossidge does not have this usergroup, either. Why not?

    Attached is a screen capture of the user change log by MrSossidge showing the latest entries relating to usergroup changes.

    1.jpg

    I have no idea how to interpret what happend on August 19th.

    Help!
    Thanks
     
    Last edited: Sep 15, 2015
  2. Mike

    Mike XenForo Developer Staff Member

    Can you check the promotion history for this user? Do they have any entries involved?

    Are these the only criteria for the promotions?

    Regarding the log, that does look a bit confusing. The times will likely be different for each grouping, so I would say that each of the other changes likely happened in a group, such as during a promotion rebuild. If you hover the date, are the times different?
     
  3. Stuart Wright

    Stuart Wright Well-Known Member

    Thanks Mike.
    This is the changelog for MrSossidge. It's the only information in the log relating to usergroup changes and it's at the top, so it's the most recent stuff.
    1.jpg
    These are the only criteria for the usergroup promotions.
    Check them out if you like - you have access - https://www.avforums.com/admin.php?user-group-promotions/

    The times of the three change events are 5:20pm, 5:48pm and 5:48pm (last two the same).
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    This is the promotion log Mike was referring to:

    upload_2015-9-16_17-41-48.png
     
  5. Stuart Wright

    Stuart Wright Well-Known Member

    Apologies, never seen that before - never knew it existed.
    I'm guessing it doesn't shed much light on the situation?!
     
  6. Mike

    Mike XenForo Developer Staff Member

    Based on that screenshot, it would imply that they have all 3 promotions, so the system won't award them again. It's very difficult to say what happened with the user groups though, without being able to reproduce it directly.

    As a first step, use the delete button on the promotion history records for the promotions the user has listed but doesn't have the user group for and let them be re-promoted (either over time or by reporting). If they don't get the group added again, there's a log elsewhere in the system that indicates they should already be in the group (implying they were removed manually). We'll deal with that if it happens though.
     
    Chris D likes this.
  7. Chris D

    Chris D XenForo Developer Staff Member

    Admin CP > Users > User Group Promotions > Manage User Group Promotions (button in the top right).

    Search for the user, and as Mike says use the delete button in the Promotion History to remove the promotion from the user.
     
  8. Stuart Wright

    Stuart Wright Well-Known Member

    I deleted all the user promotions and when he next logged in, everything righted itself.
    Thanks both of you @Mike and @Chris D for your help.

    Should I create a suggestion thread for a process which tidies up the user promotions?
     

Share This Page