UI.X

UI.X [Paid] 1.5.22.0

No permission to buy ($30.00)

idFox

Well-known member
@Mike Creuzer UIX Mod v1.0.0 Patch 2:
<phrase title="option_uix_footer_col2_icon_explain" addon_id="uix" version_id="1000033" version_string="1.0.0 Beta 3"><![CDATA[The icon class to use before the title of column 1]]></phrase>
 

Mike Creuzer

Well-known member
@Mike Creuzer
Any idea on my #3504 post above? Can't wait to upgrade.
I think the issue is that that font file isn't writeable, and thus we cannot delete it in order to replace it with a newer version file. So you can either give write permissions recursively to the /js/ and /styles/ folder. OR you can just install the traditional way.

I have makes change only to childs... and now i lose all my job (i tried also download the child) but i saved only extra.css
So long as you made your changes to the child theme, upgrading the parent should be all you need to do :)

Anyone know if the Post Ratings styling that's new to this version is exposed in the style properties? Or do I have to mod it through CSS?

I can't seem to find it.
I believe I put everything in uix_thirdparty.css

Can UI.X still be installed traditionally?
Yes it can. The files are still available at the main site. We are going to be including instructions in the add-on for all 3 methods: FTP, PHP/automatic, and manually.

@Mike Creuzer UIX Mod v1.0.0 Patch 2:
<phrase title="option_uix_footer_col2_icon_explain" addon_id="uix" version_id="1000033" version_string="1.0.0 Beta 3"><![CDATA[The icon class to use before the title of column 1]]></phrase>
Good catch, fixed on our end - will be releasing an update to the add-on today :)

Issue with "Create New Thread" Button. It's quite small. UI.X 1.4.5.1
You likely need to revert the Breadcrumb > top control style property.
 

Ridemonkey

Well-known member
I believe I put everything in uix_thirdparty.css
Thanks. Would love for that to be exposed in the style properties if you continue to add support for popular third party add-ons.

I think it's awesome that you guys are taking that initiative to ensure that add-ons are styled properly within your framework.
 

SatGuyScott

Active member
Anyone else having an issue when submitting a reply it takes 3 or 4 seconds before it posts?

It was working fine before and the rest of the site is snappy. So I am trying to figure out what's causing it. :)
 

Mike Creuzer

Well-known member
Thanks. Would love for that to be exposed in the style properties if you continue to add support for popular third party add-ons.

I think it's awesome that you guys are taking that initiative to ensure that add-ons are styled properly within your framework.
Thank you very much! For the post ratings, for example, we actually are just removing code. We find that the author added a lot of code specific to the default theme, so really all we are doing is resetting some of the css to nothing. I believe styles should just inherit whenever possible.

I hope that add-ons give UI.X some consideration as well! UI.X will work on add-ons that don't overly add specific CSS. If they use generic xenforo classes, it'll look gorgeous. Which most add-on developers do, hence UI.X works well with all of them with a few exceptions. So in those exceptions, if the add-on seems to be supported well enough, we will officially support it. We support all official XenForo add-ons, anything by @Bob, @Chris D, @Jon W, @Brogan, and @xfrocks as well as other well supported add-ons.

Anyone else having an issue when submitting a reply it takes 3 or 4 seconds before it posts?

It was working fine before and the rest of the site is snappy. So I am trying to figure out what's causing it. :)
Definitely should not be the case so feel free to submit a ticket with some credentials, Ill see whats wrong there. We made huge optimizations in speed, but even then it never took that long to post.
 

Enguerran A

Well-known member
I'm trying to get the search bar to use the minimal option added with the new UI.X but I don't know how to do it :/ Is it possible to just use all the time this minimal search bar without the drop down? Since the beginning of my journey with XenForo I'm trying to remove it and now I know I'm close to it ^^ @Mike Creuzer I need your guidance ^^'
 

Mike Creuzer

Well-known member
I'm trying to get the search bar to use the minimal option added with the new UI.X but I don't know how to do it :/ Is it possible to just use all the time this minimal search bar without the drop down? Since the beginning of my journey with XenForo I'm trying to remove it and now I know I'm close to it ^^ @Mike Creuzer I need your guidance ^^'
Not a problem, and yes thats whats great about minimal search, no dropdown unless you click the settings icon.

So to enable this go to UI.X Search style property group. Find the minimal search viewport and set to be like 99999px. We will make it work with 100% at some point, not sure if we did yet or not. Try that first as that might work I don't recall.
 

Despair

Active member
UIX "NEW" indicator in PM:
View attachment 98903

FIX:
Code:
.conversation_view .message .newIndicator {
  margin-right: 0;
}
Hmm, for me, it wasn't just PM's, same issue for new posts as well. The margin-right:0 fixes it, but the new indicator is placed inside the post instead of on the edge. So I used position:absolute and it turns out UI.X now comments out the .newIndicator span, which is the little triangle portion that makes it look a bit more 3D, which I do like. I wonder if instead of commenting it out, you could just set it to display:none? As of right now I have to edit the message template just to uncomment the span and set the indicator span css again (or uncomment the relevant message.css portion) just to get back that effect. Or maybe I will just try to use :after and see if it's possible to redo this effect without a span, not sure...
 

Mike Creuzer

Well-known member
Hmm, for me, it wasn't just PM's, same issue for new posts as well. The margin-right:0 fixes it, but the new indicator is placed inside the post instead of on the edge. So I used position:absolute and it turns out UI.X now comments out the .newIndicator span, which is the little triangle portion that makes it look a bit more 3D, which I do like. I wonder if instead of commenting it out, you could just set it to display:none? As of right now I have to edit the message template just to uncomment the span and set the indicator span css again (or uncomment the relevant message.css portion) just to get back that effect. Or maybe I will just try to use :after and see if it's possible to redo this effect without a span, not sure...
I have this fixed. We got rid of the 'flag' style new indicator as it was too difficult to work with.
 

kylerc

Well-known member
I'm trying to get the search bar to use the minimal option added with the new UI.X but I don't know how to do it :/ Is it possible to just use all the time this minimal search bar without the drop down? Since the beginning of my journey with XenForo I'm trying to remove it and now I know I'm close to it ^^ @Mike Creuzer I need your guidance ^^'
Not a problem, and yes thats whats great about minimal search, no dropdown unless you click the settings icon.

So to enable this go to UI.X Search style property group. Find the minimal search viewport and set to be like 99999px. We will make it work with 100% at some point, not sure if we did yet or not. Try that first as that might work I don't recall.
100% is supported for "Viewport Width to Show Search Icon", but not for "Minimal Search Style Size" in the current release. I've added support for 100% to "Minimal Search Style Size" for the next release though.

@HitArrowLegend You'll also likely want to set "Minimal Search Style Size" to be 99999px to make the search icon trigger the minimal search. The Viewport width setting will change out the input for a search icon.
 

Enguerran A

Well-known member
I would be so happy if it wasn't necessary to click on the icon to show the search bar. If there is a way to always have the minimal search bar displayed (without the need to click on the icon) and without having the XF dropdown, i'm done with the search bar ^^
 

Rambro

Well-known member
I'm really starting to hate the **** out of this. First, it wouldn't upgrade the child theme, so I had to kill that. Then it wouldn't add a child theme to the main theme and was kicking back an error, so I deleted the main theme. Then it wouldn't let me install a theme at all and was kicking back an error, so I uninstalled everything and then reinstalled it. Now its giving me this when I try to install UI.X. from scratch:

session_start(): Cannot find save handler 'memcached' - session startup failed

  1. XenForo_Application::handlePhpError()
  2. session_start() in Audentio/UIX/ControllerAdmin/UIXStyle.php at line 113
  3. Audentio_UIX_ControllerAdmin_UIXStyle->actionInstall() in XenForo/FrontController.php at line 347
  4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  5. XenForo_FrontController->run() in /home/dressedw/public_html/admin.php at line 13
 

Mike Creuzer

Well-known member
I'm really starting to hate the **** out of this. First, it wouldn't upgrade the child theme, so I had to kill that. Then it wouldn't add a child theme to the main theme and was kicking back an error, so I deleted the main theme. Then it wouldn't let me install a theme at all and was kicking back an error, so I uninstalled everything and then reinstalled it. Now its giving me this when I try to install UI.X. from scratch:

session_start(): Cannot find save handler 'memcached' - session startup failed

  1. XenForo_Application::handlePhpError()
  2. session_start() in Audentio/UIX/ControllerAdmin/UIXStyle.php at line 113
  3. Audentio_UIX_ControllerAdmin_UIXStyle->actionInstall() in XenForo/FrontController.php at line 347
  4. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  5. XenForo_FrontController->run() in /home/dressedw/public_html/admin.php at line 13
Different server configurations, we are finding, make it difficult to download, delete, and copy files. So in that sense its still a work in progress. You can always download the files like normal.

First, it wouldn't upgrade the child theme, so I had to kill that
Also, its important to note you should not upgrade child themes.
 
Top