Resource icon

Template Modification System (TMS) 1.3.1

No permission to download

cclaerhout

Well-known member
The fix was providing by Chris less than 30 minutes after the release of the update of XenForo and Guiltar published an update the day after. That was fast...

Now to avoid this, developers like Guiltar should receive XenForo updates a little time before, it would avoid any problems. And like Chris said in another post, this "conflict" was not a real one.
On the other side, users should not forget than they are allowed to have a developer board too... and this board should be used to test any major updates with a similar configuration to their live board (same addons installed).

I expect everything to be gone when I uninstall something.
You're absolutely right. Never uninstall a major addon except if its author told you too. There is a disable function which is better (and this reminds me I need to update the mobile tracer...).
 

tyteen4a03

Well-known member
The fix was providing by Chris less than 30 minutes after the release of the update of XenForo and Guiltar published an update the day after. That was fast...

Now to avoid this, developers like Guiltar should receive XenForo updates a little time before, it would avoid any problems. And like Chris said in another post, this "conflict" was not a real one.
On the other side, users should not forget than they are allowed to have a developer board too... and this board should be used to test any major updates with a similar configuration to their live board (same addons installed).


You're absolutely right. Never uninstall a major addon except if its author told you too. There is a disable function which is better (and this reminds me I need to update the mobile tracer...).
This is why I love xF - The community support each other with their expertise knowledge.
 

Luxus

Well-known member
Yes, getting timeout...any other way to disable it?
If you disable TMS, all edited templates are reverted and stored in the database. This process takes some time depending on how much you used TMS. You can increase the php execution time in your php.ini or, alternatively, repeat the process until TMS is shown as disabled. I have figured out that even if you get a timeout error, a part of the templates has been reverted nonetheless. So you just press F5, and repeat the process untill TMS is completly disabled. This works for other addons too.
 

Luxus

Well-known member
guiltar, I don't know if it's a TMS issue or a XenForo issue, but why can't I string replace this

Code:
<!-- help -->
with this

Code:
<xen:comment><!-- help -->
in the navigation template? It says no differences found when saving.
 

Despair

Active member
guiltar, I don't know if it's a TMS issue or a XenForo issue, but why can't I string replace this

Code:
<!-- help -->
with this

Code:
<xen:comment><!-- help -->
in the navigation template? It says no differences found when saving.
Did you check your server error log? That would result in syntax error since there is no closing </xen:comment> tag.
 

Luxus

Well-known member
Yeah I figured, I had to preg replace this

Code:
#(<!-- help -->.*?</xen:if>)#s
with this

Code:
        <xen:if is="{$tabs.help}">
            <li class="navTab help {xen:if $tabs.help.selected, 'selected', 'Popup PopupControl PopupClosed'}">
                
                <div class="{xen:if {$tabs.help.selected}, 'tabLinks', 'Menu JsOnly tabMenu'} helpTabLinks">
                    <div class="primaryContent menuHeader">
                        <h3>{$tabs.help.title}</h3>
                        <div class="muted">{xen:phrase quick_links}</div>
                    </div>
                    <ul class="secondaryContent blockLinksList">
                    <xen:hook name="navigation_tabs_help">
                        <li><a href="{xen:link help/smilies}">{xen:phrase smilies}</a></li>
                        <li><a href="{xen:link help/bb-codes}">{xen:phrase bb_codes}</a></li>
                        <li><a href="{xen:link help/trophies}">{xen:phrase trophies}</a></li>
                        <li><a href="{xen:link help/cookies}">{xen:phrase cookie_usage}</a></li>
                    </xen:hook>
                    </ul>
                </div>
            </li>
        </xen:if>
This will remove the 'Help' tab from the navigation bar. Useful for people who wants to save space in the navigation bar and place the 'Help' link somewhere else, e.g in the footer.
 
  • Like
Reactions: DRE

Andrej

Well-known member
Hello Guiltar, you would prorably want to remove the links to "Addons using TMS:" of the author Matthew2D as they are not longer available.
 

gimomo

Member
control panel ... initial part throws me the following error after updating:
 

The Dark Wizard

Well-known member
After upgrading to TMS 1.2.2 and Xenforo 1.1.4

I get this error when visiting the Admin Control Panel and enabling debug mode(Not turning it on just shows a blank page)

Fatal error: Out of memory (allocated 65536000) (tried to allocate 1091 bytes) in /home/rpdom/public_html/library/Zend/Db/Statement/Mysqli.php on line

The number is constantly changing. If it helps our php is given a limit of 256M

Disabling TMS the hard way(By disabling all addons in config then going in and turning that one off and enabling all addons back) fixes the problem.
 

sonnb

Well-known member
After upgrading to TMS 1.2.2 and Xenforo 1.1.4

I get this error when visiting the Admin Control Panel and enabling debug mode(Not turning it on just shows a blank page)

Fatal error: Out of memory (allocated 65536000) (tried to allocate 1091 bytes) in /home/rpdom/public_html/library/Zend/Db/Statement/Mysqli.php on line

The number is constantly changing. If it helps our php is given a limit of 256M
It might not caused by TMS, might some addon that invoke to AdminCP can cause this issue. Try to disable some addons then access again. (in db, table: xf_addon, field: active).
 

Deebs

Well-known member
Are you sure your php processes are allowed 256M? The error indicates it is restricted to around 65M. What does your phpinfo report for memory_limit?
 

The Dark Wizard

Well-known member
It might not caused by TMS, might some addon that invoke to AdminCP can cause this issue. Try to disable some addons then access again. (in db, table: xf_addon, field: active).
I have manually turned on every single addon and left TMS, last refreshing each time to see if it returned, after a few hours of stabbing at this I have confirmed that is only TMS that causes this issue.

Are you sure your php processes are allowed 256M? The error indicates it is restricted to around 65M. What does your phpinfo report for memory_limit?
My PHP info page shows for memory_limit 256M for local and master value
 

Mike

XenForo developer
Staff member
That's an error that you're physically out of memory - it doesn't reflect the memory_limit.
 

The Dark Wizard

Well-known member
That's an error that you're physically out of memory - it doesn't reflect the memory_limit.
[root@fili rpdom]# free -m
total used free shared buffers cached
Mem: 5845 5570 274 0 182 2259
-/+ buffers/cache: 3128 2716
Swap: 1023 28 995

We are not even close to running out of memory though.
 

Mike

XenForo developer
Staff member
I'm not proposing that it's necessarily this, but that's an error that PHP will generate when it tries to allocate memory and fails. If you have memory, then you need to look into things that are limiting the amount of memory that PHP can have.
 
Top