Add-on Install & Upgrade

Add-on Install & Upgrade 1.4.3

No permission to download

lazy llama

Well-known member
Version 1.4.3 ZIP file has two xml files in it. The one at top level is the correct one, but the one in upload/library/AddOnInstaller is from version 1.4.0.

Ironically, it's the latter which is picked up by older versions of this add-on.
 

Xon

Well-known member
@lazy llama I've updated the zip on github but it'll require @Chris D to update it here. If you install it again, the 1.4.3 xml should be picked up by the updated code :p

There changes in the XML are very minor. Mostly the version ID, and a default option for 'faster install' which now works
 

RSI

Active member
Is there any way to get a stand-alone add-on just for the "Rebuild Add-Ons" feature of this add-on?

A Rebuild Add-Ons add-on
.
 

Chris D

XenForo developer
Staff member
Well, arguably not. There shouldn't be. But for example if you were mistakenly playing around in debug mode, you might be able to modify or delete master versions of stuff.

In XF2 there IS actually a direct way to perform a rebuild of an installed add-on. It's sort of equivalent to the "Rebuild master data" option you get if you go to your "install/" page.

In XF 1.x there's a way too. You'd just perform an upgrade of the add-on with the same version XML as you have installed and that is basically the same thing so, no add-on required really.

Though, indeed, I'd evaluate why a rebuild was needed in the first place. It should only be done if there was a specific reason to.
 

RSI

Active member
Though, indeed, I'd evaluate why a rebuild was needed in the first place. It should only be done if there was a specific reason to.
Well, over time things can happen or get corrupted. Like when you have installed an add-on where the developer was working on it then made some major changes to where it required doing clean an install, but some of the old junk was still left in there and was causing an issue with the fresh install, etc. That's happened to me a couple of times and running the Rebuild Add-ons feature in this add-on fixed it.

The problem is I don’t use this add-on and partly due to some incompatibles or conflicts when the ACP Extended (ACPE) add-on is installed. I hate to have this add-on installed when the only part of it I want is the Rebuild Add-ons feature.
.
 
Last edited:

DroidOne

Well-known member
Just checking to see if there are plans to make this available for 2.0... Or does 2.0 have a simple way to upgrade like this already?
They did think of adding version check at least, so there's no need for this add-on for that part. You'll be notified via the CP if any add-on is outdated.
 

Rambro

Well-known member
@Chris D and/or @Xon I wasn't sure who to tag with this but I just used the ACP to upgrade Xon's Report Improvements, then went to check on Alter Ego Detector and it generated this error:

Code:
Zend_Db_Statement_Mysqli_Exception: Mysqli statement execute error : Data too long for column 'latest_version' at row 1 - library/Zend/Db/Statement/Mysqli.php:214
Generated By: Rambo, A moment ago
Stack Trace
#0 /home/dressedw/public_html/library/Zend/Db/Statement.php(297): Zend_Db_Statement_Mysqli->_execute(Array)
#1 /home/dressedw/public_html/library/Zend/Db/Adapter/Abstract.php(479): Zend_Db_Statement->execute(Array)
#2 /home/dressedw/public_html/library/Zend/Db/Adapter/Abstract.php(632): Zend_Db_Adapter_Abstract->query('UPDATE `xf_addo...', Array)
#3 /home/dressedw/public_html/library/XenForo/DataWriter.php(1654): Zend_Db_Adapter_Abstract->update('xf_addon_update...', Array, '(addon_id = 'li...')
#4 /home/dressedw/public_html/library/XenForo/DataWriter.php(1623): XenForo_DataWriter->_update()
#5 /home/dressedw/public_html/library/XenForo/DataWriter.php(1419): XenForo_DataWriter->_save()
#6 /home/dressedw/public_html/library/AddOnInstaller/XenForo/Model/AddOn.php(553): XenForo_DataWriter->save()
#7 /home/dressedw/public_html/library/AddOnInstaller/XenForo/ControllerAdmin/AddOn.php(716): AddOnInstaller_XenForo_Model_AddOn->checkForUpdate(Array)
#8 /home/dressedw/public_html/library/XenForo/FrontController.php(351): AddOnInstaller_XenForo_ControllerAdmin_AddOn->actionCheck()
#9 /home/dressedw/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/dressedw/public_html/admin.php(13): XenForo_FrontController->run()
#11 {main}
Request State
array(3) {
  ["url"] => string(231) "http://www.dressedwell.net/admin.php?add-ons/liam_ae_detector/update-check&&_xfRequestUri=%2Fadmin.php%3Fadd-ons%2Fupdate-check&_xfNoRedirect=1&_xfToken=2%2C1512033250%2Cfed3e27c0eec55be5b75b5ed6a6bf64be035bed6&_xfResponseType=json"
  ["_GET"] => array(5) {
    ["add-ons/liam_ae_detector/update-check"] => string(0) ""
    ["_xfRequestUri"] => string(31) "/admin.php?add-ons/update-check"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(53) "2,1512033250,fed3e27c0eec55be5b75b5ed6a6bf64be035bed6"
    ["_xfResponseType"] => string(4) "json"
  }
  ["_POST"] => array(0) {
  }
}
 

Chris D

XenForo developer
Staff member
We’ve either released a fix for this already or the latest version downloaded straight from GitHub should sort it. Which version are you running?
 

Xon

Well-known member
We’ve either released a fix for this already or the latest version downloaded straight from GitHub should sort it. Which version are you running?
I copied and pasted a line of description text into the version text when releasing the update. Apparently XFRM2.0 considers "Fix damaged alter ego reports causing search index" a valid version string :p
 

Nirjonadda

Well-known member
@Chris D Please let me know that this add-on database table name? If we choose to uninstall a legacy add-on from XF2 and any database alterations will remain. Database table need to remove manually.
 
Top