• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Add-on Install & Upgrade

Add-on Install & Upgrade 1.4.3

No permission to download
  • Support invalidating APC opcode caching for php 5.4 and older
  • Support add-ons where their upload folder is nested in a folder
This is mostly a hot fix release. The issue was found shortly after the release of 1.4.1 and the package was updated. However, some people may still have the old code so please update to this version to be sure.
  • Tweak accepted list of file types for browser compatibility.
  • Fix for "Faster Install" mode could get stuck in an infinite loop.

Reminder: If you wish to continue using the update checking or install from RM URL options, then you WILL need to upgrade to version 1.4.0 or above.
Thank you @Xon and @NixFifty. This release includes the following:
  • Fix for XenForo.com updating to XenForo 2
  • Optional, disabled by default, ability to only rebuild changed/touched public templates during add-on install process.
    • Works with multiple add-ons
    • Does not affect;
      • phrases
      • admin templates
      • email templates
Another set of improvements by @Xon. Thanks Xon!
  • Fix issue where count of add-ons requiring updates vs list of add-ons requiring updates could get out of sync
  • Optional semantic version comparison, so if a newer version is installed locally it is not considered requiring an update.
Various bug fixes in this release.
  • Do not override the update_url if it has been set
  • Add cache buster strings to the redirect
  • Do not rebuild caches on intermediate install runs
  • Prevent deleting of an installed add-on entry
Thanks @Xon!
The majority of the fixes and features in this release were developed by @Xon, so please everyone say "Thank you @Xon" :)
  • Support for multiple deployment methods. In addition to the usual "File copy" method (which requires a write access everywhere) you can now deploy add-ons via FTP uploads.
  • Resolved a number of compatibility issues with some add-ons by some developers which do not follow the usual standard of packaging add-ons.
  • Attempts to reset opcode cache to prevent unexpected errors when installing or upgrading.
  • Redesigned and simplified interface.
  • Support for add-on batches - this allows you to add multiple files and Resource Manager URLs before eventually confirming and starting the Install / Upgrade.
  • New Rebuild Caches page.
  • New Add-on Install Log.
upload_2016-8-7_19-0-32.png


Enjoy!
Please disable the add-on from the Admin CP before attempting to upgrade the add-on. This means you should not attempt to update the add-on by using the add-on itself.

If you are experiencing errors, please first upload the files from this version, and then disable event listeners by adding the following to config.php:
PHP:
$config['enableListeners'] = false;
Then, disable the add-on and upgrade by going to List Add-ons > Add-on Installer: Controls > Upgrade Add-on and uploading the XML file.

This update makes a small fix which prevents additional errors showing when listeners are disabled.