XFtoWP - XenForo to WordPress Integration

XFtoWP - XenForo to WordPress Integration [Paid] 1.2 Beta 3 Patch 4

No permission to buy ($79.00)

RoyalRumble

Active member
Thank you very much for providing this plugin.

I've never used an XenForo API key before, and so I'd be grateful if you could kindly explain to me how to resolve an issue through what I strongly suspect is my own lack of understanding.

I've tried following your guide but I'm still a bit unsure.

1. I created a new user called named XFtoWP. This user has standard registered usergroup permissions.
2. Within Setup -> API keys I have created a API Key. For Key Type, I selected - User key: XFtoWP
3. Allowed Scopes -> I've been toggling through these but currently it's 'All Scopes'

However, the API user has no API permissions;

no-permissions.png

Do you know what mistake I've made?

Thanks
 

Mangini

Well-known member
Thank you very much for providing this plugin.

I've never used an XenForo API key before, and so I'd be grateful if you could kindly explain to me how to resolve an issue through what I strongly suspect is my own lack of understanding.

I've tried following your guide but I'm still a bit unsure.

1. I created a new user called named XFtoWP. This user has standard registered usergroup permissions.
2. Within Setup -> API keys I have created a API Key. For Key Type, I selected - User key: XFtoWP
3. Allowed Scopes -> I've been toggling through these but currently it's 'All Scopes'

However, the API user has no API permissions;

View attachment 244111

Do you know what mistake I've made?

Thanks
Hi @RoyalRumble your settings look perfectly correct, there is just a problem on your forum's end that is blocking the plugin from accessing the API.

I've worked through this with another customer and we found this happens when a folder called /api/ exists in the root XenForo directory, most likely leftover from another WordPress integration plugin you tried. This is actually not a core file of XF and should be renamed or deleted if no longer used on your site.

After you make the change, verify you can access the API link in your browser and it does not redirect to the /install/ directory:


If that works go back to the XF settings page and refresh your forum data, should work now. Credit to @Mike for helping us find this issue.
 

RoyalRumble

Active member
Hi @RoyalRumble your settings look perfectly correct, there is just a problem on your forum's end that is blocking the plugin from accessing the API.

I've worked through this with another customer and we found this happens when a folder called /api/ exists in the root XenForo directory, most likely leftover from another WordPress integration plugin you tried. This is actually not a core file of XF and should be renamed or deleted if no longer used on your site.

After you make the change, verify you can access the API link in your browser and it does not redirect to the /install/ directory:



If that works go back to the XF settings page and refresh your forum data, should work now. Credit to @Mike for helping us find this issue.

That did the trick! Thanks a lot.

Installed and looks brilliant so far.

After two disappointing experiences which previous Wordpress/XenForo bridges, this is looking very promising.

Quick question - when forum replies exceed 100 comments, does the WordPress comment count stay 100?
 

Mangini

Well-known member
Glad to hear. :)

Quick question - when forum replies exceed 100 comments, does the WordPress comment count stay 100?
Each time the thread refreshes it will update the latest reply count in WordPress. The default refresh rate is set to 60 minutes and can be adjusted if you want it to update quicker.
 

Mangini

Well-known member
XFtoWP 1.1 is nearly complete and comes with some bug fixes and improvements as reported here and at the official forums, as well as some other requested features. :) I will have the update with more info posted here shortly, and the new version will be accessed from the Plugins admin screen in WordPress and also a direct download from your XFtoWP account.
 

RoyalRumble

Active member
XFtoWP 1.1 is nearly complete and comes with some bug fixes and improvements as reported here and at the official forums, as well as some other requested features. :) I will have the update with more info posted here shortly, and the new version will be accessed from the Plugins admin screen in WordPress and also a direct download from your XFtoWP account.

Great, looking forward to deploying the update!

I've set our thread comments like so;

1610974977670.png


... I'm finding the below wordpress invite to log in to reply is shown, until the forum thread has some replies then it disappears.

Is this expected behaviour or can I prevent the below? It prompts a login to wordpress you see, and we don't allow any wordpress registrations

1610974929961.png
 

RoyalRumble

Active member
Also, I'm finding this happens sometimes;


Console flags this - not sure if related;

Uncaught TypeError: Cannot set property 'onclick' of null
at Object.loadMoreComments (XFWP.js?ver=21011413:9)
at XMLHttpRequest.request.onreadystatechange (XFWP.js?ver=21011413:9)
 

Mangini

Well-known member
... I'm finding the below wordpress invite to log in to reply is shown, until the forum thread has some replies then it disappears.
So the post in question does have a thread connected to it? The screenshot you posted looks like your theme default and is not markup used in the plugin, and without a thread ID XFtoWP will not alter the comments area.

Also, I'm finding this happens sometimes;
Thanks for the video, that is a new issue I have not seen. Are you able to send me the URL to the page it happens, and any more info about the conditions that may cause it? Does it resolve itself after a refresh?
 

Mangini

Well-known member
Is there any SEO Xenforo plugin than can manage this?

I'm thinking about situation where post get duplicate content on forum. For better SEO purpose forum thread needs to have canonical tag with url to original wordpress post.

For example i can refer to Xpress.

This thread URL:
have canonical like this:
HTML:
<link rel="canonical" href="https://demo.themehouse.com/xlink/wp/2018/06/29/7-examples-of-playful-weather-app-uis/">
to original post.

I'm working as s SEO Specialist and based on my expierence it can cause serious duplication content problems and ranking drops in the future.
An exciting development - XFtoWP 1.1 will also have a way to set canonical URLs with a custom field on thread creation.

I am weighing whether the "Link to existing thread" option should also be able to set the canonical URL. Any input would be appreciated!
 

thumped

Well-known member
Does 1.1 fix the encoding issue with hypens appearing as
Code:
&#8211;
and apostrophes appearing as
Code:
&#8217;
 

RoyalRumble

Active member
So the post in question does have a thread connected to it? The screenshot you posted looks like your theme default and is not markup used in the plugin, and without a thread ID XFtoWP will not alter the comments area.


Thanks for the video, that is a new issue I have not seen. Are you able to send me the URL to the page it happens, and any more info about the conditions that may cause it? Does it resolve itself after a refresh?

No worries. The video shows the refresh and yes it did have a thread connected (you see the replies show as I refresh). It only seems to happen when I'm logged in as an admin, so perhaps it's a local issue so not to worry. It's fine for everyone besides me.

My only feedback is;

1. There's no create thread option from within Wordpress.
- This doesn't really matter for me, there's the 'Link existing thread' option so I create the thread manually.
2. Load More Replies
- Seems a bit hit and miss but I know you're aware of this.
3. Option to hide 'Reply' text.
- It seems very repetitive to me on Comment View. I removed all the text 'Reply' by entering a space in 'Edit Strings' for 'reply'.

So far though all considered I'm thrilled with XFtoWP so thank you.
 
Last edited:

Mangini

Well-known member
No worries. The video shows the refresh and yes it did have a thread connected (you see the replies show as I refresh). It only seems to happen when I'm logged in as an admin, so perhaps it's a local issue so not to worry. It's fine for everyone besides me.
Possibly a plugin conflict as I have had multiple reports of similar behaviors on the AJAX request, but I have made an improvement in 1.1 that I believe better protects the XFtoWP request from other interference, so I hope we see that working better after the update!

1. There's no create thread option from within Wordpress.
- This doesn't really matter for me, there's the 'Link existing thread' option so I create the thread manually.
It seems you have the thread:write permission properly accessible, now you need to enter the IDs of forums you wish to post to in WP Admin > XF > Setup > Forums.

2. Load More Replies
- Seems a bit hit and miss but I know you're aware of this.
Thanks, 1.1 should make this far more reliable as a lot of under the hood improvements have been made.

3. Option to hide 'Reply' text.
- It seems very repetitive to me on Comment View. I removed all the text 'Reply' by entering a space in 'Edit Strings' for 'reply'.
A better way is to use this CSS in your theme or Appearance > Customize > Additional CSS

CSS:
.forum-comment-reply { display: none; }

But nice use of the Strings manager. :D

So far though all considered I'm thrilled with XFtoWP so thank you.
Very glad it can be of value to you, the best is yet to come. :)
 

Mangini

Well-known member
Mangini updated XFtoWP - XenForo to WordPress Integration with a new update entry:

Scheduled Threads, Canonical URLs, and Performance Updates in XFtoWP 1.1

Read the blog post + watch video
  1. NEW: New “schedule” button allows you to create threads when post is published manually or scheduled for later.
  2. NEW: Set canonical URL on forum (see setup guide)
  3. Call to action now consistently shows at end of comments thread
  4. Smarter comment load and refresh process
  5. Improved user settings...

Read the rest of this update entry...
 

Mangini

Well-known member
Its still missing the one of the most vital features..

Single login.
Fortunately this last release sets the stage, and while there are plenty of things I'd like to keep adding to Thread comments it is at an even more stable and functional point thanks to 1.1.

Talking about user syncing, I am building the feature based on WordPress being the master site which I think is the main use case. So when users register or change their login details later, it must be from WordPress and up to the site owner to disable these functions on the XenForo side. I believe it also possible to log users in from WP using the XF API and I will attempt to make that possible, but I consider that more of a nice to have. Does that all sound reasonable? Did I miss anything?

Brilliant update. Thank you.

Appreciate the focus on stability/reliability.

I think some bridge add-ons - certainly the two I tried - tried to do too much, too soon and it showed.
Thank you for the support, I'm glad a site as large as yours could pick up XFtoWP so easily. As you know I highly considered the tumultuous track record of similar plugins and treat reliability as the true #1 feature of this plugin. Cannot wait to keep building from here. 💪
 

Mangini

Well-known member
How does the look and feel work?
Will the XF theme become the WP’s?
Hi @interforo, thanks for your question.

XFtoWP is a complementary plugin to your existing WordPress site, meaning it brings over data from your forum and allows you to display it on your site. The most popular feature is Thread comments which allows you to connect or create new threads on XenForo and use them as blog comments on any WordPress page.

There is also a highly flexible widget built-in that let's you display different kinds of content like latest posts, featured threads, and my own favorite—a simple forum listing.

This all blends seamlessly into your existing WordPress theme and setup and allows both software's to work independently with a lightweight integration moving across them.
 
Top