XFtoWP - XenForo to WordPress integration

XFtoWP - XenForo to WordPress integration [Paid] 1.5 Release Candidate 2

No permission to buy ($79.00)

kolakube

Well-known member
kolakube updated XFtoWP - XenForo to WordPress Integration with a new update entry:

A streamlined way to create, connect, and reply to threads when you publish in WP

NOTE: During this short testing phase, XFtoWP 1.4.2 is not yet available as an official update from the Plugins panel. You can download Release Candidate 1 from your account area and manually upload the plugin zip folder to your site. Since this is not an official version, it is recommended you make a backup or install the plugin on a test site first.

Please report any feedback to the...

Read the rest of this update entry...
 

kolakube

Well-known member
Will this work with WPDiscuz commenting add-on?
Yes, you can use forum comments and WPDiscuz on the same page, or one or the other.

This plugin doesn't (yet) support posting comments from WP to XF, but forum replies refresh every 30 minutes (or your own choosing) to help keep the latest replies in WP accurate.
 

SteveCo

Member
Am I able to have my users Register with Xenforo and then it syncs with WordPress and/or it uses Xenforo as the primary user database/management?
 

kolakube

Well-known member
kolakube updated XFtoWP - XenForo to WordPress Integration with a new update entry:

XFtoWP 1.4.2 Release Candidate 2

XFtoWP 1.4.2 RC2 - until this new version is marked as fully stable and available through the plugin updater, it is recommended you test on a development site or make a full backup of your live site before using this version.

Thread comments
  • New: A more streamlined way to create, connect and reply to threads in the newly renamed "Post to forum" meta box. These actions all work the same way as before, except now you can schedule and run any action after a new...

Read the rest of this update entry...
 

HenrikHansen

Well-known member
Pre-sale question: The widgets for latest threads, is it selectable among blocks and the other widgets there, so it can be inserted anywhere at the site, post and pages?
 

kolakube

Well-known member
Pre-sale question: The widgets for latest threads, is it selectable among blocks and the other widgets there, so it can be inserted anywhere at the site, post and pages?
Hi @HenrikHansen, the widget is not Block-compatible at this time. The suggestion has been made at the plugin forums and is planned for inclusion after XFtoWP 1.5 is released.
 

Brentnauer

Well-known member
When creating a thread for a custom post type, is it possible to use a custom field? {featured_image} is there, but I have a custom image field for a "wide" image. Would be nice to be able to use something like {custom_fieldname}
 

kolakube

Well-known member
When creating a thread for a custom post type, is it possible to use a custom field? {featured_image} is there, but I have a custom image field for a "wide" image. Would be nice to be able to use something like {custom_fieldname}
This is a good idea. The plugin already has similar logic for adding custom user fields, which will also eventually be extended to custom thread fields, so this won't be hard to implement.

I've opened a suggestion thread at the XFtoWP forums just so the idea doesn't get lost in this thread:

 

kolakube

Well-known member
kolakube updated XFtoWP - XenForo to WordPress Integration with a new update entry:

XFtoWP 1.4.2 final

XFtoWP 1.4.2 is now marked as stable and available via the one-click plugin updater in your WP admin dashboard (with valid license key only). You can also download the latest version from your account area.

Please read the official changelog for a list of changes and enhancements in this new version. There are no notable changes between 1.4.2 RC2 and 1.4.2 stable.

Thank you for your continued...

Read the rest of this update entry...
 

BT-Simon

Member
Hi,

I have the problem that the automatic thread creation does not work properly. I always create German language posts first and then the English language ones. I don't see the option to automatically create threads for the German-language ones, but I do for the English-language ones. I use Polylang Pro. I would be happy if this is fixed in a timely manner.

Thanks and best regards
Simon
 

mexl

Member
Hi,
first of all thank you for your product. This is a pre sales question...
We use Digimember as a Wordpress Membership Solution (as we sell via digistore24). Do you have any knowledge if the User Syncing between WP and Xenforo will work in this case?
Second question: Unfortunately the usernames are the email-addresses now (coming from Digimember)... This means, when syncing they would be visible in the forum. So do you see any workaround in such a scenario?
Tnx,
Matt
 

kolakube

Well-known member
My apologies @BT-Simon and @mexl I somehow overlooked your messages here.

I have the problem that the automatic thread creation does not work properly. I always create German language posts first and then the English language ones. I don't see the option to automatically create threads for the German-language ones, but I do for the English-language ones. I use Polylang Pro. I would be happy if this is fixed in a timely manner.
Does Polylang Pro create a custom post type for posts? If so, you can easily add CPT support with this filter:


We use Digimember as a Wordpress Membership Solution (as we sell via digistore24). Do you have any knowledge if the User Syncing between WP and Xenforo will work in this case?
Thank you for your questions!

I haven't heard of Digimember but XFtoWP taps into common WordPress registration and user hooks so there is a high likely of basic syncing actions working. To add full integration, including during checkout, some minor development will need to be done but is something I can work with you to achieve as XFtoWP is built with plugin integrations in mind.

Second question: Unfortunately the usernames are the email-addresses now (coming from Digimember)... This means, when syncing they would be visible in the forum. So do you see any workaround in such a scenario?
That's interesting because WordPress requires a username when a new user is created. Does this plugin use the expected WP users system (WP admin > Users), or create its own?
 

BT-Simon

Member
@kolakube I don't think that this is the issue. I can see the meta box, but for german language posts I can only active the auto-post when they are already shedulded (and then of course I have to safe them again). English language posts are always in auto mode, so I hit publish and the post is created.

Btw: I also sent you a mail because of the invoice, would be great if you check that soon.
 

kolakube

Well-known member
@kolakube I don't think that this is the issue. I can see the meta box, but for german language posts I can only active the auto-post when they are already shedulded (and then of course I have to safe them again). English language posts are always in auto mode, so I hit publish and the post is created.
I don't quite understand the problem. I downloaded the Polylang free version and just ran some tests on my dev site. All of the translation posts were created with auto publish activated, including waiting for the scheduled post. If you can provide me with exact steps to replicate the issue I can be of more help.

Screen Shot 2022-02-25 at 2.35.23 PM.png

Btw: I also sent you a mail because of the invoice, would be great if you check that soon.
I'll send that over to you now.
 

BT-Simon

Member
Hi Alex,

I think I was able to narrow down the problem further. When I create a new post, "auto-create thread" is preselected. However, not for the posts that my collaborators submit for review. Instead, "select a thread action" is selected there. And I can't even switch to "auto-create thread".

1645824121713.png
editors contribution

1645824203072.png
when I create a new post
 

El Porcharo

Well-known member
View attachment 265314
when I create a new post
Well I don't have "Auto-create thread" either, but I also never seen "Do nothing" if I recall well.

Don't know why...

Also, I wanted to do some testing on my own on my test site, and I found out that "Create new thread" is gone, while it's still there on my live site. (my test site is a clone of the live site from a couple of months ago)

TEST SITE:

1645832351239.png

LIVE SITE:

1645832415021.png

@kolakube if you wish to investigate I can give you access to my test site, where you can mess up as long as you like 😅
 
Top