• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
[Tinhte] HTML5 Uploader (Unmaintained)

[Tinhte] HTML5 Uploader (Unmaintained) 1.0.3

No permission to download

dihuta

Formerly Dinh Thanh
#1
Dinh Thanh submitted a new resource:

[Tinhte] HTML5 Uploader - HTML5 Multiple File Uploader for Xenforo

FEATURES
  • Using HTML5 for Multiple Uploader (No Flash Player Required)
  • Support Drag & Drop
  • Works with all xenforo multiple file upload fields and almost third party addons.
NSTALLATION
  • Download & Unzip
  • Upload all files & folder in /upload folder to forum root
  • Import XML File. Done! (Nothing to config)
CREDITS
  • Plpload for HTML5 upload library.
  • xfrock, who develops this product...
Read more about this resource...
 

Chris D

XenForo developer
Staff member
#4
@Mike @Kier

Wouldn't usually like to tag you but so far, from what I've seen of this library, it's a very worthy successor to swfupload. It even allows multiple file uploads from iOS which is a huge improvement over the default behaviour of single file uploads via the input[type=file] button.

Thank you for sharing this @Dinh Thanh.

@xfrocks I appear to have some difficulty getting it to work properly on iOS.

I had my add-on Quick Reply Preview enabled initially. This adds an additional button alongside the default 3 buttons on the Quick Reply editor. Pressing the Upload a File button on iOS with my add-on enabled (it's fine on desktop), results in no file selection screen coming up. Turns out the trigger for the uploader is there, but it isn't sitting over the Upload a File button. On my site, http://xenmediagallery.com I have to press in the white space below More Options for the uploader to activate.

So I thought that was solely down to my Quick Reply Preview add-on being enabled, so I disabled it. However, that still does not resolve the issue. Pressing the Upload a File button does nothing. The difference is, however, I can't find where the trigger for the uploader has gone to. So it appears as though it isn't working correctly on iOS. I disabled ALL add-ons and it is still not working correctly on iOS.

Great worth with this, look forward to being able to use it fully. I will leave the Quick Reply Preview add-on and yours enabled so you can test it if you have an iOS device. (I tested with iPhone 5s running iOS 7.1.1)
 

RoldanLT

Well-known member
#10
What about this option on Admin Options?
Use Flash Uploader
Using the Flash uploader allows those visitors with Adobe Flash installed to select multiple files to upload once, and to see a progress meter during the upload.
 

Chris D

XenForo developer
Staff member
#17
I think you're on to a good thing here. Not entirely convinced by the library being used seeing as it has some incompatibility with mobile devices, but I'm sure these issues will either be fixed by the developers of that library eventually or there will be a better one out there.
 

MattW

Well-known member
#18
another bug with this:

upload_2014-5-4_13-51-10.png

The Upload a File button is being triggered when hitting the Preview button as well. Going to un-install this for a while I think.