s9e Media BBCodes pack

s9e Media BBCodes pack 20180907

No permission to download
After posting here I tried just entering the url into the body of the message like I did in my first post (rather than using the image drop down from the tool bar) on my site and Imgur images load just fine. What does not work is the image drop down box with Imgur images when using this add on. Is this something new? In the past, we've always had to use the tool bar to insert images that weren't being uploaded directly. I think this is what has caused our confusion...
 
Last edited:
Hi.
I have the following problem.
When somebody post a video from youtube and other quotes him the height of the iframe goes over the quote block


I realized there a max-width in 640px



Thanks for advanced!
 

JoshyPHP

Well-known member
I don't know what Viuly is but if you're interested in sponsoring the development of a custom add-on for it, I can look into it.

When somebody post a video from youtube and other quotes him the height of the iframe goes over the quote block
That seems like a styling issue. Notify the style authors and there's a good chance it'll be fixed using CSS.

I want to enable https on my board, but that means I have to manually edit all bb-codes that aren't https from the get-go. Is there a way to do this in bulk?
No, there's no such option. All of the media site definitions use either HTTPS URLs or protocol-relative URLs, which means that all embeds will use HTTPS on a HTTPS site, but some external sites may not support HTTPS at the moment.
 
When somebody post a video from youtube and other quotes him the height of the iframe goes over the quote block
That seems like a styling issue. Notify the style authors and there's a good chance it'll be fixed using CSS.
Similar issue for us using default styles, but the YouTube embeds overflow even in the first quoted message. This issue was introduced after installing a recent update to the add-on.

Screenshot 2018-03-23 13.59.53.png
 

JoshyPHP

Well-known member
@Gene @Glats Try the latest update. It fixes this issue on my local board but it may also have unintended side-effects that makes it unsuitable. You can revert the change by disabling the template modification named s9e_quote_collapsed_css

I'm not sure whether there's a silver bullet here. At the time I'm writing this, the default style suffers from the same issue, although I can't reproduce it reliably for some reason.

 

JoshyPHP

Well-known member
Potentially none of the above. HTML doesn't provide anything to support responsive iframes so they're implemented using dubious CSS hacks involving proportional padding and repositioned elements. Chrome and Firefox disagree on how to apply overflow to absolutely-positioned elements and I don't know which one is right. (edit: most browsers side with Firefox so it's probably a Blink issue)

So it's either a Blink issue or the natural consequence of not having the right tools for the job and having to make do with what we have. Both XenForo 2.0's default media sites and this add-on's use the same CSS technique, that's why both are affected.
 
Last edited:
Top