• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
s9e Media BBCodes pack

s9e Media BBCodes pack 20180215

No permission to download

JoshyPHP

Well-known member
Yes, I've just updated the hosted iframe that handles Imgur albums. There's a discrepancy between how XF1 and XF2 handle some characters such as the backslash / that caused the URL to be incorrect. Fortunately that's something that can be fixed on my side without updating the add-on.
 
Hello! I wanted to say thank you for this add-on and for the hard work. I noticed something strange on my side.

This Imgur link: https://imgur.com/gallery/i7LLj62 works fine without the /gallery/. However, when I insert the full link, it shows up broken.

See my example here: https://niketalk.com/threads/posting-images.666903/

Do you have a solution for this? Thank you in advance!

Edit: I forgot to put that we're still on XF1.
 

JoshyPHP

Well-known member
Do you have a solution for this?
Yes, but it's not a good one. Imgur has made it impossible to distinguish single images from albums based on their URL, and their oEmbed point requires authentication. It complicates a number of things and it's hard to preserve backward compatibility while ensuring forward compatibility.

I've just updated the hosted iframe so images should work as expected now.
 
Yes, but it's not a good one. Imgur has made it impossible to distinguish single images from albums based on their URL, and their oEmbed point requires authentication. It complicates a number of things and it's hard to preserve backward compatibility while ensuring forward compatibility.

I've just updated the hosted iframe so images should work as expected now.
I see. So I noticed something after you made the push.

This image here is not supposed to the grateful dead bears. If you click through on it, it takes you to Imgur where it's Matt the Radar Technician / Kylo Ren's skit on SNL: https://niketalk.com/threads/posting-images.666903/#post-29522495

Same with this one: https://niketalk.com/threads/posting-images.666903/#post-29522539 the embedded preview is not the same as the image you get when you click through.

Sorry for being a pain, I hope this is fixable.
 

JoshyPHP

Well-known member
@Raitsa Theoretically could but that's not something I would include by default because of the relatively small audience of the site and because Brightcove-based video services add to the add-on's upkeep / maintenance cost. If the site is important enough to you that you'd want to sponsor its addition, you can send me a pm and I'll look into it.
 

JoshyPHP

Well-known member
@colcar My best guess is that they are probably just testing something that doesn't work. If I go to the Imgur page and try the embed code that they give directly, it doesn't work either. I expect it will get fixed at some point in the near future.