Font Awesome Manager

Font Awesome Manager 1.2.3.1

No permission to download

duderuud

Well-known member
 

Kirby

Well-known member
Why don't you support XF 2.1 ? :(
The way Font Awesome is implemented in XenForo 2.1 is quite a bit different from XenForo 2.2, therefore the existing code does not (fully) work with XenForo 2.1.
So far I think nobody really needed support for 2.1, so I wasn't really bothereed to to that extra work to make it compatible.

That being said, it's not totally impossible - in fact I started very early development of this Add-on on 2.1 so it might not be too much effort to backport that support code.

I'll take a look into that, but please keep in mind that XenForo 2.1 has been EOL for quite some time already.

I tried a lot but the installation didn't work..do you have a clear way
Do you have root access?

If so it isrecommended to install pyftsubset systemwide, instructions for Debian/Ubuntu/CentOS (which should cover most cases) can be found in the FAQ.

If not but your server is running Linux x64 you might be able to use the precompiled binary that @duderuud mentioned already.

If none of those option does work you might be a bit SOL (for now).

Why don't you make transfonter to support xF and xF to support 2.1?
I don't have control over what transfonter.org does as it is a 3rd party webservice, so I can't do much in this regard.
 

Mr. Jinx

Well-known member
Maybe it's time to remove that option from this addon entirely?
No, please keep it!
It is the only option if you are on XFCloud. Although I don't like to cheat with the user agent, it is a the only way for now :(
 
  • Like
Reactions: rdn

Kirby

Well-known member
It is the only option if ...
That's pretty much the reason why I am a bit hesitant to remove this processor (right now).
I don't have access to XF Cloud, so I can't test myself - did you check if the precompiled pyftsubset binary does work?
 

rdn

Well-known member
However, they told me this functionality will be in XF 2.3 ;)
Excited Season 2 GIF by The Office
 

zoldos

Well-known member
That's crude, many people still using XF 2.1 even XF 2.0, they may can't upgrade for many reasons. Lots of good addons only support limited version like 2.0-2.1 but not 2.2 because they dropped, or the upgrade may cause lots of bugs and errors and they don't know how to handle it, once upgrade xf 2.2, lots of things to do, like upgrade php, nginx, mariadb, many outdated things but need to update to work with xf 2.2 but many people they don't really know technical things, code, etc...
Just saying...
It's always best to use the latest versions of scripts and programs, yes? I know I do.
 

Kirby

Well-known member
Kirby updated Font Awesome Manager with a new update entry:

1.2.2 - First Anniversay Bugfix Release

About one year ago I published the first public release of this Add-on (after about two years fully private development and some months closed beta testing).

Within that one year Font Awesome Manager seemingly has become somewhat popular and is now one of the Top 50 XenForo 2 Add-ons (ranked by the number of downloads) :)
I am happy that this Add-on seems to be useful for many users.

So today I am publishing another bugfix / maintenance release to celebrate its first anniversay.

Thanks...

Read the rest of this update entry...
 

Kirby

Well-known member
Relating to https://xenforo.com/community/threads/d-c-style-thread-icon.206913/post-1580412
Hello, i installed this add-on but with the FAM add-on by @Kirby most of the icons doesn't appears, how to manage that ?
It seems that the sub-sets are not updated. Thanks.
The Add-on is incompatible with FAM and there is basically nothing that really could be done to make it compatible:

It does allow users to choose any FA icon for a thread which means that all FA icons must be available for the chooser as well as all icons there are currently in use for any thread must be avialable (at leasst on all pages where those thread icons are being displayed).

While it would be theoretically possible to monitor icon usage and update subsets accordingly, this IMHO doesn't make much sense - over time you would end up with a pretty large subset (of icons that are used seldom).

So for now the only options are:
  1. Do not use Font Awsome Manager
  2. Do not use D.C Style - Thread Icon
  3. Disable option Load subsets only
    This will significantly increase CSS size (as it causes all icon definitions to be included), but should only load full Font Awesome font files (additionally to the subset files!) if they are required, e.g if the current page does use icons that are not included in the subset.
In a future version of Font Awesome Manager it might be possible to optimize this a bit further so the full icon definitions are only loaded on pages that do make use of icons not included in the subset.

But that would also require a slight change to the other Add-on so it does use standard templater function fontAwesome to generate the HTML (instead of doing its own magic to achieve basically the same thing).
 
Top