Font Awesome Manager

Font Awesome Manager 1.2.3.1

No permission to download

Betclever

Well-known member
I am sorry, but I don't know what you are talking about.

Please read the FAQ on ""How can the Add-on be configured?" and "What are the recommended settings?"

If you can't figure it out yourself please follow the steps outlined in "I've tried everything, but icons are still missing. How can I get help?"

I already read it.

1637150722965.png
 

Kirby

Well-known member
I unfortunately still don't understand as to what kind of help you do need exactly?

493 KB fonts might be correct or it might indicate a configuration problem, I can't answer this without knowing your website URL.
 
Last edited:

Mouth

Well-known member
At /admin.php?bb-codes/ I have an entry for font awesome ...

Screen Shot 2021-11-24 at 09.26.23.png

An example heavy usage of the above is within a Resource Manager (RM) item, eg. [FA_ICON="blue"]question-square[/FA_ICON]

I found that this add-ons automatic detection ( Build Mode: Automatic ) didn't include these ( I added them manually ). Is the intention that it should have picked them up? If not, is there an adjustment I can make to the bb code so that it would/will pick them up and include them?
 

tajhay

Well-known member
trying to install to the latest version from 1.2.0 RC2 and get the following error:
TypeError: Return value of Kirby\FontAwesomeManager\Helper::getCache() must be of the type array, null returned in src/addons/Kirby/FontAwesomeManager/Helper.php at line 77
  1. Kirby\FontAwesomeManager\Helper->getCache() in src/addons/Kirby/FontAwesomeManager/Setup.php at line 105
  2. Kirby\FontAwesomeManager\Setup->upgrade1020054Step1() in src/XF/AddOn/StepRunnerUpgradeTrait.php at line 124
  3. Kirby\FontAwesomeManager\Setup->upgradeStepRunner() in src/XF/AddOn/StepRunnerUpgradeTrait.php at line 73
  4. Kirby\FontAwesomeManager\Setup->upgrade() in src/XF/Admin/Controller/AddOn.php at line 597
  5. XF\Admin\Controller\AddOn->actionUpgrade() in src/XF/Mvc/Dispatcher.php at line 352
  6. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
  7. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
  8. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
  9. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2345
  10. XF\App->run() in src/XF.php at line 512
  11. XF::runApp() in admin.php at line 13

Even if i disable it it has an action pending, so hits that error if i try to install/other addons. Any fix for it?
 

Kirby

Well-known member
I found that this add-ons automatic detection ( Build Mode: Automatic ) didn't include these ( I added them manually ). Is the intention that it should have picked them up?
It should automatically detect the used icon font-awesome-flag.

However, as this BB-Code does allow users to use any icon, those will not be detected automatically as this IMHO would not make much sense - over time the list could grow to the entire glyph set effectively making pre-compiled subsets useless.

For your (edge) usecase there are currently 3 options:
  1. Limit the amount of icons that can be used (probably requires a callback handler) and add the allowed icons to the appropriate list
  2. Disable option Load subsets only and disable style property Include CSS for selected weight only if you are not using Solid as main weight. This does increase CSS size significantly (it will be even larger than without this Add-on), but would allow you to use the subset fonts on pages that do not use this BB Code. Pages that do use it for icons not included in the subset would load the full font file additionally to the subset.
  3. Do not use Font Awesome Manager
I'll have to think about your usecase a bit to see if there might be approaches to help this, but for now I think those are only options. If possible I'd try to go for option 1).
 

tajhay

Well-known member
I really wonder where you got that version from ...
It was never released publically and AFAIK you were not part of the beta test group?

Anyway, try to manually perform a rebuild - this should fix the error.
If it does not try Uninstall & Install.
Hmm interesting. I dont believe i was part of a beta group nor would have got the version from anywhere other than here. Weird!!

Unfortunately only able to 'Upgrade' which then hits the error, or 'Enable' or 'Disable'. All of them still say 'action pending' and cant seem to do a manual rebuild without hitting the error. Unable to uninstall & install again too.
 

Kirby

Well-known member
Hmm interesting. I dont believe i was part of a beta group nor would have got the version from anywhere other than here.
Yeah, I guess I am already a bit tired - forget that part, it's wrong. Sorry.

All of them still say 'action pending' and cant seem to do a manual rebuild without hitting the error.
You get that error when you go to admin.php?tools/rebuild and execute Rebuild Font Awesome subsets?
 

Nirjonadda

Well-known member
@Kirby What is the path to the directory 'pyftsubset'?

Code:
[root@na ~]# pip --version
pip 21.3.1 from /usr/local/lib/python3.6/site-packages/pip (python 3.6)
[root@na ~]# locate pyftsubset
-bash: locate: command not found
[root@na ~]#

ScreenShot00432.png
 
Last edited:

Nirjonadda

Well-known member
Before we have installed pyftsubset and fonttools with this Code for CentOS 7 but this SSH command no more working for AlmaLinux v8.5.0 or CentOS 8

Code:
sudo yum iinstall python36
sudo yum install rh-python36
scl enable rh-python36 bash

and this path to the directory 'pyftsubset' for CentOS 7 installation.

Code:
/opt/rh/rh-python36/root/usr/bin/pyftsubset

Now I have installed Python 3 with AlmaLinux v8.5.0 and Does this correct installation pyftsubset?

Code:
[root@na ~]# yum install python3-pip
Last metadata expiration check: 2:18:41 ago on Sun 28 Nov 2021 09:05:04 AM EST.
Package python3-pip-9.0.3-20.el8.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@na ~]# pip3 install fonttools
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Requirement already satisfied: fonttools in /usr/local/lib/python3.6/site-packages (4.27.1)
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
[root@na ~]# pip3 install fonttools[woff]
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see https://github.com/pypa/pip/issues/5599 for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
Requirement already satisfied: fonttools[woff] in /usr/local/lib/python3.6/site-packages (4.27.1)
Requirement already satisfied: zopfli>=0.1.4 in /usr/local/lib64/python3.6/site-packages (from fonttools[woff]) (0.1.9)
Requirement already satisfied: brotli>=1.0.1 in /usr/local/lib64/python3.6/site-packages (from fonttools[woff]) (1.0.9)
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
[root@na ~]# pip --version
pip 21.3.1 from /usr/local/lib/python3.6/site-packages/pip (python 3.6)
[root@na ~]#

What is the path to the directory 'pyftsubset' we need use? Here showing 3 directory?

Code:
[root@na ~]# find / -name pyftsubset
find: ‘/proc/57583’: No such file or directory
/usr/local/bin/pyftsubset
/home/virtfs/nadda/usr/local/bin/pyftsubset
/home/virtfs/nmela/usr/local/bin/pyftsubset
[root@na ~]#
 

Kirby

Well-known member
@Kirby What is the path to the directory 'pyftsubset'?
pyftsubset is an executable/binary file, not a directory.

On our servers the path is /usr/bin/pyftsubset, but might be different on your server - contact your host or server administrator for support if you do not know the path.

I can't tell you where it is located on your sever as I don't know your environment/setup and I don't use any RPM-based dsitributions (like RHEL, CentOS, AlmaLinux, Fedora, etc.).

Where can add Duotone Icons? I can only add for Icons, Solid Icons, Regular Icons and Light Icons.
You can't. Duotone icons are currently (might change in future versions) only supported via the main icons list.
 
Last edited:

Frode789

Well-known member
Thank you for this wonderful addon.

I would like to add additional entries (addons) to be scanned for icons. Got lots of icons missing, Automatically add missing Icons didn't seem to help.
ozzmodz_badges
Social Groups
Premium Page
etc.

For example [OzzModz] Badges. How would I format that into the "additional entries" field?

Tried to debug. All the icons show in the error log here
1638206424705.png
Can I just paste those names (bell, book etc) into the icons area in settings for FA manager?
 

Kirby

Well-known member
Thank you for this wonderful addon.

I would like to add additional entries (addons) to be scanned for icons. Got lots of icons missing, Automatically add missing Icons didn't seem to help.
ozzmodz_badges
Social Groups
Premium Page
etc.
I don't specifically know those Add-ons, but unless they are doing smth. that is a bit unusual (like using hardoded icons in JavaScript files) icons should be detected automatically (if they are being used in main weight, won't work if they are used in different weights).

Unless Add-ons or Styles are doing things that are even more unusual, enabling Option Automatically add missing icons for some time (a few minutes at least) should take care of missing icons.

If this sill does not work please read FAQ section "I've tried everything, but icons are still missing. How can I get help?" and act accordingly.

Adding additional entities for automatic scanning does require information from the respective authors, so you would have to ask for the entity and field names where tohose Add-ons to stroe FA icons.

The log (except) you've posted does show icons that are included in the main subset.
You could take the icon names (eg. the array keys) and pste tose into the Icons option, however this would not make any sense - those icons are already in the subset anyway (otherwise they would not appear in the log).
 
Last edited:

Frode789

Well-known member
Thanks. I will use it a bit more and then compile a list of icons missing afterwards.

Btw. Installed fonttools. It askes for path to pyftsubset executable in addon settings.
I enter path, and it says it cannot be found there. I see the exec in my Filezilla in that folder. What is the correct entering of the path/URL? Probably a slash or something messing with it.
 

Kirby

Well-known member
What is the correct entering of the path/URL?
I just answered this question 3 posts before you asked it again ...
TL;DR I don't know the path where pyftsubset is installed on your server - it is your server.
If you do not know the correct path ask your server administrator for help.

Common paths are /usr/bin/pyftsubset (for example on Debian based distributions if fonttools is installed via apt) and /usr/local/bin/pyftsubset (seems to be common on CentOS)
 

Frode789

Well-known member
TL;DR I don't know the path where pyftsubset is installed on your server - it is your server.

Obviously... I didn't ask for the path, I asked for the correct formating. I know where the file is.. Which I see now includes the pyftsubset in the path itself. I didn't have that.
 

Kirby

Well-known member
Yes, it's the full path to the executable/binary - I thought this was obvious (especially as the placeholder text is /usr/bin/pyftsubset).

This is somewhat consistent with executable/binary path setting for FFmpeg in XenForo media gallery:
Enter the path to the FFmpeg binary on this server. You can sometimes find this with the command which ffmpeg.

If you have a suggestion for better phrasing please let me know :)
 
Last edited:
Top