Font Awesome Manager

Font Awesome Manager 1.2.1

No permission to download

Kirby

Well-known member
Do you think that you will be able to release a version that works for UI.X 2 for Material Design?
Depends on what what you consider "works with UI.X 2 for Material Design":
This Add-on does manage Font Awesome fonts, this does also work with UI.X 2 if configured accordingly - the Add-on however does not manage Material Design Icon fonts.

This might be smth. that can be added ia a future major version, but due to limited time resources it will take quite some time.

Also, I installed "apt install fonttools" but after installation I can't find any path to "pyftsubset".
"pyftsubset" should be somewhere in usr/bin, correct?
I assume you are using Debian / Ubuntu (or another distribution based on Debian)?

Usually pyftsubset should be /usr/bin/pyftsubset, if it is not you'de have to find out where it is.

find pyftsubset or dpkg -L fonttools might help you.
 
Last edited:

Kirby

Well-known member
I checked the source of the page and see this:
Code:
<style></style>
<style>@font-face{font-family:'Font Awesome 5 Pro';font-style:normal;font-weight:300;src:url(about:blank)}.fal{font-family:'Font Awesome 5 Pro';font-weight:300}</style>

I also see that the error only happens when logging level is set to Info :) 👍
This is a placeholder font that is being used to detect missing icons in case no icons are defined for a specific FA weight (like Light in this case, this is not being used at all with XenForo default style).

Apart from the error being logged in console (which can be safely ignored) this does not cause any issues.

Will be fixed in 1.2.0 though.
 

Kirby

Well-known member
Kirby updated Font Awesome Manager with a new update entry:

1.2.0 Release Candidate 5

Bugs Fixed​

  • Added missing phrase kirby_fam_invalid_entity
  • Added missing phrase kirby_fam_pyftsubset_path_empty

New Features​

None

Other Changes​

  • Added icons eye and eye-slash to the list of regular icons
  • Default value for style property Enable Duotone icons is now Disabled
    If duotone icons are being used and the property has not been customized so far, this needs to be done after upgrading to this version
  • Set various options (like ignored templates, etc.) as Advanced, so they will now only be shown when displaying Advanced Options
  • Icon names entered in options...

Read the rest of this update entry...
 
Last edited:

Kirby

Well-known member
It's been quite a while since the first public release of this Add-on and so far it seems to work witthout any (major) issues.

I've therefore removed the Beta prefix and released 1.2.0 as the first stable version :)
 
Last edited:

easiii

Well-known member
Hello @Kirby,
I get this error when trying to upgrade from RC3 to Stable

Code:
TypeError: Return value of Kirby\FontAwesomeManager\Helper::getCache() must be of the type array, null returned in src/addons/Kirby/FontAwesomeManager/Helper.php at line 77
Kirby\FontAwesomeManager\Helper->getCache() in src/addons/Kirby/FontAwesomeManager/Setup.php at line 105
Kirby\FontAwesomeManager\Setup->upgrade1020054Step1() in src/XF/AddOn/StepRunnerUpgradeTrait.php at line 122
Kirby\FontAwesomeManager\Setup->upgradeStepRunner() in src/XF/AddOn/StepRunnerUpgradeTrait.php at line 71
Kirby\FontAwesomeManager\Setup->upgrade() in src/XF/Admin/Controller/AddOn.php at line 583
XF\Admin\Controller\AddOn->actionUpgrade() in src/XF/Mvc/Dispatcher.php at line 350
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 257
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 113
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 55
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2326
XF\App->run() in src/XF.php at line 488
XF::runApp() in admin.php at line 13


And this >

One or more add-ons currently have actions pending and may be in an inconsistent state. Because of this, some errors may be suppressed and unexpected behavior may occur. If this does not change shortly, please contact the add-on author for guidance.
 

BassMan

Well-known member
After updating to stable 1.2.0 the Duotone icons won't load. I rebuild subsets and empty caches, but still nothing.
 

Kirby

Well-known member
I think I did, yes.
Do you think so or did you do this? ;)
Anyway, try to perform a manual rebuild and re-try the upgrade afterwards.

After updating to stable 1.2.0 the Duotone icons won't load. I rebuild subsets and empty caches, but still nothing.
Which version did you upgrade from?

Did you check if duotone icons are enabled in the style properties?
This style property is disabled by default since 1.2.0 RC 5, if you never explicity enabled that style property it will be disabled.
https://xenforo.com/community/resources/font-awesome-manager.8407/update/39976/
 
Last edited:

Marcus

Well-known member
Works, totally amazing.

For the install, first I installed on centos 7 the first stuff on root (and got the "better do this at user-level"), the second stuff on user level. No error messages there. But the addon didn't work. I installed the second needed programs at root level (sudo ....) and the addon works perfectly! It fetches my added font awesome icons automatically. This is so cool !
 

Marcus

Well-known member
There was no need to, but i clicked on "rebulid: rebuild font awesome". After that the branded icons (whatsapp, facebook, twitter) and some icons I added were not visible any more (also removed from the <i ....> tag). I deactivated the addon, it was all working. When I activated the addon, it didnt work. I deinstalled it where the files were deleted, reinstalled it by uploading the addon again: still not working.

Guess something in the "rebuild" makes the addons "wizard effect of adding all the right addons automatically" make go away :)
 

Marcus

Well-known member
There was no need to, but i clicked on "rebulid: rebuild font awesome". After that the branded icons (whatsapp, facebook, twitter) and some icons I added were not visible any more (also removed from the <i ....> tag). I deactivated the addon, it was all working. When I activated the addon, it didnt work. I deinstalled it where the files were deleted, reinstalled it by uploading the addon again: still not working.

Guess something in the "rebuild" makes the addons "wizard effect of adding all the right addons automatically" make go away :)
It works now when I manually add the icons and set the style setting to "embed" the icons instead of lazy load or the other option :) Awesome addon! I got 100% on google pagespeed insights for desktop with that yesterday.
 

Marcus

Well-known member
It was a server misconfiguration on my part (that obviously only was visible after I rebuild the font awesome icons in the rebuild section - befor eit worked even with my misconfigurated server): the nginx user (first line) was not the php-fpm user. After changing the nginx user to the php-fpm user, it works. Flawless!
 

Kirby

Well-known member
I don't know exactly what you are talking about @Marcus, but if it works for you: :)

Normally, it should not be necessary to run the webserver as the same user running PHP-FMP; in fact I would recommend not doing this.
What is necessary is that the webserver can read the generated .woff/.woff2-Files, but that should be the case.

Can you check the owner and the permissions on styles/fonts/fa/*.min.woff2?
The owner should be the user running PHP and the files should be world readable.
 
Last edited:
Top