Resource icon

Chat 2 by Siropu [Paid] 2.0.8

No permission to buy (€29.99)

Siropu

Well-known member
Try this instead:
CSS:
.siropuChatMessageText .bbMediaWrapper, .siropuChatMessageText .bbMediaJustifier
{
     width: 300px !important;
}
 
To put the second code that you gave me in extra.less and modify the 300px?
Because when I did that I did not see any change.
As a reminder, it is the MEDIA included in the instructions
 

Kevin

Well-known member
Bug or did I miss a setting? :unsure:

I did a fresh install of Chat 2.0.2 on XF 2.0.1 and gave the groups permissions & set some basic options. To mimic my XF1 Chat environment, where I only have one general room that everything takes place in, I turned off the option "Enable Rooms".

The problem is that with that option turned off when I try to use Chat I get the error that "You haven't joined any rooms." even though rooms are not enabled. I tried a mix of things like making sure the default room is enabled in the ACP (even though rooms aren't being used) but it seems like no matter which options I try I get that error while "Enable Rooms" is turned off.
 

Siropu

Well-known member
To put the second code that you gave me in extra.less and modify the 300px?
Because when I did that I did not see any change.
As a reminder, it is the MEDIA included in the instructions
After you place the code, please provide a test account to see what's going on.

Will look into it.

@Kevin, this is probably affecting only you and not all your users. That's because you have set to join default room after you changed your settings from front-end. Even if "Enable rooms" is disabled, it is still using a room to chat (general room) but doesn't allow creating or joining more rooms. I will make some changes to auto-join all users if rooms are disabled and no room is set as default joined.
 
After you place the code, please provide a test account to see what's going on.


Will look into it.

@Kevin, this is probably affecting only you and not all your users. That's because you have set to join default room after you changed your settings from front-end. Even if "Enable rooms" is disabled, it is still using a room to chat (general room) but doesn't allow creating or joining more rooms. I will make some changes to auto-join all users if rooms are disabled and no room is set as default joined.
Actually it works well your second code but only in the media published in the chat not in the media in record
 

Kevin

Well-known member
@Kevin, this is probably affecting only you and not all your users. That's because you have set to join default room after you changed your settings from front-end. Even if "Enable rooms" is disabled, it is still using a room to chat (general room) but doesn't allow creating or joining more rooms. I will make some changes to auto-join all users if rooms are disabled and no room is set as default joined.
Thanks, Siropu. I did try going into the ACP and making sure I had the "general chit-chat" room selected as the default but it still made no difference. For now my XF2 is still in my test area so it's not a major thing and when I do migrate the live site I can live with turning rooms on & only having one room if necessary, just wasn't sure if I had missed something with the settings. :coffee:
 
Just installed it on a development site where I am changing over to Xenforo 2x using Xenporta 2x. Everything seems to be working well, but what do I do about this that is now populating my error log even though the chat is idle?

PHP:
     ErrorException: [E_NOTICE] Undefined index: disable src/addons/Siropu/Chat/Widget/Chat.php:91
Code:
Stack trace

#0 src/addons/Siropu/Chat/Widget/Chat.php(91): XF::handlePhpError(8, 'Undefined index...', '/home/saintsre/...', 91, Array)
#1 src/XF/Template/Templater.php(1522): Siropu\Chat\Widget\Chat->render()
#2 src/XF/Pub/App.php(438): XF\Template\Templater->widgetPosition('pub_sidebar_top')
#3 src/XF/App.php(1724): XF\Pub\App->renderPageHtml('\n\n\n\n\n\n\n\n\n\t\n\t\n\t\n...', Array, Object(XF\Mvc\Reply\View), Object(XF\Mvc\Renderer\Html))
#4 src/XF/Mvc/Dispatcher.php(310): XF\App->renderPage('\n\n\n\n\n\n\n\n\n\t\n\t\n\t\n...', Object(XF\Mvc\Reply\View), Object(XF\Mvc\Renderer\Html))
#5 src/XF/Mvc/Dispatcher.php(44): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#6 src/XF/App.php(1889): XF\Mvc\Dispatcher->run()
#7 src/XF.php(328): XF\App->run()
#8 index.php(13): XF::runApp('XF\\Pub\\App')
#9 {main}
PHP:
Request state

array(4) {
  ["url"] => string(29) "/community/index.php?members/"
  ["referrer"] => string(49) "https://blog.saintsreport.com/community/index.php"
  ["_GET"] => array(1) {
    ["members/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 

Siropu

Well-known member
I have looked into it and it is a bug with admin option "Disable chat" under "Default miscellaneous settings". The value should be "disable" but there it is "disabled".

It will be fixed in the next release.
 

Siropu

Well-known member
Try this:
Code:
.p-navEl .fa-iconname
{
     margin-right: 5px;
}
Replace iconname with the Font Awesome icon name you are using.
 
Top