• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

https

  1. M

    XF 1.5 Switching to HTTPS Issue

    I'm having issues switching over to https. I have went through every option to make sure I do not have "http://" set anywhere in my modifications (templates / css / settings). Then I changed : Options > Basic Board Information > Board URL to "https://" This is what Firefox is showing me when...
  2. vFranky

    XF 1.5 Going to https

    Hello, some big players in the internet want to push websites to the usage of https. Googles signales better rankings for https and the Firefox browser actually warns "attention, non secure website" when users are in the XenForo login form. My Question: What do I have to do (technically) to...
  3. B

    XF 1.5 change http to https in posts (sql?)

    hi i move my site to https the think is that i have more than 600 url in the posts of my forum that still refer to old url http:// whats is the best method to remplace url in posts that point to my site with http (to https) can i do sql find and replace url in database? how? thank you for...
  4. Live Free

    Made the move to HTTPS: a few questions ensuring correct implimentation

    I made the move to HTTPS a few days ago after doing a lot of research online and following Brogan's HTTPS conversion guide. I do have a few remaining questions I hope someone would shed some light on. 1. A few default Xenforo templates reference a few external http:// links. I don't think...
  5. polle

    XF 1.5 Https not working

    Hello, I moved my site to https and I have some problems. (XenForo 1.5.12) https://site.com - works fine https://site.com/forum - does not work (here is Xenforo installed) I already changed the board URL and added the following to htaccess. RewriteCond %{HTTPS} off RewriteRule ^...
  6. R

    XF 1.4 Switched to https, [ATTACH] still linking to http

    Hi there, I recently switched my site over to https, however I notice that attachment images are still being linked via http, causing mixed-content errors. I haven't done any edits to the `bb_code_tag_attach` template. It seems like {xen:link full:attachments, $attachment} is at fault. Could...
  7. Robert Waanders

    Other Convert Xenforo to https

    Hello everyone, I would like to convert my forum (www.modelbouwforum.nl) to https . I don't feel confident to do it myself... Is there anyone out there who can do this for me? Let me know your offer.. Kind regards, Robert Waanders
  8. eva2000

    Centmin Mod Nginx HTTP/2 HTTPS Migration Guide

    As there's many users here using my Centmin Mod LEMP stack with Nginx for their sites and forums, I wrote a guide for existing Centmin Mod Nginx HTTP users for migrating to Nginx HTTP/2 HTTPS with free Letsencrypt SSL certificates https://centminmod.com/migrating-to-https.html For Xenforo...
  9. vFranky

    XF 1.5 XenForo on HTTPs - How to?

    Hello, I like to activate SSL (https) for XenForo in the near future, because of Googles strategy. I would be perfect only to secure the XenForo login pages, but that seems not possible. Therefore I have already server certificates installed. What do I have to do in detail to get XenForo to...
  10. M

    Switch to HTTPS - External login/registration issue

    Hi guys, I'm trying to switch my website and forum to HTTPS (SSL) usage. Both separate are working fine, but combined I find some issue's. Is there someone that can help me on why this is not working properly? First let me describe what I have now: A website which is currently working via...
  11. Mouth

    Migration from commercial SSL certificate to LetsEncrypt

    Has anyone with their site https only and using a commercial SSL certificate that is expiring shortly, migrated to a LetsEncrypt SSL certificate instead? If so, any learnings or issues ... or a seamless transition?
  12. Apodictive

    A few Pre-Purchase Questions

    Hi xenForo community. I will be building my first xenForo forum and I have a few pre-purchase questions that I would like to see if I can get some answers for. I searched here and on Google for the answers to most of my questions but there are a couple I either couldn't find exactly what I am...
  13. X

    HTTPS Site > HTTP images linked by users?

    What is the best way to handle this problem? https://www.hairlosstalk.com/interact/threads/age-24-have-i-avoided-genetic-mpb.99561/ Our forums are HTTPS, but the user has linked to images on another site at HTTP. As you can see in the top of the page, this breaks our SSL status, and will...
  14. Mr Lucky

    XF 1.5 Redirect https to just one page

    Does anyone know the best way with .htaccess to redirct just one page to https? e.g. I want to redirect http://domain.com/pages/sales to https://domain.com/pages/sales A normal Redirect 301 / doesn't seem to work. I also need to make sure that after leaving that page, all other pages are...
  15. DarkKitarist

    XF 1.5 MITM question and going HTTPS

    Hello again good people at Xenforo, I hope you're having a great Sunday evening/morning/afternoon! Anyway today someone from "Anonymous" (not really anonymous but he referenced himself as such and these times everyone does this apparently) used the MITM hack to change our banner on the website...
  16. D

    XF 1.4 Having problems with https

    Can be closed :)
  17. TRGCommunity

    Gametracker SSL Proxy 2.0

    NOTE: It seems like Gametracker is now finally supporting SSL. Try to change your Gametracker links to https. If everything works fine, you won't need this resource! Introduction If you display Gametracker banners on your ssl secured site, you may get a warning for mixed content as Gametracker...
  18. Amin Sabet

    mod_pagespeed authorization and mapping for https sites using CDN?

    From: https://gtmetrix.com/reports/www.mu-43.com/K5VWnaa7 Re: https://www.mu-43.com/forums/ Anyone know how to avoid this when using a CDN and mod_pagespeed with an https site? Here are my origin and mapping settings from pagespeed.conf: ModPagespeedDomain https://www.mu-43.com...
  19. ElgrandOC

    Moving from HTTP to HTTPS

    I use cloudflare to provide basic SSL cover for my website. At the moment, I have http://forum.elgrandoc.uk set up to work through the cloudflare service to give me https://forum.elgrandoc.uk Now, if you click both of the above links, you will see my problem. I have changed the settings...
  20. Amin Sabet

    XF 1.5 Cloudflare SSL issues

    I just changed over all 6 of my XenForo forums to https. I am using the XenForo link proxy and the @digitalpoint image proxy. I have a valid GeoTrust Rapid SSL certificate on my server for each one of the sites, and all showed the green lock in Chrome prior to setting up CloudFlare. Yesterday...