XF 1.5 XenForo on HTTPs - How to?

vFranky

Active member
Hello,

I like to activate SSL (https) for XenForo in the near future, because of Googles strategy. I would be perfect only to secure the XenForo login pages, but that seems not possible.

Therefore I have already server certificates installed. What do I have to do in detail to get XenForo to https? Where can I perhaps find a "how to" guide? Perhaps in combination with some hints in the aspect of SEO, like page forwarding in the htaccess.

Any information welcome! Thank you in advance!

Kind regards,
Frank
 

Mr Lucky

Well-known member
It's actually much easier than you think.

This thread tells you:

https://xenforo.com/community/threads/move-forum-from-http-to-https.120846/

EDIT: just checked, that thread is abit all over the place and some info is out of date, so basically this is it:

  • Change the board URL in Options > Basic Board Information (two instances)
  • Tick both Image and link proxy in Options > messages
  • htaccess redirect:
Code:
RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
 
Last edited:

Mr Lucky

Well-known member
Oh yes if you have Google Analytics, change the URL there (in Admin section)

Create a new site in Google Search Console. Won't do any harm to resubmit sitemap.

Won't do any harm to get any inbound links changed also, though I think for SEO your htaccess redirect effect is going to be miniscule, if any.
 

vFranky

Active member
Should be irrelevant for advertising if a forum is using SSL or not.
But I can imagine temporary effects after switching to https.
 

Chris Radford

Active member
What kind of SSL addon do I need to purchase from our host, to go about implementing this?
I also need to act based on the implementation of warnings that Google is undertaking.

Thank you.
 
Top