• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 htaccess and friendly urls on HTTPS

#1
Hello,

I recently installed a fresh installation of XenForo on my server. This server was already running a copy of XenForo beforehand without HTTPS and I was able to use htaccess, friendly urls, and mod_rewrite without an issue.

Prior to using letsecrypt to install my certificate and modify my virtual hosts, my friendly urls worked just fine on this installation of XenForo, however after the install it looks like htaccess no longer works.



Disabling friendly urls causes this to go away.

If anyone has any idea on how to resolve this problem, please let me know.

htaccess

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>

ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 405 default
ErrorDocument 406 default
ErrorDocument 500 default
ErrorDocument 501 default
ErrorDocument 503 default

<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    RewriteBase /

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]

    RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
    RewriteRule ^(.*)$ https://%1/$1 [R=301,L]
</IfModule>
Site - https://tria.tv
 

Mike

XenForo developer
Staff member
#3
Is it just that one URL that causes the problem?

If not, then it's very possible your VHost configuration is different in the HTTPS VHost. Check for differences (particularly with things like AllowOverride.) If it is just that URL, that would potentially imply something else is preempting XF -- at a guess, either the "accounts" directory existing or a rewrite elsewhere.
 
#4
I resolved the matter at hand by recreating my virtual host file for ssl that letsencrypt automatically created. The one that was generated lacked AllowOverride All under Directory options.

I apologize that this was not a XenForo issue. Thank you all for being so helpful. Turns out a good nights sleep was all I needed.