VaultWiki

VaultWiki [Paid] 4.0.27

No permission to buy ($10.00)
Failed install.

Server Error
rmdir(install/addons/51cd0ce91bf9c/upload/vault/core/controller/install/upgradepath/steps/4) [function.rmdir]: Directory not empty

  1. XenForo_Application::handlePhpError()
  2. rmdir() in AddOnInstaller/Model/AddOn.php at line 214
  3. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  4. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  5. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  6. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  7. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  8. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  9. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  10. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/Model/AddOn.php at line 201
  11. AddOnInstaller_Model_AddOn->deleteAll() in AddOnInstaller/ControllerAdmin/AddOn.php at line 239
  12. AddOnInstaller_ControllerAdmin_AddOn->actionInstallUpgrade() in XenForo/FrontController.php at line 310
  13. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  14. XenForo_FrontController->run() in /home/farearch/chat.farearchitects.com/admin.php at line 13
 
Ok, looks like my homepage isn't working either. Halp! (yes, I probably shouldn't have used the new fancy AddOnInstaller, now that I think of it)
 

pegasus

Well-known member
Due to its massive size, VaultWiki was given its own install system. You must use that. See: https://www.vaultwiki.org/manual/vaultwiki-4-manual/vw4:install-manual

Also it has not been updated for XenForo 1.2 yet, so you may encounter some issues (like possibly not being able to post/edit anything since XenForo 1.2 has a completely different editor). Please post bug reports at the support site. You will receive faster responses there.
 
Last edited:
Will do so. I'm still using 1.1.3, and the home page isn't working. Will post at the support site; but any ideas how to get the homepage working? The individual forum and post pages work...
 

pegasus

Well-known member
I have not tried the AddOnInstaller as it doesn't work with VaultWiki. If it's a database problem, you may have to restore your backup. It really depends on the error message. Support will be able to help more.
 
Is there a specific db table I should look at for the home page? I have a backup; but would rather not lose new posts , of course.
 
Hmm. Did an install the way suggest; putting vault in the root dir and library/vw in the library dir.

Again, noforum access ... login page gives a 500 server error.
 
I installed, each of the steps worked well, including the many step js install. I got the admin page for VW; and tried to access my XF. Dead. Login page returns a 500. Homepage returns empty.

Admin panel was formatted terribly; all JS didn't work. clicked the X, deleted, and after index rebuild, all was good again.
 

pegasus

Well-known member
If you don't post bugs at the support site, then they will never get fixed... A 500 error might be a database error, or it might be something else. Are you trying to use one of the advanced URL formats? If so, you might want the staff to look at your .htaccess or other rewrite config.

If you don't get a specific message other than 500, you need to start checking logs because it can be caused by almost anything.

For the JS not working, please check your browser console/logs. Are there 404 errors for some of the JS files, or any Javascript errors?
 

pegasus

Well-known member
Beta 2 should be released in a day or two, which will fix a number of showstopper issues, like incompatibility with Tapatalk, not being able to add wiki pages to areas, and fatal errors with XenForo 1.2. However, you may notice reduced features in XenForo 1.2, as not everything has been ported yet, simply made compatible enough to prevent errors.
 

pegasus

Well-known member
Beta 2 was released today (no announcement yet). VaultWiki should be more stable on XenForo now, and should be compatible with 1.1 and 1.2. No database changes this time, but you should still run the upgrade script (from VaultWiki's script) to get the updated templates and other goodies like template mods. If there's fewer showstopper issues this time around, next update should be a style update.
 

pegasus

Well-known member
They should be relatively similar. If there are any missing features in 1.2 vs 1.1 then they are changes that were missed on the first look.
 

Alpha1

Well-known member
I'd like to quote this suggestion by DigitalDoctor:
wikipedia-lipoma-icd10-structured-data-jpg.28173

Wordpress shortcodes - look complicated ! http://codex.wordpress.org/Shortcode_API
This would be powerful but I think many people would get intimidated by this.
It's almost as hard as learning HTML or learning Mediawiki syntax.

Just like WYSIWYG is key to make things newbie friendly ... so would WYSIWYG structure be important.

wikipedia-lipoma-icd10-structured-data-blank-jpg.28174

If structure is important .. I think an easy to use wiki (aka a wiki that will be used by a community) would need easy templates as I have depicted above.

FWIW, I think that structured WYSIWYG templates would be a very advanced feature that would be unlikely to make it into any version 1.0 product.

The main goal of a "Xenforo wiki" or any "Community driven wiki" should be to make it easy for a community to: (1) contribute, (2) find and (3) keep up to date.

An important addage should be: "Adding a wiki entry should be almost as easy as posting a new thread."

http://xenforo.com/community/threads/native-wiki.1636/page-11#post-346841

Related suggestion (but in the VW3 section) : https://www.vaultwiki.org/issues/1730/
 

pegasus

Well-known member
I agree that WYSIWYG templates like that above would be great for text values, but we run into problems when there are template parameters that modify HTML tag attributes or style options (even something as simple as a URL's href would be problematic because it can be easily overlooked in WYSIWYG mode). Handling these quite common situations in an intuitive way is one reason why WYSIWYG templates have not been tackled yet in such form.

The current plan for VaultWiki's template editor button is for a form-driven pop-up interface that lists all the template parameters and asks for their values. Perhaps the ideal solution is to return an error message if the user tries to insert a template in WYSIWYG mode and there are unentered template parameters that don't have default values (not even an empty default value).
 
Top