XF 1.4 Upgrade XF 1.4.10 = Account Suspended ??!


I have upgrade XenForo to 1.4.10 with :
XenForo Updater

After this it's okay but 1-2 minutes after this update :
Account Suspended

Appears on my website for this reason :
“Thousands of email in a few minutes
This hosting package is currently suspended.
You cannot continue to use or manage this package until it is reactivated.”

Just after update.

Small information when I did the update with "XenForo Updater" initially I got this error: An exception occurred: Mysqli prepare error: MySQL server has gone away in /home/phoenix/public_html/library/Zend/Db/Statement/Mysqli.php on line 77

I use the back on the browser button and I restart and it it is done properly then.

Thanks for your responses and help.

Kind Regards,

Edit (more information by my hoster):
Thats all genre forum notifications new message, new response.
I understand your concerns, but unfortunately many thousands of messages in minutes represents a security risk for our IP and the server load.

P.S.: Excuse me for my bad english, I'm French.
Last edited:

Chris D

XenForo developer
Staff member
It appears as though your host as suspended your hosting account, so you will need to contact them in order for them to restore your account.

The update process would not trigger any emails, so I can't explain what would cause that.
Apparently an old notification spam, new message forum and topic etc. That no would have surely been sent before because the installation was poorly done. Where my update to try to resolve this.

Implement maintenance quickly forum could you it temporarily prevent this spam time to find how to solve it, which then can have change a file to stop this is it you please? Because in the meantime my site and suspended and this impact on my game server.


XenForo moderator
Staff member
You can prevent emails being sent by adding this to the library/config.php file:
$config['enableMail'] = false;
That should avoid your host suspending you again for too many emails.

Chris D

XenForo developer
Staff member
To disable all outgoing mail from your forum you would need to add the following to your config.php file:
$config['enableMail'] = false;
Further, you may want to see if you have any mail queued up. You can check the mail queue by looking at the xf_mail_queue table. Ordinarily this queue would be empty, or at least not contain more than around 30 minutes worth of emails, and it is not normal for it to fill up and get stuck - if that's what happened then that would be extremely unusual and, once again, not something that would usually be caused by an upgrade.

However, as long as the mail queue is empty and usually doesn't contain more than a relatively small amount of messages (and you can see it being cleared at regular intervals), I would guess that the problem is resolved and shouldn't happen again. You would just have to keep a close eye on it.
In fact he had a big problem on my old version XenForo improperly installed. Because since the shift it has repair everything and to see the 'xf_mail_queue' table I understand...

Can I empty it? Way it is either cela, or I remade me suspend the account. Until I put the forum in maintenance and put fake mails of contact.

Chris D

XenForo developer
Staff member
I think the important question is why does that have nearly 14,000 mails queued up? This isn't normal and the priority should be finding out why that is in that state.

You can, however, empty it. You would need to keep a very close eye on it.
As explained on another post already I had a problem with my database that was normally heavy (1.4 + GB) here: XF 1.3 - How to clean my XF Database ?

They seems that upgrading XF 1.3.3 to 1.4.10 have already solved the problem of mails which send not long. Your colleague I had mentioned on the other post a problem at the level of the crons, how to check their good launches?

Here's a screenshot of the heaviest classified tables in my database:

Kind Regards,