Resource icon

Template Modification System (TMS) 1.3.1

No permission to download

Arty

Well-known member
I just realized I can't create two separate modifications for the same template. I put the two together and now it worked :)
You can.

Probably you have clicked something wrong. That error message should appear only if you are trying to edit or delete item that doesn't exist (but you have id for it), not when you are trying to create new item.
 

faeronsayn

Well-known member
You don't need addon for upgrade. All mods will stay on forum.
Tried it again and apparently that's not how it's working right now. Everytime I try to update a theme by overwriting it, all modifications that i've made through TMS are removed. I essentially want to keep my modifications while also letting the theme update. I've had no luck with it so far.
 

Arty

Well-known member
Tried it again and apparently that's not how it's working right now. Everytime I try to update a theme by overwriting it, all modifications that i've made through TMS are removed. I essentially want to keep my modifications while also letting the theme update. I've had no luck with it so far.
Create child style, apply modifications to it.
 

Arty

Well-known member
Hi, Im new to xenforo and wondering could you give me a step by step guide for installing TMS. Thanks
Unpack zip file, upload contents on your server. In admin control panel click "Add-ons" link, import xml file that you can find in this add-on's zip file.
 
  • Like
Reactions: HWS

BlackImpallaSS

New member
Ok, I uploaded the library folder -> library folder on server and js folder -> js folder on server , then i used the "add-on" link to upload the xml file from my local computer, but im getting the following messege:


Error

The files associated with this add-on could not be found. Please upload them and try again.
 

web09

Member
I have this installed, but when I go to Appearance/Template Modifications there are no choices like I see on the screenshots here. The install rebuilt the cache and I don't have any error messages but I don't see where/how this works in terms of using it. Could anyone please point me in the right direction on how this works? Thanks
 

Adam Howard

Well-known member
Nooooooo !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I just learned the hard way that TMS does not keep it's own template base.

That is to say, if you make a custom edit in TMS it does not save in its own plug-in or anything else in the database except for within the template its self.

I goofed up on a skin edit and so I imported the skin over its self expecting the TMS edits to remain. This was not the case.
 

web09

Member
Success Finally ** Thank you Arty for pointing me in the right direction***
I'm posting just in case someone else tries to install and gets a duplicate table error or has an install that for some reason didn't complete the first time.

I had to manually find two tables:

1. xf_template (and I had to make two changes in this table: deleting both the template_modified field and the template_modifications field

2. tms_modifications (I had to manually delete this table)

And then reinstall the tms add on. It finally worked! Thanks Arty for the help:)
 

kankan

Well-known member
Hi, Thank you for your job.
When trying to import the xml my Xenforo 1.1.3 reports this error :

Mysqli statement execute error : Duplicate column name 'template_modified'
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in TMS/Manufacture.php at line 72
  4. TMS_Manufacture->_installVersion1() in TMS/Manufacture.php at line 59
  5. TMS_Manufacture::build()
  6. call_user_func() in XenForo/Model/AddOn.php at line 214
  7. XenForo_Model_AddOn->installAddOnXml() in XenForo/Model/AddOn.php at line 169
  8. XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 178
  9. XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /home/e-smith/files/ibays/forumasus/html/www/admin.php at line 13
 

guiltar

Well-known member
Hi, Thank you for your job.
When trying to import the xml my Xenforo 1.1.3 reports this error :
Hi! You need to delete the column 'template_modified' and 'template_modifications' form xf_template_map and try again.
 

kankan

Well-known member
Hello Guiltar,
Thanks for your answer.
I cannot see 'template_modified' and 'template_modifications" in table xf_template_map , cf capture attached.
 

Attachments

guiltar

Well-known member
Hello Guiltar,
Thanks for your answer.
I cannot see 'template_modified' and 'template_modifications" in table xf_template_map , cf capture attached.
These are columns, not rows. You have to remove colums that tms created.
 

cclaerhout

Well-known member
A quick feedback about using a xen conditionnal with a visual property element inside a callback (I didn't test if the problem also occurs without a callback replacement). If you do it directly, it will not work (will generate a log error message). The solution is to set a variable before, then everything will be fine.

Example:

Code:
{xen:if "{@myProperty}", "Do this", "Else: Do that}
=> will not work (even if the property exists)

Code:
<xen:set var="$myVariable">@myProperty</xen:set>
{xen:if "{$myVariable}", "Do this", "Else: Do that}
=> will work

SORRY DOESN'T WORK
SOLUTION: use the command include with a template which will have this code​
 

guiltar

Well-known member
Cédric, thanks. What is @myProperty here?
XenForo parser recognize such things as style variables.
Also, could you give me search and replace strings to check.
 
Top