1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Spell check doesn't work

Discussion in 'Resolved Bug Reports' started by rellect, Jul 13, 2013.

  1. rellect

    rellect Well-Known Member

    Browsing here using iPhone5, safari:
    The built-in spell check doesn't work while you writing messages.
  2. Jeremy

    Jeremy XenForo Moderator Staff Member

    I haven't had issues, but unfortunately I don't think there is much XenForo can do since this is controlled by the browser, not the software.
  3. rellect

    rellect Well-Known Member

    There are ways to disable the built-in spell check. It is not conrolled by the browser alone.
    That could be the case, but it might be also just a styling issue that hides the misspelled word dots.
  4. Mike

    Mike XenForo Developer Staff Member

    This seems to work correctly in my tests - I see the red dots and clicking on the word brings up the choice list.

    We're not doing anything to disable it -- it may just be a choice made by iOS (or a bug within it).
  5. rellect

    rellect Well-Known Member

    Your test was with the same device?
  6. Mike

    Mike XenForo Developer Staff Member

    In this case, the iPhone simulator (I only personally own Android devices, I have to wait to check iOS stuff directly later). But this should generally be a software thing.
  7. MattW

    MattW Well-Known Member

    I don't see the red dots to indicate a spelling mistake in any text area box I type when using Sarafi on IOS6 (tried on various different websites (redactor / tinymce / google))

    2013-07-15 13.36.54.png
    Hornstar likes this.
  8. Moshe1010

    Moshe1010 Well-Known Member

    It definitely worked before, so it's interesting what was changed.
  9. MattW

    MattW Well-Known Member

    It's also not showing the ...... in Chrome either.
  10. mauzao9

    mauzao9 Well-Known Member

    I have the issue with Chrome in Win7, it happens only some times that i am writing and all the red dots disappear from sudden and i must write random text or delete text to make the spell check work again.
    It usually happens when I enter some smilie / image / paste text in the editor. I'm not sure if this is chrome related, it happens in the 1.1 editor and 1.2, but it is frustrating to make the spell checker work again when it happens.
  11. Hornstar

    Hornstar Well-Known Member

    Yep confirmed that the red dots do not show on the iPhone 5 iOS 6.1.4 in safari.
  12. Mike

    Mike XenForo Developer Staff Member

    Just to confirm, what about in the non-WYSIWYG elements? What about in 1.1? @MattW seems to imply that it doesn't show anywhere.
  13. MattW

    MattW Well-Known Member

    Plain editor on here


    No red dots
    Mike likes this.
  14. MattW

    MattW Well-Known Member

    But you do get red dots on the iPad2
  15. rellect

    rellect Well-Known Member

    When tested with iPod4 (6.1.2) I could see the red dots of misspelled words. Also someone posted that it works for him in his iPad2.
    Seems like this is just iPhone5/iOS6.1.4 bug/behavior. Double clicking on misspelled word does give list of corrections, it's just don't display the red dots. It does show the red dots in apps, such as the email app.

    Guess this report can be closed as it's not related to XF, unless the staff would want to investigate that further.
  16. MattW

    MattW Well-Known Member

    It's random on the iPad. The screen shot on the iPad above shows Vectra being highlighted. Typing it now, it's not showing it as a spelling mistake (no words are now)

Share This Page