1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Spam is getting through

Discussion in 'XenForo Questions and Support' started by Core Freedom, May 27, 2014.

  1. Core Freedom

    Core Freedom Well-Known Member

    Hi everyone,

    I hope this is in the right place. Since the upgrade I am getting spam membership requests. My membership is set to "manual approval" and I have 2 security questions that they have to fill out. These bots are filling out the questions like this:

    zlik6g6h (ug.g.b.o.ot.s2014@gmail.com
    How did you find us: who_referred_you
    Why do you want to become a member: more_about_you

    All of the requests are filled out the same way. Did something change with the latest upgrade or is there a way to stop these bots to come through?

    Thank you all!
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    What are the permitted answers to those two questions?
    Or are they just profile fields?

    In which case, consider setting up Q&A captcha.
     
    Core Freedom likes this.
  3. Core Freedom

    Core Freedom Well-Known Member

    They have to answer the questions in any way they choose. The Q&A captcha is set, they still get through. I had a dozen of these (different names and emails but all spammy looking and same answers).
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    If you want a really good captcha system, and don't mind using an add-on, I can't recommend @tenants FoolBotHoneyPot enough. There is the free branded version and the unbranded (paid). His complete collection pretty much eliminates any non-human spam signups. Well worth the few bucks it costs for it.
     
    Core Freedom likes this.
  5. SchmitzIT

    SchmitzIT Well-Known Member

    We also saw a lot of spam come in all of a sudden, albeit on an older version of XF. I got a hold of a Akismet API key, which has worked wonders.
     
    Core Freedom likes this.

Share This Page