• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
s9e Media BBCodes pack

s9e Media BBCodes pack 20171028

No permission to download

Triops

Well-known member
Cool! Sometimes it is better to keep calm and wait and see. Videos were for sure not showing up when I wrote the message above. Now all my tries embed and show the videos just fine. Must have been a temp. problem on Facebook's side...
 

JoshyPHP

Well-known member
How do you mean they are blocking embeds?
They block some HTTP requests if they don't like your browser. I haven't spent a lot of time investigating it but they do seem to block post embeds if the browser doesn't send a Referer header.

Videos were for sure not showing up when I wrote the message above. Now all my tries embed and show the videos just fine.
That's because the latest version of the add-on (at the time) used a third-party page to embed posts and videos and I updated that page before updating the add-on. That's like hotpatching for people who haven't updated the add-on yet.
 

BoostN

Active member
I had this installed on XF 1.5. I did a an upgrade to 2.X Beta 1, and I've noticed the media is missing. Should we uninstall before upgrading or?
 

JoshyPHP

Well-known member
This add-on isn't compatible with 2.0 yet. I don't know whether you have to uninstall it before upgrading but you may have to disable it. At any rate, it will not function properly on 2.0 so you may as well uninstall it.
 

Floyd R Turbo

Well-known member
I don't know whether you have to uninstall it before upgrading but you may have to disable it. At any rate, it will not function properly on 2.0 so you may as well uninstall it.
Is there a standard approach for this? I seem to recall that the approach is to disable all addons, upgrade, and then install 2.x addon versions. This way the tables in the database associated with the addons will stay in place for the future, but the addons will essentially be wiped away as XF 1.x > 2.0 will only port over it's own stuff, and the library folder is then no longer used....but I could be totally wrong.

either way, no 1.x addons will work with 2.x
 

BoostN

Active member
This add-on isn't compatible with 2.0 yet. I don't know whether you have to uninstall it before upgrading but you may have to disable it. At any rate, it will not function properly on 2.0 so you may as well uninstall it.
I understand it won't work. :)

Just wondering the proper method to go from XF 1.5 with this add-on, to XF 2.X without this add-on. I'm on a local machine right now testing, and my most recent thread with YouTube embeds are now gone on XF2.

1504904714749.png
 

JoshyPHP

Well-known member
@Floyd R Turbo @BoostN I don't know. I have a local 2.0 install but it's a fresh install, not an upgrade. You might as well uninstall the add-on since you can't use it in 2.0.

Technically you may be able to retain some of the media sites (those that don't use callbacks) by changing their addon_id before uninstalling but it's probably not worth the trouble.
 

BoostN

Active member
@Floyd R Turbo @BoostN I don't know. I have a local 2.0 install but it's a fresh install, not an upgrade. You might as well uninstall the add-on since you can't use it in 2.0.

Technically you may be able to retain some of the media sites (those that don't use callbacks) by changing their addon_id before uninstalling but it's probably not worth the trouble.
If I uninstall on 1.5, will the posts/media embed revert back to the XF 1.5 defaults?

I would obviously do this before upgrading.. but I'm hoping you can get a XF 2 version for this sometime. I haven't read the thread to see if you've mentioned plans or not.
 
Question. on our forum there is a person that's pasting from digg. The videos autoplay, so I went into 'options' to see if I could find options for individual sites and turn autoplay off.

I wasn't able to find that spot in the options and I swear I thought I'd seen it before.

Can you point me to the right place to find this?
 

JoshyPHP

Well-known member
No, there's no option for toggling autoplay because all of the media sites have it disabled if possible. What site autoplays videos? Digg isn't a media site.
 

JoshyPHP

Well-known member
That must be another add-on then, because this one doesn't handle Digg videos. If you go to your admin panel and edit the Digg media site you'll see what add-on it belongs to.
 
That must be another add-on then, because this one doesn't handle Digg videos. If you go to your admin panel and edit the Digg media site you'll see what add-on it belongs to.
OK no problem. Sorry to bother you with it.

I will say, this is likely the most useful plugin i've installed. We donated to you a while back, i think we should do so again. Everyone loves it!
 

JoshyPHP

Well-known member
It works for me locally. Try disabling all of your extensions, enabling cookies, referrers, etc... Usually it's a browser issue although I've occasionally seen some rogue Amazon server misbehave. You can also try a new profile or a different browser.