• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
Quick Reply Preview

Quick Reply Preview 1.4.4

No permission to download

Triops

Well-known member
#42
Is there any chance to move the preview button to the very left, so "before" the "Post reply" button?
Maybe as admin configurable option in a further update or with a style in EXTRA.css?!

Thanks a lot for this add-on, preview is so important in my forums.
 
#43
Great Add-on. One issue though. When someone creates a long post and hits the preview button, there is no way to see the whole post. There is no scroll bar and users can only see the upper part of the post. Any way to fix this?

Thanks
 

Amaury

Well-known member
#44
Bug: There is no scroller. Also notice how the overlay isn't centered because of that and is therefore cut off at the bottom.

Quick Reply Preview.png
 

Sunka

Well-known member
#45
Yep, on some long posts there is not scroller. Preview posts stays fixed, and page under is moving when you try scroll with mouse.
Also, this MOD conflict with another one - Post Macros. Button from Post Macros do not show in quick reply if Quick reply preview is enabled (this mod).
Is there any chance to try to fix this two problems @Chris D ?
 

Chris D

XenForo developer
Staff member
#46
As I do not have access to the Post Macros add-on, we might need @Liam W to let me know the specific settings he is using to display the button there so we can work together and see if we can get it working harmoniously.
 

Liam W

Well-known member
#48
As I do not have access to the Post Macros add-on, we might need @Liam W to let me know the specific settings he is using to display the button there so we can work together and see if we can get it working harmoniously.
Thanks for your goodwill
Looks to be more of an issue with the template modification replace I use (I use way to much)... I'll release an update soon (later this evening) @Sunka.
 

Chris D

XenForo developer
Staff member
#49
I'm not saying mine is necessarily the best way, but if you were to do the same then that should work quite nicely and if anyone needed to change the order of the buttons it should just be a case of affecting the execution order.
 

zagorskey

Active member
#51
There's a conflict with "Post As User by Waindigo", the <dl class="ctrlUnit postAsUser"></dl> completely disappears when both add-ons being enabled.
 

Chris D

XenForo developer
Staff member
#53
Nothing I can do about that. I don't apply any styling to overlays. There will probably be other overlays that have a similar problem.
 

Chris D

XenForo developer
Staff member
#55
Yeah, but to be fair, most of these types of overlay do have a footer and close button at the bottom. But, in theory, the issue is a style issue and could crop elsewhere.

This is the fix, though. Add to EXTRA.css:

Code:
.xenOverlay a.close.OverlayCloser
{
    top: 30px;
}
 

RAHSTYLES

Active member
#56
Yeah, but to be fair, most of these types of overlay do have a footer and close button at the bottom. But, in theory, the issue is a style issue and could crop elsewhere.

This is the fix, though. Add to EXTRA.css:

Code:
.xenOverlay a.close.OverlayCloser
{
    top: 30px;
}
yea i tried that but it didnt work
 

Chris D

XenForo developer
Staff member
#59
Your EXTRA.css is full of parse errors.

You're not using comments properly.

This is not valid CSS:
Code:
/ start previewfix /

.xenOverlay a.close.OverlayCloser
{
top: 30px;
}

/ end previewfix /
Try:

Code:
/* start previewfix */

.xenOverlay a.close.OverlayCloser
{
    top: 30px;
}

/* end previewfix */
 

RAHSTYLES

Active member
#60
Your EXTRA.css is full of parse errors.

You're not using comments properly.

This is not valid CSS:
Code:
/ start previewfix /

.xenOverlay a.close.OverlayCloser
{
top: 30px;
}

/ end previewfix /
Try:

Code:
/* start previewfix */

.xenOverlay a.close.OverlayCloser
{
    top: 30px;
}

/* end previewfix */

SEriously?? lol is it that sensitive?? Yes this worked .. Thanks chris