1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Poor Grammar in Phrasing for TLS 1.2 Warning in XenForo 1.5.6

Discussion in 'Resolved Bug Reports' started by StarArmy, Feb 23, 2016.

  1. StarArmy

    StarArmy Active Member

    upload_2016-2-23_11-35-36.png

    The new message here seems to have missed proofreading.

    I think it should say "Starting June 18, 2016, PayPal will require all requests to use TLS 1.2 and that your server has the required SSL libraries to support this. Without TLS 1.2 support, user upgrades will not be processed correctly. Please contact your host or system administrator for guidance."

    or this, for more clarity:

    "Starting June 18, 2016, PayPal will require all requests to use TLS 1.2. Without TLS 1.2 support, user upgrades will not be processed correctly. XenForo has detected that your server does not have the required SSL libraries to support this. Please contact your host or system administrator for guidance."
     
    semprot likes this.
  2. Mike

    Mike XenForo Developer Staff Member

    Should really be "...does not have...". I don't know how I missed that. It's a trivial issue, but it does confuse the meaning of that message so I think I'm going to look at changing that. (I looked at that message so many times that I think I went blind to it. :) )
     
  3. Mike

    Mike XenForo Developer Staff Member

    I've just patched the package here to make it clearer. (It's just a text change to make the message less ambiguous. You can change the phrase if needed, wait for 1.5.7 or redownload/upload/rebuild the master data.)
     
  4. The Sandman

    The Sandman Well-Known Member

    If we don't see the message does it mean that TLS 1.2 support has been detected so no worries?
     
    Mouth likes this.
  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. The Sandman

    The Sandman Well-Known Member

    Thanks Brogan. I went and found the new message phrase and it's clear from that as well.
     
  7. vinafix

    vinafix Active Member

    I've upgraded 1.5.6.
    But I do not see the message as above. Are my servers that support TLS1.2 ?

    Thanks you.
     
  8. Amaury

    Amaury Well-Known Member

     

Share This Page