• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
How to upgrade to XenForo 1.3

XF 1.3 How to upgrade to XenForo 1.3

Important information and actions to be taken

Brogan

XenForo moderator
Staff member
#1
Brogan submitted a new resource:

How to upgrade to 1.3 - Important information and actions to be taken

As XenForo 1.3 introduces many new features and functions, as is typical with a second point release, there are several specific things which need to be considered when upgrading.

Take a backup of the database before you do anything!
See here for how to backup (and restore):...
Read more about this resource...


Please note that in order to keep this discussion thread relevant and informative, off topic and other non-relevant posts will be removed.

The general feedback thread is here: http://xenforo.com/community/threads/xenforo-1-3-general-discussion-feedback.67122/
 

Romchik®

Well-known member
#2
Hm... From XenForo requirements test script:
Requirements Met
Your server meets all of XenForo's PHP requirements.

XenForo also requires MySQL 5.0 or newer. Please manually check that you meet this requirement.
But
The following warnings were detected when verifying that your server can run XenForo:
  • Your server has disabled core PHP functions. This may cause unexpected problems in XenForo. All PHP functions should be enabled.
These may affect the proper execution of XenForo at times and should be ideally be resolved.
Something has changed in the system requirements?
 
#6
My upgrade crashed on my beta site... :(

Mysqli prepare error: Unknown column 'display_order' in 'order clause'

  1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
  2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
  3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
  4. Zend_Db_Adapter_Abstract->query() in XenForo/Model.php at line 219
  5. XenForo_Model->fetchAllKeyed() in XenForo/Model/Smilie.php at line 87
  6. XenForo_Model_Smilie->getAllSmiliesForCache() in XenForo/Model/Smilie.php at line 113
  7. XenForo_Model_Smilie->rebuildSmilieCache() in XenForo/Deferred/ImportMasterData.php at line 40
  8. XenForo_Deferred_ImportMasterData->execute() in XenForo/Deferred/Atomic.php at line 66
  9. XenForo_Deferred_Atomic->execute() in XenForo/Model/Deferred.php at line 252
  10. XenForo_Model_Deferred->runDeferred() in XenForo/Model/Deferred.php at line 378
  11. XenForo_Model_Deferred->_runInternal() in XenForo/Model/Deferred.php at line 312
  12. XenForo_Model_Deferred->runByUniqueKey() in XenForo/Install/Controller/Abstract.php at line 34
  13. XenForo_Install_Controller_Abstract->_manualDeferredRunner() in XenForo/Install/Controller/Upgrade.php at line 221
  14. XenForo_Install_Controller_Upgrade->actionRunDeferred() in XenForo/FrontController.php at line 347
  15. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  16. XenForo_FrontController->run() in /home/user/directory/beta/install/index.php at line 18
 

Mike

XenForo developer
Staff member
#7
This will likely be from an add-on that has added conflicting data to the DB. I suspect it's smilie related. You may need to revert to your backup and remove the offending add-on (and hopefully it actually removes the DB column it added...).
 

cclaerhout

Well-known member
#10
Try to rebuild your xf_smilie table using this query (from XenForo) :
Code:
ALTER TABLE xf_smilie
        ADD smilie_category_id INT UNSIGNED NOT NULL DEFAULT 0,
        ADD display_order INT UNSIGNED NOT NULL DEFAULT 1,
        ADD display_in_editor TINYINT UNSIGNED NOT NULL DEFAULT 1,
        ADD INDEX display_order (display_order)
May be you will have to drop your previous "display_order " field.
 

Rob

Well-known member
#11
@Brogan As always an excellent resource. I'm just wondering if it could be improved by adding to it a list of add-ons that 1.3 makes obsolete? Just a suggestion :)
 

Brogan

XenForo moderator
Staff member
#12
That's always a subjective issue as add-ons almost always have slightly different functionality so continue to be used.

I prefer to leave it up to the individuals using those add-ons to make the decision for themselves.

A quick look at the HYS threads will make it clear what new features and functionality are coming in 1.3.
 

Kevin

Well-known member
#15
For your custom style folders, these are the new images I've identified so far...

/styles/default/xenforo/gplus.png
/styles/default/xenforo/twitter-bird.png
/styles/default/xenforo/icons/missing-image.png
 

tafreehm

Well-known member
#16
If you have a custom style it is highly likely that it will not work in 1.3 and will require updating. If the style is from a third party, ensure there is a new compatible release before you upgrade otherwise you will need to wait until the author releases an update.
why is that? I have a custom design, that was built on 1.2, you are saying it wont work if I upgrade?
 

Moshe1010

Well-known member
#17
why is that? I have a custom design, that was built on 1.2, you are saying it wont work if I upgrade?
I think this is true only if you're coming from 1.1
I have a custom design and nothing happened when upgrading form 1.2 (nor I see what would anything happen since nothing design wise was changed [like the responsive design implementation in 1.2]).
 

tafreehm

Well-known member
#18
I think this is true only if you're coming from 1.1
I have a custom design and nothing happened when upgrading form 1.2 (nor I see what would anything happen since nothing design wise was changed [like the responsive design implementation in 1.2]).
yes, thats what I was thinking. XF implemented template merge system, specially for this reason. I think author needs to be more specific about this point.
 

Brogan

XenForo moderator
Staff member
#19
why is that? I have a custom design, that was built on 1.2, you are saying it wont work if I upgrade?
Nothing is certain.
There are changes in 1.3, nothing like as much as 1.2 but you will still need to check.

Unless you revert or merge the changes, it won't work as designed.
So yes, you still need to check and carry out specific actions.
 

Tracy Perry

Well-known member
#20
Those are warnings, not a completely missing dependency. It may not affect anything, but it's hard to guarantee.
Any possibility of showing what the "core functions" that are missing are? My servers were working just fine (and passed all checks) on 1.2 but I just got this warning when upgrading to 1.3 BETA 1.