Gallery

Gallery 1.1.2

No permission to download

Mike2020

Well-known member
hi all

Just to let you all know i now have my PC back up and running.

I have uploaded the latest version to my site and have made a few changes to the layout.
There are no longer any borders around the images i have changed this to a more slick idea.

just put your mouse over any image and the title and a short description will show with a button to view that media.
Taking the borders out was i think a good idea as it did not work the way i wanted it to.

Take a look and let me know what you think and i hope its a bit more responsive now as well.
 

Mike2020

Well-known member
Mike2020 updated Gallery with a new update entry:

Bug Fix For Version 1.1.0

This fixes some errors that where happening in the last release.
These errors was on line 888 of the gallery.php file in the module folder,
and one in the index file where a missing id was giving an error.

There also has been a change to the layout to make it more responsive when viewing on a mobile phone or other device.
In the admincp gallery options have removed the frames from the images as this was one reason the images was not responsive.
Read the rest of this update entry...
 

Mike2020

Well-known member
Hey all

It's been a while since i posted whats going on with the gallery system.

Well i'v been changing things and adding in new features for you to enjoy.

First i'v fixed an error when making ecards
Next added the option to download hosted files with a download delay limit.
Added in exif data from the image.
This will show
Camara Used:
Exposure:
Aperture:
Software:
ISO:
Date Taken:
Focal:
and if there is any geo information it will show this on a map.

This version is in testing and will be released as soon as i think its all working fine.
Let me know what your thoughts are on these new features
 

Mike2020

Well-known member
Not long now before the next release.
Have added more functions for your users like adding in there own album's/categories
can edit delete album's/categories and in usergroup options you can set who can add new album's/categories and the amount they can add.

Will upload some new screenshots soon
 

Mike2020

Well-known member
Hi,

I have the same problem as pmflav:
When using the dropdown to choose a category, it is not letting me select one.
you have to add sub categories as it want let you add media to the top level categories.

Keep in mind 95% don't care about that info.
Yes i know but if someone uploads an image thats not theres this info will show that.
If there is no info in these fields it want show whats missing.
I can put an option in to turn this off if need be
 

Mouth

Well-known member
Yes i know but if someone uploads an image thats not theres this info will show that.
If there is no info in these fields it want show whats missing.
I can put an option in to turn this off if need be
I think a link/button to reveal or hide the exif data would work best. Much like the 'Click to expand' link works at the bottom of quoted text.
 

Mouth

Well-known member
Have added more functions for your users like adding in there own album's/categories
can edit delete album's/categories and in usergroup options you can set who can add new album's/categories and the amount they can add.
Sounds great. Is it an ACP option for just albums? I'd like users to create albums within existing categories, not have permissions to create categories. If they create an album, then only the user that created the album can add media to it.
 
Thanks for your answer. I created a subcategory and I can select it now.

But then I get the following error (I used the method "image from computer"):

unlink(): No such file or directory

XenForo_Application::handlePhpError()
unlink() in gallery/Model/galleryimage.php at line 100
gallery_Model_galleryimage->upload_gallery_image_file() in gallery/ControllerPublic/index.php at line 302
gallery_ControllerPublic_index->actionDouploadfile() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /srv/www/vhosts/RettForum/index.php at line 13
 

Mike2020

Well-known member
Thanks for your answer. I created a subcategory and I can select it now.

But then I get the following error (I used the method "image from computer"):

unlink(): No such file or directory

XenForo_Application::handlePhpError()
unlink() in gallery/Model/galleryimage.php at line 100
gallery_Model_galleryimage->upload_gallery_image_file() in gallery/ControllerPublic/index.php at line 302
gallery_ControllerPublic_index->actionDouploadfile() in XenForo/FrontController.php at line 351
XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
XenForo_FrontController->run() in /srv/www/vhosts/RettForum/index.php at line 13
i will have a look at this for you but im sure this is fixed in the next release.
 
Top