1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gallery 1.1.2

A image and video gallery system for xenforo

  1. Mike2020

    Mike2020 Well-Known Member

    Mike2020 submitted a new resource:

    Gallery - A image and video gallery system for xenforo

    Read more about this resource...
     
  2. Ricardo Moura

    Ricardo Moura New Member

    Well, the install and configure thats ok. But when i want view a picture in my gallery appear this server error

    Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') WHERE title = ?' at line 6

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
    5. Zend_Db_Adapter_Abstract->fetchRow() in gallery/Model/gallery.php at line 257
    6. gallery_Model_gallery->getSubCategoryByNodeName() in gallery/Model/gallery.php at line 160
    7. gallery_Model_gallery->getCategoryOrError() in gallery/Model/gallery.php at line 149
    8. gallery_Model_gallery->assertCategoryValidAndViewable() in gallery/ControllerPublic/index.php at line 730
    9. gallery_ControllerPublic_index->actionMedia() in XenForo/FrontController.php at line 351
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /var/www/xxxxxxxx.com.br/onlyfortest/index.php at line 13
     
  3. Mike2020

    Mike2020 Well-Known Member

    has the title of the image or the category got ' in them
     
  4. Mike2020

    Mike2020 Well-Known Member

  5. Kintaro

    Kintaro Well-Known Member

    @Mike2020 is there a demo or an installation to "play" with?
     
  6. bt012ss

    bt012ss Well-Known Member

  7. Mike2020

    Mike2020 Well-Known Member

    has this gone away for you now since the update
     
  8. Mike2020

    Mike2020 Well-Known Member

    Hi all

    Just wanted to update you on whats coming next.
    In the next version i will be adding in a friends system where you will be able to add users as friends and only show content to them.

    Have already added the add friend to profile over lay
    Sorted out add friend
    Reject friend and except friend

    Just need to work on the limiting media to friends only or public
     
  9. Mike2020

    Mike2020 Well-Known Member

    Here are the images of whats to come in next release

    Its in testing before its released
     

    Attached Files:

  10. JustinHawk

    JustinHawk Active Member

    Facing some issues with addon :)

    Using php version 5.6.21
    Plugin Version : 1.0.5a
    XenForo : 1.5.7

    Code:
    ErrorException: Undefined index: - library/XenForo/Visitor.php:678
    Generated By: admin, 4 minutes ago
    Stack Trace
    #0 /var/www/vhosts/xen-demo/httpdocs/library/XenForo/Visitor.php(678): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/vhosts...', 678, Array)
    #1 /var/www/vhosts/xen-demo/httpdocs/library/gallery/ControllerPublic/index.php(30): XenForo_Visitor->offsetGet(NULL)
    #2 /var/www/vhosts/xen-demo/httpdocs/library/XenForo/FrontController.php(351): gallery_ControllerPublic_index->actionIndex()
    #3 /var/www/vhosts/xen-demo/httpdocs/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /var/www/vhosts/xen-demo/httpdocs/index.php(13): XenForo_FrontController->run()
    #5 {main}
    Request State
    array(3) {
      ["url"] => string(30) "http://xen-demo/gallery/"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(0) {
      }
    }
    

    Code:
    Error Info
    ErrorException: Undefined index: id - library/gallery/Model/gallery.php:2176
    Generated By: admin, 5 minutes ago
    Stack Trace
    #0 /var/www/vhosts/xxxx/httpdocs/library/gallery/Model/gallery.php(2176): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/vhosts...', 2176, Array)
    #1 /var/www/vhosts/xxxxx/httpdocs/library/gallery/ControllerPublic/index.php(276): gallery_Model_gallery->sendNotificationToCategoryWatchUsersOnReply(0, Array, Array)
    #2 /var/www/vhosts/xxxxx/httpdocs/library/XenForo/FrontController.php(351): gallery_ControllerPublic_index->actionDouploadfile()
    #3 /var/www/vhosts/xxxxx/httpdocs/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /var/www/vhosts/xxxxx/httpdocs/index.php(13): XenForo_FrontController->run()
    #5 {main}
    Request State
    array(3) {
      ["url"] => string(42) "http://xxxxx/gallery/douploadfile"
      ["_GET"] => array(0) {
      }
      ["_POST"] => array(9) {
        ["_xfToken"] => string(8) "********"
        ["maxuploadsize"] => string(7) "2097152"
        ["phpmaxuploadsize"] => string(2) "2M"
        ["imagetype"] => string(1) "0"
        ["photonameurl"] => string(0) ""
        ["videonameurl"] => string(0) ""
        ["filetitle"] => string(11) "DEmo upload"
        ["description"] => string(41) "Dont know what to say, its just an eye :P"
        ["agerestrict"] => string(1) "0"
      }
    }
    

    Also i uploaded the image in a test category and the media is being shown in my media tab but is not available in gallery.

    Screenshot
    Screenshot_2.png Screenshot_3.png
     
  11. Mike2020

    Mike2020 Well-Known Member

    check in admin cp if the media is in the un-approved list.

    If this is the case you need to change the usergroup options for admins and set this Moderate New Media Added: to no and yes to groups you want to approve media from.
    I will look into these errors for you and let you know what i find
     
  12. JustinHawk

    JustinHawk Active Member

  13. Mike2020

    Mike2020 Well-Known Member

  14. JustinHawk

    JustinHawk Active Member

  15. Mike2020

    Mike2020 Well-Known Member

    i will put this on a test server and see whats happening

    but change this to Moderate New Media Added: Never as it needs to be set
     
  16. JustinHawk

    JustinHawk Active Member

    it set it to never for admin

    also faced this issue viewing media from sidebar :(

    Code:
    Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') WHERE title = ?' at line 6
    
    Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 753
    Zend_Db_Adapter_Abstract->fetchRow() in gallery/Model/gallery.php at line 257
    gallery_Model_gallery->getSubCategoryByNodeName() in gallery/Model/gallery.php at line 160
    gallery_Model_gallery->getCategoryOrError() in gallery/Model/gallery.php at line 149
    gallery_Model_gallery->assertCategoryValidAndViewable() in gallery/ControllerPublic/index.php at line 730
    gallery_ControllerPublic_index->actionMedia() in XenForo/FrontController.php at line 351
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    XenForo_FrontController->run() in /var/www/vhosts/xen-demo./httpdocs/index.php at line 13
     
  17. Mike2020

    Mike2020 Well-Known Member

    am looking into this for you
     
    JustinHawk likes this.
  18. Mike2020

    Mike2020 Well-Known Member

    what version you using the one here or the one i sent you by email.
     
  19. JustinHawk

    JustinHawk Active Member

    one that is here atm ;)
     
  20. Mike2020

    Mike2020 Well-Known Member

    ok ill have a look into this and get back to you in a few hours as im at work at moment and dont have the files here.
     

Share This Page