• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't fix Flash Attachment Uploader Stuck at 100% when using Socks Proxy

bottiger

Active member
#1
The Flash attachment uploader gets stuck at 100% when using a socks proxy.

Steps:
  • Set up your browser to use a socks proxy. If you run OSX or linux it is easy to test on your own computer: http://www.mikeash.com/ssh_socks.html
  • Click Upload a File.
  • Observe the progress bar getting stuck at 100% and not letting you embed or having the attachment show up at the end of the post.
 

Mike

XenForo developer
Staff member
#2
Unfortunately, this is likely down to issues in Flash itself -- specifically, Flash doesn't use the browser proxy settings and can't do proxy authentication. (It may actually use IE's on Windows.) Unfortunately, as such, we can't really do much about it.
 
R

ragtek

Guest
#3
Possible solution=> let the user choose, if he want to use the flash uploader or not.

If somebody is using the (default) flash uploader and he reports problems to me, i could disable it for him in the user edit form in the acp and say him to try again:D

Unfortunately, this is likely down to issues in Flash itself -- specifically, Flash doesn't use the browser proxy settings and can't do proxy authentication. (It may actually use IE's on Windows.) Unfortunately, as such, we can't really do much about it.
 

bottiger

Active member
#5
Unfortunately, this is likely down to issues in Flash itself -- specifically, Flash doesn't use the browser proxy settings and can't do proxy authentication. (It may actually use IE's on Windows.) Unfortunately, as such, we can't really do much about it.
I can connect without a proxy just fine, I just prefer to use one.

This means it is probably a problem with the flash uploader itself.

I used to have this problem with Gmail, but I don't anymore.
 

Puntocom

Well-known member
#6
I have also this problem.
Possible solution=> let the user choose, if he want to use the flash uploader or not.

If somebody is using the (default) flash uploader and he reports problems to me, i could disable it for him in the user edit form in the acp and say him to try again:D
+1
 

jmurrayhead

Well-known member
#7
This has been a major annoyance for me when browsing from work. It would be nice to be able to quickly toggle from the flash uploader to a basic uploader from the thread.