1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Error upgrade 1.4 > 1.5

Discussion in 'Resolved Bug Reports' started by HWS, Jul 12, 2015.

  1. HWS

    HWS Well-Known Member

    When upgrading to XF 1.5 you need to make sure you're logged into the ACP before you upload the files.

    Because if you upload the new files and try to log into the ACP afterwards, you get the error:

    Code:
    Server Error
    Undefined index: use_tfa
    
    [LIST=1]
    [*]XenForo_Application::handlePhpError() in XenForo/ControllerHelper/Login.php at line 14
    [*]XenForo_ControllerHelper_Login->userTfaConfirmationRequired() in XenForo/ControllerPublic/Login.php at line 134
    [*]XenForo_ControllerPublic_Login->actionLogin() in XenForo/FrontController.php at line 347
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    [*]XenForo_FrontController->run() in /Users/****/Sites/xf5/index.php at line 13
    [/LIST]
    
    Which is a bug, imho.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. HWS

    HWS Well-Known Member

    I got this error and am not able to login into the ACP and finish the upgrade.

    So I'm stuck with an unusable board. What can I do now, if this is no bug?
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Are you not able to log in to the ACP directly by navigating to /admin.php?
     
  5. HWS

    HWS Well-Known Member

    Correct. Just getting the above error after submitting the login form.
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Navigate directly to install/index.php?upgrade/ instead.
     
  7. HWS

    HWS Well-Known Member

    I solved it by temporarily wrapping "$user['use_tfa']" into '!empty()' in XenForo/ControllerHelper/Login.php at line 14. This made it possible to log into the ACP as admin and finish the upgrade.

    Directly calling /index.php?upgrade/ did not work either, because it also requested me to be logged in (which does not work).
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    It will ask you to log in. But with it being a different controller that doesn't support 2FA you won't get the same error. Did you try to log in? Did it give you the same error?
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I tested it on my localhost and was able to log in and upgrade via the install path.
     
  10. HWS

    HWS Well-Known Member

    I tried it and got the login form at the /install path. Did not try to log in however, because I thought the same error would appear. Was able to solve it as described above.

    Thank you for your help, @Brogan and @Chris D !
     

Share This Page