XF 2.2 Install error on 2.2.10

When doing an upgrade to 2.2.10 I get the following error that I cannot get past:


ErrorException: [E_WARNING] file_put_contents(/var/www/html/community/internal_data/code_cache/templates/l1/s0/admin/option_email_dkim_confirm.php): failed to open stream: Permission denied in src/vendor/league/flysystem/src/Adapter/Local.php at line 199

  1. XF::handlePhpError()
  2. file_put_contents() in src/vendor/league/flysystem/src/Adapter/Local.php at line 199
  3. League\Flysystem\Adapter\Local->update() in src/vendor/league/flysystem/src/Filesystem.php at line 99
  4. League\Flysystem\Filesystem->put()
  5. call_user_func_array() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 431
  6. League\Flysystem\EventableFilesystem\EventableFilesystem->callFilesystemMethod() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 395
  7. League\Flysystem\EventableFilesystem\EventableFilesystem->delegateMethodCall() in src/vendor/league/flysystem-eventable-filesystem/src/EventableFilesystem.php at line 57
  8. League\Flysystem\EventableFilesystem\EventableFilesystem->put() in src/vendor/league/flysystem/src/MountManager.php at line 597
  9. League\Flysystem\MountManager->put() in src/XF/Util/File.php at line 204
  10. XF\Util\File::writeToAbstractedPath() in src/XF/Service/Template/Compile.php at line 146
  11. XF\Service\Template\Compile->writeCompiled() in src/XF/Service/Template/Compile.php at line 43
  12. XF\Service\Template\Compile->recompile() in src/XF/Entity/Template.php at line 435
  13. XF\Entity\Template->_postSave() in src/XF/Mvc/Entity/Entity.php at line 1272
  14. XF\Mvc\Entity\Entity->save() in src/XF/AddOn/DataType/Template.php at line 97
  15. XF\AddOn\DataType\Template->importAddOnData() in src/XF/Job/AddOnData.php at line 110
  16. XF\Job\AddOnData->run() in src/XF/Job/Atomic.php at line 40
  17. XF\Job\Atomic->run() in src/XF/Job/Manager.php at line 260
  18. XF\Job\Manager->runJobInternal() in src/XF/Job/Manager.php at line 202
  19. XF\Job\Manager->runJobEntry() in src/XF/Job/Manager.php at line 153
  20. XF\Job\Manager->runUnique() in src/XF/Install/Controller/AbstractController.php at line 24
  21. XF\Install\Controller\AbstractController->manualJobRunner() in src/XF/Install/Controller/Upgrade.php at line 266
  22. XF\Install\Controller\Upgrade->actionRunJob() in src/XF/Mvc/Dispatcher.php at line 352
  23. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
  24. XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
  25. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
  26. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2353
  27. XF\App->run() in src/XF.php at line 524
  28. XF::runApp() in install/index.php at line 14

Help would be appreciated, thanks.
 
Last edited:

Brogan

XenForo moderator
Staff member
If chmod and chown doesn't resolve it then it's something else server side.

You host will have to assist with identifying the cause.
 
If chmod and chown doesn't resolve it then it's something else server side.

You host will have to assist with identifying the cause.
I ran chmod and chown on the internal_data folder and that fixed the problem. I was able to complete the install. BUT when clicking on the link to enter the admin area I am shown this:

An unexpected error occurred. Please try again later.

I'm able to access the install folder and re-ran the install process which completes fine. I still get the same error. Not sure where to proceed from there.
 
Top