1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't upload

Discussion in 'Troubleshooting and Problems' started by Demon_skeith, Aug 22, 2016.

  1. Demon_skeith

    Demon_skeith Member

    For some reason I can't upload images to my media gallery. I had no issues when I did it a few weeks ago and since then the only thing that really changed was that I upgraded my software to the latest version. It really don't give me a detailed error but:

    The following error occurred

    There was a problem uploading your file.

    *insert file name*



    I've tried several images and even ones that uploaded correctly, nothing works anymore.
     
  2. Mike

    Mike XenForo Developer Staff Member

    Can you add attachments to threads?
     
  3. Demon_skeith

    Demon_skeith Member

    Nope, nowhere on the site.
     
  4. Chris D

    Chris D XenForo Developer Staff Member

    Make sure the data and internal_data directories still exist, and that they are globally writable as well as all of the contents within them and ensure they are owned by the correct user.

    It sounds like it could be a permissions issue.
     
  5. Demon_skeith

    Demon_skeith Member

    Sorry for the late reply and thanks for posting.

    The directories are still there, permissions haven't changed from the ACP side of things and on the server they are 755. Not sure what you mean by correct user but no permissions have been changed recently.
     
  6. Mike

    Mike XenForo Developer Staff Member

    Depending on server setup, 0755 isn't correct. They may need to be 0777. (If there was a change in configuration, the permissions may need to be changed.) This will need to be done recursively (to all the files and directories within).
     
  7. Demon_skeith

    Demon_skeith Member

    I changed all files within Data and internal data to 777 and still get this:

    [​IMG]

    Only thing that has changed on my site other than software updates was this one post issue. I wouldn't think the mod_security would mess with image uploads?
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    It could... have your host/admin check... the reason I say that is the file has ps in it's file name.
    ps is used at the CLI to report a snapshot of the current processes.... so the mod_security rule may be to strict.
     

Share This Page