• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[bd] Widget Framework 2.6.3

No permission to download

HWS

Well-known member
Updated to the recent 2.6.3 Beta 22 and got the following issues on PHP 5.5:

library/WidgetFramework/WidgetRenderer/UserFollow.php: Line 5
Error when editing or adding widgets. Reason: String concatenation is not possible with public static vars.

PHP Callback Widget (with or without wrapper):
The form offers no field to enter callback info and just shows an error "Please enter a valid callback method". I had no time to find out if this is a real bug or also a PHP 5.5 incompatibility.

If this version is not compatible with PHP 5.5 it should be mentioned or checked in update/installation code. Will test it with PHP 7 soon.
 

HWS

Well-known member
Tested with PHP 7:
As expected the first error does not appear any more. It's clearly an incompatibility with PHP 5.5.

The second error however is still there. You cannot create a PHP Callback widget.
 
is anyone else having an issue with the status updates widget after upgrading to 2.6.3beta22? all my statuses never change, show statuses from years ago, doesn't show latest statuses, etc... i've tried messaging the addon author about it but he's not responding to posts or pm's on his website....
 

M@rc

Well-known member
is anyone else having an issue with the status updates widget after upgrading to 2.6.3beta22? all my statuses never change, show statuses from years ago, doesn't show latest statuses, etc... i've tried messaging the addon author about it but he's not responding to posts or pm's on his website....
It's a known bug. I went back to 2.6.3 beta 14 to fix the issue.
 
hey guys,
I have a question: is it possible to integrate a javascript in the widget?
Theoretically it should work with the advanced html & template renderer but in practice I dont get it.
I dont know much about JS and I got a script already set up and "ready to integrate" for ads from a website.
Actually it should work, so I ask if it's possible at all... Or if I'm just too dumb. :D
 
This post is purely an informational one.

IF you're using the Threads renderer to display a list of threads with newest replies, say, on your homepage, and you're using the default (list) view, and you want to include forum node names with the threads (so people know what forum the thread is in), do this:

In template wf_widget_threads find
Code:
<ol class="discussionListItems">
                    <xen:contentcheck>
                        <xen:foreach loop="$threads" value="$thread">
                            <xen:include template="thread_list_item" />
                        </xen:foreach>
                    </xen:contentcheck>
                </ol>
And replace with
Code:
<ol class="discussionListItems">
                    <xen:contentcheck>
                        <xen:foreach loop="$threads" value="$thread">
                            <xen:include template="thread_list_item_wf" />
                        </xen:foreach>
                    </xen:contentcheck>
                </ol>
Then, create a new template called "thread_list_item_wf" and copy into it the contents of your stock "thread_list_item" template. But make one small change. Find:

Code:
                    <xen:username user="$thread" title="{xen:phrase thread_starter}" /><span class="startDate">,
                    <a{xen:if {$visitor.user_id}, ' href="{xen:link threads, $thread}"'} class="faint"><xen:datetime time="$thread.post_date" title="{xen:if {$visitor.user_id}, '{xen:phrase go_to_first_message_in_thread}'}" /></a></span><xen:if is="{$showForumLink}"><span class="containerName">,
                    <a href="{xen:link forums, $thread.forum}" class="forumLink">{$thread.forum.title}</a></span></xen:if>
and take out that if statement, so it looks like this (replace with this):

Code:
                    <xen:username user="$thread" title="{xen:phrase thread_starter}" /><span class="startDate">,
                    <a{xen:if {$visitor.user_id}, ' href="{xen:link threads, $thread}"'} class="faint"><xen:datetime time="$thread.post_date" title="{xen:if {$visitor.user_id}, '{xen:phrase go_to_first_message_in_thread}'}" /></a></span><span class="containerName">,
                    <a href="{xen:link forums, $thread.forum}" class="forumLink">{$thread.forum.title}</a></span>
Yay!
@kontrabass Thank you very much for this. (y)
 
Is their any way to exclude threads from most viewed threads tab?

Tried both !in_array($thread['thread_id'], array(1111,1112)) and $thread['thread_id'] != 1111 as Expression.
 
Hi,

Am looking for the widget to show unanswered threads i.e those threads that were started in the last four weeks timeframe AND that has no replies. How do I implement it?
Thanks.