Resource icon

[bd] Widget Framework 2.6.3

No permission to download

ENF

Well-known member
Can anyone help? I really want to use this add on. @xfrocks
I checked this on a test install.

If you get this message when installing the Addon:
"The files associated with this add-on could not be found. Please upload them and try again."

...it's definitely related to how/where the files were uploaded. I can't produce this error any other way.

In the Widget Addon (latest) pack, for each folder:

./library/ = 78 files & 36 Folders
./js/ = 14 files & 2 Folders

You may wan to double check that the exact count is uploaded to your server via your FTP program or whatever transfer method you use.

In a normal circumstance, I don't get any other error after uploading the files and running the installer XML file.
 

xfrocks

Well-known member
Author of plugin not give me answer about this it is possible add widget for recent posts?? And sidebar snipets from posts how to reduce and limit words in this option, like in IPB.
You can change that in AdminCP > Appearance > Style Properties > [bd] Widget Framework.
 

xfrocks

Well-known member
I'm not doing something right.... i uploaded the contents from the upload folder into their respective folders and try to install the xml add-on but when I do I get this

Error
The files associated with this add-on could not be found. Please upload them and try again.

I went to add-ons > install addons > install from uploaded file.

Do I need to actually upload the xml file (somewhere... not sure where) before trying to install the addon?
You only need to upload files and directories inside "upload" directory. The error message indicated that you haven't uploaded library/WidgetFramework/Listener.php, please try uploading again.
 
We seem to have a bit of inconsistency in displaying the following in forum view. They seem to come and go as they please from forum to forum
  • forum_view (4)
    1. Most Viewed Threads Threads (11)
    2. Most Replied Threads Threads (12)
    3. Most Liked Threads Threads (13)
    4. Forum Polls Threads (14)
 

brstrm

Active member
Hi there.

Looking to hide the sidebar (and thus all widgets) on a single page. Was wondering if there exists an expression that in effect says "Yes, I want this widget to display on all pages except THIS page."

Thanks for all the hard work. Fantastic plugin.
 
You only need to upload files and directories inside "upload" directory. The error message indicated that you haven't uploaded library/WidgetFramework/Listener.php, please try uploading again.
I double checked and I confirmed that Listener.php is indeed installed in the library/WidgetFramework folder :confused:
 
I deleted the files and downloaded a fresh copy from here and did the upload again.

Tried to install the addon by importing the XML... Install Addon > Install from uploaded file (Choose File). Clicked install and I get the same error message.

Again, double checked to see if the listener.php file is installed and it is.

-----------

The only thing I can think of that might causing this is when I unzip the file I get this message (get this for all files):

"Do you want to copy this folder without encryption?
A problem is preventing this folder from being encrypted
Do you want to continue."

I clicked yes... seemed to unzip just fine (showed all files and folders as normal)
When I click no... doesn't unzip any folders... just gives me the addon-widget_framework, changelong, and readme.

Please help me get this running. :(What do I do?
 
I don't know.

I download from the link here... open the zip from my downloads folder and click "extract all files" which places them in a new folder. I'm using windows 7 and I guess I'm not using a true unzipper but doing it this way hasn't caused me any problems in the past.
 

xfrocks

Well-known member
We seem to have a bit of inconsistency in displaying the following in forum view. They seem to come and go as they please from forum to forum
  • forum_view (4)
    1. Most Viewed Threads Threads (11)
    2. Most Replied Threads Threads (12)
    3. Most Liked Threads Threads (13)
    4. Forum Polls Threads (14)
How did you configure those widgets? There may be no threads for some forum therefore they hide themselves.

Hi there.

Looking to hide the sidebar (and thus all widgets) on a single page. Was wondering if there exists an expression that in effect says "Yes, I want this widget to display on all pages except THIS page."

Thanks for all the hard work. Fantastic plugin.
I guess you are using "all" position? Then you can do something like this to show in all pages except forum_view.
PHP:
$_WidgetFramework_positionCode != 'forum_view'
I don't know.

I download from the link here... open the zip from my downloads folder and click "extract all files" which places them in a new folder. I'm using windows 7 and I guess I'm not using a true unzipper but doing it this way hasn't caused me any problems in the past.
Yeah, Windows extract tool should work. Please start a conversation with me with your FTP info, I will come by and take a look.
 
Can anyone help me out? I've been trying to install this addon for ages now. I've downloaded the file, clicked and dragged the js and library file into their folders in my filezilla, and then go to the admin area, and hit install addon, put the XML file in, and press install it says:
"The files associated with this add-on could not be found. Please upload them and try again."
Can anyone help me out? I'm kinda new to this.
 

xfrocks

Well-known member
Can anyone help me out? I've been trying to install this addon for ages now. I've downloaded the file, clicked and dragged the js and library file into their folders in my filezilla, and then go to the admin area, and hit install addon, put the XML file in, and press install it says:
"The files associated with this add-on could not be found. Please upload them and try again."
Can anyone help me out? I'm kinda new to this.
If you give me your FTP info in a conversation, I will come by and check.
 
Hi @xfrocks

i just ran into a funny problem. The Position thing seems not to work when the Clear Sidebar Widget is active.

As in your hint:
Or you can input a comma separated list of templates that need the widget.
when i put in something else than all like forum_list or thread_view in the position, the desired widget (a template wrapper) is not showing up (also not a standard widget like forum statistics or something else) when the Clear Sidebar is active.

BUT when i deactivate the Clear Sidebar then everything works fine with the template positioning.

Interesting is also that when i put all in the position AND controller == 'XenForo_ControllerPublic_Thread' in the expression, the desired behaviour is showing up no matter if the Clear Sidebar is activated or not.

Any ideas, why this happens?
 
Top