1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Android 2.2: can't type to editor

Discussion in 'Resolved Bug Reports' started by goyo, Jul 29, 2010.

  1. goyo

    goyo Member

    I've just browsed with an Android Froyo stock browser.

    The funny thing is the wysiwyg editor displays fine but I can't type in to it thus can't start/reply to a thread.
  2. BamaStangGuy

    BamaStangGuy Well-Known Member

    This should eventually have a mobile style anyways.
  3. Floris

    Floris Guest

    I think the alpha is too early to do proper alpha testing for mobile, but it's in the planning. I've tested in iPad and can type, but couldn't get richtext editor.
  4. Mike

    Mike XenForo Developer Staff Member

    Rich text doesn't work in mobile browsers - it's really down to them not triggering the keyboard for contentEditable stuff. We do have checks to prevent mobile WebKit from getting it, which should work for Android, but I guess I'll have to check it with an emulator.

    Alternatively, can you get the full user agent string from the Android browser?
  5. Disjunto

    Disjunto Well-Known Member

    My Desire (Running 2.1 Sense Stock) reports itself as running Mac OS X for some strange reason

    Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17
    If I run it in "Mobile" mode I get a more reasonable

    Mozilla/5.0 (Linux; U; Android 2.1-update1; en-gb; Desire_A8181 Build/ERE27) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17
  6. Mike

    Mike XenForo Developer Staff Member

    I've tweaked the user agent check so it should pick up the mobile version of Android. I don't see anyway of detecting it from the first user agent.
  7. Cezz

    Cezz Well-Known Member

    I think that was the idea, the first code is made to emulate a desktop browser and stop sites from displaying mobile version if you didn't want them to.
  8. Mike

    Mike XenForo Developer Staff Member

    There's usually a hint that you can use to figure out the real browser. But it's just a shame here, as it reports that something works ... except it doesn't. And that destroys the experience.

    Either way, provided you're not masquerading, it should be working now.
  9. Disjunto

    Disjunto Well-Known Member

    I always make my phone say it's a desktop, simply because I hate the mobile pages. Hopefully 2.2 actually treats the WYSIWYG correctly so I can type on xf boards in the future. Can you not get anything out of the Safari version #? Or is that also the same as desktop builds?
  10. Darfuria

    Darfuria Active Member

    How was this resolved? I've got a user having exactly the same issue.
  11. Mike

    Mike XenForo Developer Staff Member

    Mobile Safari doesn't get the WYSIWYG editor. If they're masquerading as a desktop browser, there's really nothing we can do to pick it up.
  12. ChemicalKicks

    ChemicalKicks Well-Known Member

    Another thing I've noticed is that although it is super easy to upload pictures directly from my phone I'm not being shown thumbnails of the images I want to upload, some weird flash screen is being triggered instead of the normal picture view that I would get on the vast majority of sites. So I'm flying blind when trying to pick the correct picture.

    Settings wise my phone is presenting as a desktop and I noticed the problem the OP states, the way I got around this was to disable WYSIWUG in my options. Here's what I see on my phone when I want to upload a picture.

  13. Jeremy P

    Jeremy P Well-Known Member

    That's because the software uses flash (swfupload) to enable multiple simultaneous uploads. Don't think it can be disabled, or worked around really if your phone is presenting itself as a desktop. The WYSIWYG problem is also probably caused by that, since the software can't detect you're on mobile and disable it.
  14. ChemicalKicks

    ChemicalKicks Well-Known Member

    Okay what I'll do then is switch my phone back to mobile browser and try and upload a picture.
  15. ChemicalKicks

    ChemicalKicks Well-Known Member

    Switched mobile view back on, cleared cache and attempted again. Same thing.

    With mobile view on and Full WYSIWYG on still the same, anyone else getting this, bit of a shame. :(
  16. ChemicalKicks

    ChemicalKicks Well-Known Member

    Ahhhhhh, if I turn flash off on my phone I get what I'm looking for. I gather then for iOS devices this is a non-issue then?
  17. Jeremy P

    Jeremy P Well-Known Member

    Running Android 2.3 stock browser I don't get WYSIWYG. Never tried to upload anything, but I don't have Flash installed anyways, in which case it falls back to a regular file upload.
  18. ChemicalKicks

    ChemicalKicks Well-Known Member

    Cheers Jeremy P, I thought all Android phones came with Flash installed, guess not.

Share This Page