Resource icon

Ads Manager 2 by Siropu [Paid] 2.1.3

No permission to buy (€49.99)

duderuud

Well-known member
Tried to upgrade from b5 to b6. Got the same error as from b4 to b5 (I didn't disable the add-on first, my bad).

So I disabled all listeners in the XF config file (that worked with b5).

But still the forum is not working:

Code:
An exception occurred: [TypeError] Argument 3 passed to XF\Template\Templater::fnCssUrl() must be of the type array, string given in src/XF/Template/Templater.php on line 2004

    XF\Template\Templater->fnCssUrl()
    call_user_func_array() in src/XF/Template/Templater.php at line 877
    XF\Template\Templater->fn() in /mnt/storage/internal_data/code_cache/templates/l3/s8/public/helper_js_global.php at line 39
    XF\Template\Templater->{closure}() in src/XF/Template/Templater.php at line 659
    XF\Template\Templater->callMacro() in /mnt/storage/internal_data/code_cache/templates/l3/s8/public/PAGE_CONTAINER.php at line 2329
    XF\Template\Templater->{closure}() in src/XF/Template/Templater.php at line 1246
    XF\Template\Templater->renderTemplate() in src/XF/Pub/App.php at line 449
    XF\Pub\App->renderPageHtml() in src/XF/App.php at line 1724
    XF\App->renderPage() in src/XF/Mvc/Dispatcher.php at line 310
    XF\Mvc\Dispatcher->render() in src/XF/Mvc/Dispatcher.php at line 44
    XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1889
    XF\App->run() in src/XF.php at line 328
    XF::runApp() in index.php at line 13

With listeners enabled it gives me this error:

Code:
An exception occurred: [Error] Call to a member function getUnitCssClass() on integer in src/addons/Siropu/AdsManager/Listener.php on line 138

    Siropu\AdsManager\Listener::Siropu\AdsManager\{closure}()
    call_user_func_array() in src/XF/Template/Templater.php at line 877
    XF\Template\Templater->fn() in /mnt/storage/internal_data/code_cache/templates/l3/s8/public/siropu_ads_manager_ad_macros.php at line 83
    XF\Template\Templater->{closure}() in src/XF/Template/Templater.php at line 659
    XF\Template\Templater->callMacro() in /mnt/storage/internal_data/code_cache/templates/l3/s8/public/PAGE_CONTAINER.php at line 2533
    XF\Template\Templater->{closure}() in src/XF/Template/Templater.php at line 1246
    XF\Template\Templater->renderTemplate() in src/XF/Pub/App.php at line 449
    XF\Pub\App->renderPageHtml() in src/XF/App.php at line 1724
    XF\App->renderPage() in src/XF/Mvc/Dispatcher.php at line 310
    XF\Mvc\Dispatcher->render() in src/XF/Mvc/Dispatcher.php at line 44
    XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1889
    XF\App->run() in src/XF.php at line 328
    XF::runApp() in index.php at line 13
 

Siropu

Well-known member
Error doesn't seem to be related to Ads Manager.

P.S. For users who upgraded to Beta 6 and receiving some errors in the ACP re-download it, as I made a small change to address that.
 

duderuud

Well-known member
Seems it does.

I fixed it by disabling all the add-ons with the cmd.php cli tool and was able to upgrade from b5 tot b6. Now it's working again.
 
Just tested new version, if I put align center (code ads) is not showing, if I put auto is showing but not on the homepage, I haven't set any option to not show there, pretty strange. On the other page, it shows at every refresh.

The upgrade went without problems.
 
@I. C. Daniel, make sure that the siropu_ads_manager_ad.less template is not outdated.
You right, there was an outdated template, then I went ahead and merge it, and I switch from auto to center and the ads stop showing.
Tried with a different browser same thing. Browse multiple pages same thing no ads.

Went back and enabled auto and the ads start showing on each refresh except the homepage. However, when I put ads with the advertising option built by Xenforo ads shows on the homepage. I believe there is still a glitch, you wait for more reports to see if this is a real bug.
 
Top