[8WR] XenCarta (Wiki) PRO

[8WR] XenCarta (Wiki) PRO [Paid] 1.4.8a

No permission to buy ($30.00)
Is it still not possible to control how the navigation is displayed? I really would love to use this Wiki addon for my site, as we are getting to the point to where we need to start making a detailed wiki for the project that my site focuses around. Although I don't feel I can make an easy to navigate wiki without being able to control the navigation blocks. Being able to sort them or something in some way is a must for me, and I don't see how it's not an issue with others.
 

arms

Well-known member
What am i doing wrong?

Created a slug
Code:
[template=myiconROW] name=Construction| slug=construction[/template]

click on the link , it goes to

upload_2013-10-3_21-20-28.png

click on the "create new page" and i get
upload_2013-10-3_21-21-53.png

"The requested page could not be found."
 

Eelviny

Member
Is it possible to make certain pages only accessible to certain usergroups? At this point I'm just hiding pages, but if someone were to pass the link off to someone that wasn't supposed to see that page, they'd still be able to see it.

Thanks!
I agree that this is needed too... A wiki holds information, that is it's point, but I want to be able to give information to only staff members.
 

XenStyle

Active member
@Jaxel any idea why 3rd party table BB code addons do not work with xencarta? I assume it has to do with some parent style for tables in Xencarta already.

I cannot figure out how to do a basic table using bb code or templates with just xencarta though, so had to go to a 3rd party addon
 

wtgw

Member
I agree that this is needed too... A wiki holds information, that is it's point, but I want to be able to give information to only staff members.

I 3rd this feature. Usergroup x has access to this page, and a message showing why.
 

Fleur

Member
Each page needs a page status.
It's been explained in the previous post a year ago.

For every page, there is a default status -> "Draft", "Production", "Needs QA".
When the page is "Needs QA", "Draft" it is hidden from all users.

So:
- when you create a Xencarta page, the default status is Draft.
- there is a combo-box at the bottom to change the page status.
- This is different from other Xenforo add-ins where status refers to a user.

XenCarta Page Status Table:
- ID, Page Status Name, Comments (not visible), Visible?

XenCarta Wiki Page ->
- extra field - Link to foreign key ID from table Page Status Table.

By doing so, you can QA (quality assurance) easier. You can then make it easier to proof-read the Wiki you create.

It's something like this http://xenforo.com/community/resources/avforums-com-moderator-checkpoint-system.2131/ where you check-point system to check each and every Xencarta page.
 

ElChristo

New member
Hi, bought the addon a week or so ago and been getting used to it.
I seem to have came across a problem though. I've created a page, and the 'Mark Page as Protected' is always checked. I tried unchecking it and saving the page, but it doesn't seem to save that change.
Any help from anyone would be greatly appreciated :).

The page has a <table> and an attachment if these make a difference.
 
How do you disable reverting edits for users without disabling access to the history?

I want users to be able to view the history, but block them from reverting changes - that's for admins only.

How to do this? :)
 

OwenJames

Active member
Hi

I bought this today, after trying out the free version.

I uninstalled the free version, then installed the pro version.

Everything seems to have installed properly, as the Wiki shows up on the forum, but when I click on 'Create New Page', I get the following error;

'The requested page could not be found'

I have all the permissions set to yes for the admin user I am logged in with.

Any ideas what this might be?
 

Jaxel

Well-known member
Hi

I bought this today, after trying out the free version.

I uninstalled the free version, then installed the pro version.

Everything seems to have installed properly, as the Wiki shows up on the forum, but when I click on 'Create New Page', I get the following error;

'The requested page could not be found'

I have all the permissions set to yes for the admin user I am logged in with.

Any ideas what this might be?
Where is it sending you? "wiki/special/create"?

Check to make sure all the files got uploaded correctly.
 

OwenJames

Active member
Where is it sending you? "wiki/special/create"?

Check to make sure all the files got uploaded correctly.

Thanks for the reply.

I fixed the problem by reverting all the templates to their original form (I had modified the main .css file on the free version).

Another question; can anyone give me a run through of how the template system works. I mean, I can see how to make a template, but then what? Can the users use this for creating pages, or is it something only the admins can use, etc?

Thanks
 

Jaxel

Well-known member
Another question; can anyone give me a run through of how the template system works. I mean, I can see how to make a template, but then what? Can the users use this for creating pages, or is it something only the admins can use, etc?
Only admins can create templates... but anyone can use them.
 

OwenJames

Active member
OK thanks.

So, once the template is created and saved, how is it then used by Admin to Create a Page? I don't see any way to insert a template into the Create a Page screen...?
 
Top