XF2 [8WR] XenPorta 2 (Portal) PRO

XF2 [8WR] XenPorta 2 (Portal) PRO [Paid] 2.2.0.7

No permission to buy ($40.00)

SynBay

Member
How can i show a html widget in Position XenPorta->Articles list:Above only above special categories?

I'm looking for a template condition, something like that:

<xf:if is="$category == '/article/categoriy/sub-category-1'">
Show content...
</xf:if>

Is there something like that available or what would be the right way todo it? Thanks a lot for help.
 

Kent Clark

Member
Xenforo 2, Xenporta 2 with the Themehouse Tactical and TH UI.X framework. They say it doesnt change the core or hooks, any ideas.

I installed this fresh install didnt have a problem until I went to add a catagory then I got these two errors of an outdated Theme but its Xenporta related.

Any help would be great, im a noob with this so if you could go slow that would be great.

Thanks
 

Attachments

  • brave_nzaVuQIbQs.png
    brave_nzaVuQIbQs.png
    260.3 KB · Views: 31

Kent Clark

Member
I should of read this thread before purchase, its a train wreck in here.

I posted the above post, can anyone p[oint me in the right direction, I can do the work but I need someplace to start. Jaxel said I altered the default style but all I did was install Xenporta. Got those errors, Ive tried it with the UI.X from TH and without, same issue. Stayed with the default style.
 

djbaxter

Well-known member
What exactly is the "Enable portal header" option supposed to do. The Xenporta page looks the same with or withoput that checked.
 

Jaxel

Well-known member
What exactly is the "Enable portal header" option supposed to do. The Xenporta page looks the same with or withoput that checked.
Breadcrumbs and title.

I should of read this thread before purchase, its a train wreck in here.

I posted the above post, can anyone p[oint me in the right direction, I can do the work but I need someplace to start. Jaxel said I altered the default style but all I did was install Xenporta. Got those errors, Ive tried it with the UI.X from TH and without, same issue. Stayed with the default style.
I told you to revert templates.
 

Jaxel

Well-known member
How can i show a html widget in Position XenPorta->Articles list:Above only above special categories?

I'm looking for a template condition, something like that:

<xf:if is="$category == '/article/categoriy/sub-category-1'">
Show content...
</xf:if>

Is there something like that available or what would be the right way todo it? Thanks a lot for help.
$category is accessible I believe.
 

Kent Clark

Member
Breadcrumbs and title.


I told you to revert templates.
Am I supposed to understand what that even means, Revert templates?

I didnt change any templates why am I reverting one?

I can undue what I have done but if I havent changed anything like a template this means nothing to me.
 

webbouk

Well-known member
Perhaps an attitude adjustment is required instead!

A simple and polite question is all that is needed to get the answers you require; your ignorance is not an excuse for bad manners.
 

Kent Clark

Member
Perhaps an attitude adjustment is required instead!

A simple and polite question is all that is needed to get the answers you require; your ignorance is not an excuse for bad manners.
really? Ive been asking this same question for a week in many different ways, I can see no one wants to help, not even the developer so ive moved onto sarcasm. This lets anyone who is thinking about buying this turd in the future this is what they have look forward to. Maybe a notice that you need to have experience with CSS or something - Not that this guy cares.

I made the switch to Xenforo from VB and now Im stuck here. Oh well, never had this problem on the VB forum or maybe its just that forum software is just dead. To many other options out there.

Looks like ill take a stab at Mastodon or Pleroma.

Not sure what else to do. I like the Themehouse style more then I like the Portal so you can guess which one is going. Also TH has a real support for their products.

Again this is a reply to you, but also anyone else who is thinking about buying this turd. My opinion of course.
 

leelo

New member
Hi, my URL looks like this ewr-porta/categories/bao-hiem-tin.4/
How can I remove ewr-porta or rename it?
thank you
 

Mr. Wah

Member
Xenforo 2, Xenporta 2 with the Themehouse Tactical and TH UI.X framework. They say it doesnt change the core or hooks, any ideas.

I installed this fresh install didnt have a problem until I went to add a catagory then I got these two errors of an outdated Theme but its Xenporta related.

Any help would be great, im a noob with this so if you could go slow that would be great.

Thanks

I recently had issues with styling after upgrading both my UI.X and EWRPorta2. The way I fixed my styling issues was by manually copy and pasting the EWRporta_articles.less style from the latest version's upload\src\addons\EWR\porta\_data\templates.xml file. You can find what the text for this style should be by looking for <template type="public" title="EWRporta_articles.less" version_id="2206" version_string="2.2.0.6"> so in case it might help you, copy the text after <![CDATA[ and before ]]></template> then paste over all the text in your EWRporta_articles.less template in your style within your Admin Control Panel.

Doing that corrected my styling issues. Hopefully it helps you.
 

Jaxel

Well-known member
I recently had issues with styling after upgrading both my UI.X and EWRPorta2. The way I fixed my styling issues was by manually copy and pasting the EWRporta_articles.less style from the latest version's upload\src\addons\EWR\porta\_data\templates.xml file. You can find what the text for this style should be by looking for <template type="public" title="EWRporta_articles.less" version_id="2206" version_string="2.2.0.6"> so in case it might help you, copy the text after <![CDATA[ and before ]]></template> then paste over all the text in your EWRporta_articles.less template in your style within your Admin Control Panel.

Doing that corrected my styling issues. Hopefully it helps you.
You could have accomplished this by just reverting your templates.
 

Mr. Wah

Member
You could have accomplished this by just reverting your templates.

This is incorrect. Reverting my template would load the much older version of the EWRPorta_article.less.

For example it would alter:
Code:
        .porta-header-image
        {
            background-position: center;
            background-size: cover;
            height: @xf-EWRporta_header_image;
        }
to
Code:
        .porta-header-image
        {
            background-position: center;
            background-size: cover;
            height: @xf-EWRporta_header_height;
         }

Which was one of the issues I was having as EWRporta_header_height doesn't exist (any more?) and was replaced with EWRporta_header_image presumably.

So "Reverting" can cause the issue or not fix the issue as "simply as" copying the code from the template to .less directly.
 

Jaxel

Well-known member
This is incorrect. Reverting my template would load the much older version of the EWRPorta_article.less.
Revert templates will load whatever is the most recent version of a template. That's what it does.

If it doesn't then your addon was not built properly when you installed/upgraded it.
 

est3ban129

Active member
the titles with white letters and black border don't look too good, does anyone have a good solution?
I've been trying some alternative colors but nothing convinces me

I accept suggestions

Captura.JPG

the white lettering is too faded, it does not read correctly I think.
 
Hi It's just a quick question. I want to have 2 widgets showing articles, with and another block in between in the side bar. The problem is that I want the first block to show the latest article and the second to start with the next article. at the moment if I just add the two blocks the first article is repeated..

Hope that makes sense

Many thanks
 

est3ban129

Active member
I have added xenporta to my website but in the mobile view it doesn't look good.
A blank space appears on one side, how can I fix it?

photo_2021-03-20_11-59-56.jpg

also the gradient is black in the mobile view and it is not good, thanks
 

Itworx4me

Well-known member
@Jaxel I am getting this error when running XenPorta
Code:
Server error log
ErrorException: Template error: [E_USER_WARNING] Method isPortaArticle is not callable on the given object (XFMG\XF\Entity\Thread) src/XF/Template/Templater.php:1161
Generated by: Unknown account Mar 24, 2021 at 6:54 PM
Stack trace
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, '[E_USER_WARNING...', '/home/nginx/dom...', 1161, Array)
#1 src/XF/Template/Templater.php(1161): trigger_error('Method isPortaA...', 512)
#2 internal_data/code_cache/templates/l1/s18/public/post_macros.php(459): XF\Template\Templater->method(Object(XFMG\XF\Entity\Thread), 'isPortaArticle', Array)
#3 src/XF/Template/Templater.php(799): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#4 internal_data/code_cache/templates/l1/s18/public/post_macros.php(59): XF\Template\Templater->callMacro('post_macros', 'post_user_conte...', Array, Array)
#5 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#6 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('user_content', Array, Array, Object(XF\Template\ExtensionSet))
#7 internal_data/code_cache/templates/l1/s18/public/post_macros.php(93): XF\Template\Templater->renderExtension('user_content', Array, Object(XF\Template\ExtensionSet))
#8 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#9 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('content', Array, Array, Object(XF\Template\ExtensionSet))
#10 internal_data/code_cache/templates/l1/s18/public/post_macros.php(122): XF\Template\Templater->renderExtension('content', Array, Object(XF\Template\ExtensionSet))
#11 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#12 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('main_cell_inner', Array, Array, Object(XF\Template\ExtensionSet))
#13 internal_data/code_cache/templates/l1/s18/public/post_macros.php(136): XF\Template\Templater->renderExtension('main_cell_inner', Array, Object(XF\Template\ExtensionSet))
#14 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#15 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('main_cell', Array, Array, Object(XF\Template\ExtensionSet))
#16 internal_data/code_cache/templates/l1/s18/public/post_macros.php(148): XF\Template\Templater->renderExtension('main_cell', Array, Object(XF\Template\ExtensionSet))
#17 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#18 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('full_body', Array, Array, Object(XF\Template\ExtensionSet))
#19 internal_data/code_cache/templates/l1/s18/public/post_macros.php(178): XF\Template\Templater->renderExtension('full_body', Array, Object(XF\Template\ExtensionSet))
#20 src/XF/Template/Templater.php(799): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#21 internal_data/code_cache/templates/l1/s18/public/thread_view.php(823): XF\Template\Templater->callMacro('post_macros', 'post', Array, Array)
#22 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#23 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('thread_view', Array)
#24 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#25 src/XF/Mvc/Dispatcher.php(458): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#26 src/XF/Mvc/Dispatcher.php(440): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#27 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#28 src/XF/Mvc/Dispatcher.php(58): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#29 src/XF/App.php(2326): XF\Mvc\Dispatcher->run()
#30 src/XF.php(488): XF\App->run()
#31 index.php(20): XF::runApp('XF\\Pub\\App')
#32 {main}
 
Top