XF2 [8WR] XenPorta 2 (Portal) PRO

XF2 [8WR] XenPorta 2 (Portal) PRO [Paid] 2.2.0.7

No permission to buy ($40.00)

ShikiSuen

Well-known member
Hey, Jaxel. Would you please help me test the compatibility between this addon and my CSCN Anniversary style?

Mendalla showed me his concerns about that:
1608547751643.png
 

Mendalla

Well-known member
Hey, Jaxel. Would you please help me test the compatibility between this addon and my CSCN Anniversary style?

Mendalla showed me his concerns about that:
View attachment 242622
I will get a screenshot in a bit. I actually removed CSCN while fixing a problem yesterday so need to reload it.
 

Mendalla

Well-known member
Here is what I am getting. This happens with the Masonry default shown below (or any px value in that box as far as I can tell). If I blank that box to use variable box heights, it is fine.

CSCN Xenporta Setting 1.png

Gets this. Note the middle column. If I switch to another style, like default or my board's custom (based on Flat Awesome+ from Pixelexit), the tops line up.

CSCN Xenporta 1.png

Hope this helps you sort it out @ShikiSuen. I can use a different configuration in Xenporta to get around it, but it came to mind as a "glitch" that might be notable when I was posting about your style.
 

ShikiSuen

Well-known member
Here is what I am getting. This happens with the Masonry default shown below (or any px value in that box as far as I can tell). If I blank that box to use variable box heights, it is fine.

View attachment 242643

Gets this. Note the middle column. If I switch to another style, like default or my board's custom (based on Flat Awesome+ from Pixelexit), the tops line up.

View attachment 242644

Hope this helps you sort it out @ShikiSuen. I can use a different configuration in Xenporta to get around it, but it came to mind as a "glitch" that might be notable when I was posting about your style.
Looks like it requires a data-template-specific LESS template to rule how flex-boxes behave in any of such portal page.
If I'm gonna deal with this issue myself, then I'm afraid I have to buy a license from the dev.
Or, the dev install this theme to his demo forum (as a user-choosable non-default theme), and I view his demo forum to use Microsoft Edge (Chromium ver.) browser to inspect the CSS to see how the solution can go.

Or... Could you please do not uninstall this theme on your main site for a few days? Just leave this theme as non-default and I believe that not pretty much people will notice its existence.
 

ScratchMang

Member
I'm trying to get the Portal Page to follow the theme colours with little success... So For example my portal page (Latest posts) looks like this in the "Blue Theme" Note the White text..

1608562997293.png

However the forums themselves are setup like this...

1608563048006.png

Note the Blue text, same for when the Theme is in Red or Green...

1608563125076.png

Would like to get he Front page to match so when someone is using the RED Theme the text on the portal page is in RED, Green when in the Green theme and so on....
 

Mendalla

Well-known member
Or... Could you please do not uninstall this theme on your main site for a few days? Just leave this theme as non-default and I believe that not pretty much people will notice its existence.
It has never been on my main site, I have just been playing with it in my dev. I'll probably leave it up for now anyway to tinker with some more.
 

ShikiSuen

Well-known member
@Jaxel May I suggest you to use flexbox or flexgrid in lieu of inline block, please?

Flexbox and flexgrid are comparatively modern comparing to inline block. Your plugin will have better compatibility with my CSCN anniversary style if using flexbox or flexgrid.

1608563545964.png
 

ShikiSuen

Well-known member
It has never been on my main site, I have just been playing with it in my dev. I'll probably leave it up for now anyway to tinker with some more.
The CSS coding of this addon is too vintage, considering the HTML5 abilities that Chrome / Safari / FireFox shares in this year.
Flex is far better than blocks.
 

l3ta

Well-known member
I'm trying to get the Portal Page to follow the theme colours with little success... So For example my portal page (Latest posts) looks like this in the "Blue Theme" Note the White text..

View attachment 242648

However the forums themselves are setup like this...

View attachment 242649

Note the Blue text, same for when the Theme is in Red or Green...

View attachment 242650

Would like to get he Front page to match so when someone is using the RED Theme the text on the portal page is in RED, Green when in the Green theme and so on....
Put the following code in your blue style extra.less template:


[data-template="EWRporta_articles_index"] {.structItem-title a{ color: #26c3f6; }}

If it works, use it on all your other styles. Just change the link colour.
 

Jaxel

Well-known member
The CSS coding of this addon is too vintage, considering the HTML5 abilities that Chrome / Safari / FireFox shares in this year.
Flex is far better than blocks.
It's basically only changing 3 lines of code. I never changed them from blocks to flexboxes, because there was no advantage to them at the time. Why change from blocks, which had 100% browser compatibility, to flexboxes, which were new and had limited browser compatibility at the time. It's several years later now, and flexboxes are supported in every browser now. And as I said, its only changing 3 lines of code... so I've updated them to flexboxes for the next release.
 

ShikiSuen

Well-known member
It's basically only changing 3 lines of code. I never changed them from blocks to flexboxes, because there was no advantage to them at the time. Why change from blocks, which had 100% browser compatibility, to flexboxes, which were new and had limited browser compatibility at the time. It's several years later now, and flexboxes are supported in every browser now. And as I said, its only changing 3 lines of code... so I've updated them to flexboxes for the next release.
I am not blaming you. Sorry for making you not feeling well.

Considering that even the latest Microsoft Edge Chromium runs on Windows 7, plus the Chromium-based 360 Extreme Browser runs on Windows XP. These browsers support Flexbox and Flexgrid well.

Note that there might be better choice than 360 browsers for Windows XP users: http://www.xpbrowsers.com/
 

ScratchMang

Member
Put the following code in your blue style extra.less template:


[data-template="EWRporta_articles_index"] {.structItem-title a{ color: #26c3f6; }}

If it works, use it on all your other styles. Just change the link colour.

Awesome, worked like a charm, Thank you!
 

Itstest

New member
Hello, how I can delete the preview of the content of article ? The articles should be presented as a picture, with the heading, no preview of the content. Only the background Image and the headline like on a simple Blog
 
Top