• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Service issue WYSIWYG editor - Copy/Paste issue when pasting via right-click

Alien

Well-known member
#1
Hello.

One of my members had just brought this to my attention, and I was able to confirm it as well with the latest version of Firefox 3.6.15/Win7 (and it happens on this site as well).

Scroll down to Quick Reply, type some gibberish then IMMEDIATELY right-click at the end of your gibberish to paste some text that has been copied and you will see it highlight and remove all of your previous text.

This does not occur in the non-wysiwyg editor, and I was unable to reproduce this in the latest version of "that other forum software". :)
 

Rudy

Well-known member
#5
I had that happen to me maybe once or twice, but I'm unable to reproduce it now.

One thing I wish is that the editor would always post in plain text from the clipboard. If there is an option to set for the editor, I'm willing to change it. I have a feeling that odd copy/paste issues (including above) may come from the clash of having "clean" typed-in input mashed together with formatted code coming from a paste. Going to the BBCode editor, it often looks like a trainwreck. It's not an XF issue, but an issue with the editor.
 

Brogan

XenForo moderator
Staff member
#6
You can set the editor to be plain text by default in your preferences.

You can remove formatting from the WYSIWYG editor by highlighting the content and clicking the eraser icon in the top left corner.
 

Rudy

Well-known member
#7
You can set the editor to be plain text by default in your preferences.
I don't want the editor to be plain text, but just have the copy/paste function paste in text without the formatting. This would be similar to using Paste Special/Paste as Unformatted Text in MS Word, for instance. It's too much of a bother to highlight the affected text and click the eraser as, some of the time, it does not remove all of the formatting (as evidenced by going to BBCode view and seeing there's some formatting left behind). If I copy text from a website to paste into a post of mine, I don't want the formatting to follow.

You would think there might be an option for this, not in XF but in the configuration of the editor within the XF code. I haven't looked at the editor code in a few years (I used an earlier version of TinyMCE for another project I was working on).
 

Peggy

Well-known member
#10
This happens to me ALL the time, and only on a XenForo forum, in FF.

Whenever I type anything in the text editor, if I go copy text from somewhere else and attempt to paste it after what I've already typed,
the text I've already typed gets highlighted and deleted. Darned irritating. :mad:
 

Alien

Well-known member
#16
So this is in a fixed forum, but it's still an issue in a library that needs fixing from TinyMCE or Firefox? We might need another sub-forum. ;)

Or is this actually resolved?
 

Alien

Well-known member
#20
I've been scanning through their bug reports on their site (and I can reproduce the problem there too as Mike has mentioned previously), but I haven't found an exact bug match just a few *close* matches. If it hasn't made it over there yet, I can always take care of it later.