• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

MG 1.1 Video could not be processed error

51463

Well-known member
#1
I keep getting this message when i upload videos.

Unfortunately, the video file you uploaded named My Car Video could not be processed. Please upload a different video and try again.


It was working last month. Im not sure exactly when it stopped worked. What could be the problem. I tried 2 different videos and 2 different file types.

I remember installing ffmpeg a while ago and it was working.

Do i need to upgrade? or re-install?


Code:
XenForo_Exception: Video uploaded by mr magoo named My Car Video failed to be transcoded. - library/XenGallery/Helper/Video.php:575
Generated By: Unknown Account, Today at 7:34 PM
Stack Trace

#0 /home/website/public_html/library/XenGallery/Helper/Video.php(476): XenGallery_Helper_Video->_transcodeException(Array, 'xengallery_vide...', Array)
#1 /home/website/public_html/library/XenGallery/Helper/video-transcode.php(48): XenGallery_Helper_Video->finalizeTranscode(Array, '/home/website...')
#2 {main}

Request State

array(3) {
  ["url"] => string(7) "http://"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}

I am running the latest versions



.
.
 

Chris D

XenForo developer
Staff member
#2
Generally, if you go to Gallery Options > Video Options and the options to transcode are all enabled (FFmpeg binary path and PHP binary path need to be filled in and correct, too) and you click save, you will get errors if anything isn't set up correctly.

If you don't get any errors and it still doesn't work, try and send me one of the videos, if possible.
 

51463

Well-known member
#3
i didn't get any errors after saving, i also tried an .mp4 and it uploaded fine,


I've had problems with .mpg, .avi, & 1 .flv file but another flv video worked fine



These are my settings,

1.PNG


Here is my ffmpeg info

2.PNG



Here is one of the videos i tried to upload, .wmv file(2.49MB)

http://www.filedropper.com/wontwork


here is an .flv video that won't work (bars and tone)
http://www.mediacollege.com/adobe/flash/video/tutorial/example-flv.html


here is an .avi video that uploads and plays but the thumbnail doesn't work (drop & flame)

http://www.engr.colostate.edu/me/facil/dynamics/avis.htm

.
.
 
Last edited:

51463

Well-known member
#4
Also i want to note, something i found out tonight

In the media gallery on xenforo here it says under allowed extensions:

asasd.PNG


I tried to upload:
.avi
.mov
.ogg
.webm
.wmv

and i got this message

2.PNG



I was only able to successfully upload mp4 & m4v here on xenforo.com

And as you can see the thumbnails did not work.

22.PNG



So i believe it's not only my server,



Here are the 7 video files i used,
http://www.filedropper.com/samplevideos



.
.
 
Last edited:

Mike

XenForo developer
Staff member
#5
FFmpeg was somewhat recently disabled here, so that's not particularly surprising -- without it, only one format is supported. I'll need to re-enable it.
 

Chris D

XenForo developer
Staff member
#6
Here is one of the videos i tried to upload, .wmv file(2.49MB)

http://www.filedropper.com/wontwork
Works:

upload_2016-2-26_12-52-8.png

This also works but it didn't generate a thumbnail -- that's not a massive concern, though.

here is an .avi video that uploads and plays but the thumbnail doesn't work (drop & flame)

http://www.engr.colostate.edu/me/facil/dynamics/avis.htm
Works fine.

upload_2016-2-26_13-28-17.png
All 7 worked fine (2 didn't require transcoding).

I would try a different FFmpeg version, and look at what changes you have made since it last worked. Something will have changed on the server to trigger this to stop working.
 

51463

Well-known member
#7
I guess the problem was my ffmpeg.
either:

1. I didn't install it right or;
2. my ffmpeg version was old or corrupt

i will never know..

I ended up searching online and finding an Free FFMPEG autoinstaller.

Here's the website:
http://ffmpeginstaller.com/


I used putty and following these instructions:
http://thoaimedia.com/how-to-install-ffmpeg-auto-installer-on-centos/


Code:
mkdir ~/ffmpeg-packages
cd ~/ffmpeg-packages
wget http://LINKTO NEWEST VERSION HERE
tar -xvzf ffmpeginstaller.8.0.tar.gz
cd ffmpeginstaller.8.0
./install.sh

it was so easy!

This autoinstaller not only installed ffmpeg, but installed a bunch of other things, not sure if i needed them...

ff.PNG

but oh well.. there's no option to only install ffmpeg

anyways.. ffmpeg now works!


After installing that, and restarting my server,

I tried those 7 videos and...

All 7 uploaded fine and playback is fine

3 of them(AVI, MP4, OGG) the thumbnails didn't work


i really hate ffmpeg.. i'm not skilled enough to install it.. other then using an autoinstaller

i dont like using the terminal because im not good with it yet,


if someone isn't skilled, you can always try that autoinstaller,

it worked for me

.
.