Username Change by Siropu

Username Change by Siropu 1.2.5

No permission to download
It's not an issue of this add-on. The username change in tables is done by a built in XF function.
That feature is optional.
If you are using add-ons that have custom tables with username fields, you add those so that when the username is changed, the change applies on those tables too.
Server Error Log

Error Info
ErrorException: Undefined index: password_date - library/XenForo/Visitor.php:678
Generated By: Unknown Account, Today at 7:35 PM
Stack Trace
#0 /library/XenForo/Visitor.php(678): XenForo_Application::handlePhpError(8, 'Undefined index...', '/home/nginx/dom...', 678, Array)
#1 /library/XenForo/ControllerPublic/Register.php(438): XenForo_Visitor->offsetGet('password_date')
#2 /library/XenForo/ControllerPublic/Register.php(427): XenForo_ControllerPublic_Register->_completeRegistration(Array)
#3 /library/Siropu/UsernameChange/ControllerPublic/Register.php(32): XenForo_ControllerPublic_Register->actionRegister()
#4 /library/XenForo/FrontController.php(351): Siropu_UsernameChange_ControllerPublic_Register->actionRegister()
#5 /library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#6 /index.php(13): XenForo_FrontController->run()
#7 {main}

Request State
array(3) {
  ["url"] => string(42) ""
  ["_GET"] => array(1) {
    ["/register/register"] => string(0) ""
  ["_POST"] => array(13) {
    ["username"] => string(0) ""
    ["8a23e851216469052d163ca2815852ec"] => string(13) "USER"
    ["ec378e6884864ccf3b190c08bcde39bb"] => string(32) ""
    ["password"] => string(8) "********"
    ["d63c1f1c7764a89452a63c8267a431a5"] => string(4) "male"
    ["215ebc5aa7508effd77d996caad156d4"] => array(1) {
      ["owe4zgq5zjdjmw"] => string(0) ""
    ["custom_fields_shown"] => array(1) {
      [0] => string(14) "owe4zgq5zjdjmw"
    ["674832e5aa1d0e86140ec04a2ff88df3"] => string(14) "Asia/Hong_Kong"
    ["captcha_question_answer"] => string(7) "Aguilar"
    ["captcha_question_hash"] => string(40) "16e297ee87efd826640e03bb7a06b215d8c49886"
    ["agree"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["reg_key"] => string(32) "9a8dd9f7c3bcb14921ddf2a3077c40dc"
We have set name change every 360 days, on that last day you can change but it gives an error 'you can change your name after 0 days'. So i think it is the day after that it will work because when we set it to 300 days it works again.
I've just done some testing and cannot reproduce this. Basically I've set time frame to 360 days and changed the username. Then I've changed the date of the change in the database to -360 days and it allowed me to change it again with no issues. I've even tried with -359 which shows that you have to wait 1 more day and -361 days and worked fine.
I think it needs a few hours to meet the exact days.
I also encounter that on my forum many times.

I have tested this further and when counter hits 0 there is indeed some more time needed for it to work. Maybe it hits 0 on the exact day but only works on the exact time?
On my website, my users do not have the change username option, it works in admin panel but does not work on the website itself, and I did setup permissions but it's still not working, any idea why?
In admin control panel under options section, you can find the options for the add-on. From there you can set restrictions for it. By default you need minimum 6 months and 150 posts in order to change the username.
Is it possible to limit this to a maximum number of posts and time as member as opposed to minimum? For instance a member can not have more than 5 posts and has to have registered within the past 5 days to be allowed a name change.
Not possible.
This is a very common administrative task on our site, as many members username is autofilled with their real name. We do not allow established members to change their names because it disrupts any content/quoted replies. I have to imagine other forums have a similar issue. Is it not a feature you will consider adding?
Got this error when page is accessed as Guest user.
Server Error Log

Error Info
XenForo_Exception: Cannot load class using XFCP. Load the class using the correct loader first. - library/XenForo/Autoloader.php:108
Generated By: Unknown Account, 6 minutes ago

Stack Trace
#0 [internal function]: XenForo_Autoloader->autoload('XFCP_Siropu_Use...')
#1 /library/Siropu/UsernameChange/ControllerPublic/Account.php(10): spl_autoload_call('XFCP_Siropu_Use...')
#2 /library/XenForo/Autoloader.php(119): include('/home/nginx/dom...')
#3 /library/XenForo/Application.php(1052): XenForo_Autoloader->autoload('Siropu_Username...')
#4 /library/XenForo/Application.php(465): XenForo_Application::autoload('Siropu_Username...')
#5 /library/XenForo/FrontController.php(478): XenForo_Application::resolveDynamicClass('Siropu_Username...', 'controller')
#6 /library/XenForo/FrontController.php(361): XenForo_FrontController->_getValidatedController('Siropu_Username...', 'Index', Object(XenForo_RouteMatch))
#7 /library/XenForo/FrontController.php(152): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#8 /index.php(13): XenForo_FrontController->run()
#9 {main}

Request State
array(3) {
  ["url"] => string(40) ""
  ["_GET"] => array(1) {
    ["/change-username"] => string(0) ""
  ["_POST"] => array(0) {
Top Bottom