1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 URGENT: Avatar permissions problem

Discussion in 'Troubleshooting and Problems' started by Valter, Apr 29, 2014.

  1. Valter

    Valter Active Member

    Uploaded avatars are not properly chmodded which makes them not appear in forums. It's 0600 instead of 0644. My hosting provider will not change umask settings so is there anything to do on my side to fix this?

    Can I add umask() in php somewhere to define avatars permissions on creation?
    Last edited: Apr 29, 2014
  2. Mian Shahid

    Mian Shahid Well-Known Member

    Why not you change the avatar folder permission by your self using FTP client?
  3. Mike

    Mike XenForo Developer Staff Member

    You posted in a thread where I mentioned the config.php option to force a specific chmod. You should set that.
  4. Valter

    Valter Active Member

    Folder permissions for data and internal_data are correct (0777).
    I have a problem with the wrong file permissions.

    I've also added $config['chmodWritableValue'] = 0644; to config.php.

    But it didn't helped. When user uploads new avatar images are automatically set to 0600.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Sounds like a hosting problem... have you contacted them with your problem?
  6. Mike

    Mike XenForo Developer Staff Member

    If you've added that to config.php, then I can only presume that the chmod function has been disabled (which I have seen at least once before, I believe). In which case, only your host can help resolve this.
  7. Valter

    Valter Active Member

    I've contacted hosting company, they said they can not change php options globally.

    Fortunately, forum user Devilwillcry4you sent me a php.ini file which worked for them. I've added that to the forum root folder and problem is gone now. :)

    Thanks Devilwillcry4you!

Share This Page