• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 upgrade problem from 1.5.13 to 1.5.14

#1
I try to upgrade from 1.5.13 to 1.5.14 and i get blank page when i acces site.com/install (site.com/install/index.php?upgrade/)
I try with 1.5.15 and 1.5.15a version and the same problem.
I run on centos 7 with php 5.6
Code:
php -v
PHP 5.6.31 (cli) (built: Sep 14 2017 18:12:46)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v5.1.1, Copyright (c) 2002-2016, by ionCube Ltd.
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies
    with Suhosin v0.9.38, Copyright (c) 2007-2015, by SektionEins GmbH
Code:
Distributor ID: CentOS
Release:        7.4.1708
Codename:       Core
If i go back to 1.5.13 my forum work again.

some advices to solve my problem?
thk you.
 

Mike

XenForo developer
Staff member
#2
You will likely either need to disable Suhosin or adjust your Suhosin function blacklist. I'm guessing you have escapeshellarg blacklist, which really shouldn't ever be disabled (it's a string manipulation function).
 
#3
You will likely either need to disable Suhosin or adjust your Suhosin function blacklist.
The forum work fine now (version 1.5.13) with Suhosin enable, the problem is when i try to upgrade.
They are change on version 1.5.14 and .1.5.15 that don`t work with Suhosin?
 

Mike

XenForo developer
Staff member
#4
No, Suhosin is interfering with code that has been around for a while. It's only triggered with upgrades though.

Note that it's specifically related to how the Suhosin function blacklist is configured.
 
#5
I solve the problem.
1. disable Suhosin for my domain
2. run upgrade
3. enable Suhosin again for my domain.

Now all work fine and i run last version.
thk you @Mike