XF 2.2 Upgrade crashes to action_available_via_post_only

Janderfu

Member
Upgrading from 1.5 to 2.2.4. Upgrade starts and then crashes at some point around 2.1 alpha step 18 mark. It happens so fast that I can't tell exactly. Site becomes completely unresponsive. After about 5 minutes I can go to the /install/index.php?upgrade/run URL and I get an error that reads "action_available_via_post_only" and an "Oops! We ran into some problems." message.

During this the general site URL is completely 404d.

If I go back to the install URL I get this message:
Known conflicts with the following third-party add-ons have been detected:
  • [TH] Custom Fields
  • [bd] Widget Framework
  • Conversation Improvements by Xon
Conflicts will be resolved during the upgrade process by renaming affected database tables and columns. If you do not intend to use the add-ons after upgrading, you may prefer to restore the XenForo files from your previous version and uninstall the conflicting add-ons. The add-on authors may have more specific recommendations for resolving these conflicts.

I get the option to restart the upgrade. Same crash happens.

Submitted a ticket. Just wondering if there's something else I can do.

Entire site is down. Thanks.
 

Masetrix

Well-known member
The best way in your case is to restore a backup of your forum version 1.5.
Then uninstall there: [bd] Widget Framework
Upgrade: https://xenforo.com/community/threads/th-custom-fields.34093/page-59#post-1375440 and Conversation Improvements by Xon.

Then, after that, upgrade to XF 2.0.12 and import your th-custom-fields there.
If everything works properly then upgrade to the latest XF.

But if everything works as it should already, you don't have to follow these steps ....
 
Top