UI.X 2

UI.X 2 [Paid] 2.1.0.2

No permission to buy ($35.00)

haincha

Member
Trying to upgrade to 2.1, installed the latest UI.X packages then upgraded to 2.1 and am greeted with this message on any page:
Code:
An exception occurred: [ErrorException] [E_WARNING] Declaration of ThemeHouse\Reactions\XF\Template\Templater::fnReaction($templater, &$escape, $reaction, $class = '') should be compatible with XF\Template\Templater::fnReaction($templater, &$escape, array $config) in src/addons/ThemeHouse/Reactions/XF/Template/Templater.php on line 0

XF::handlePhpError() in src/vendor/composer/ClassLoader.php at line 444
include() in src/vendor/composer/ClassLoader.php at line 444
Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
Composer\Autoload\ClassLoader->loadClass()
spl_autoload_call()
class_exists() in src/XF/Extension.php at line 172
XF\Extension->extendClass() in src/XF/App.php at line 2661
XF\App->extendClass() in src/XF/App.php at line 1665
XF\App->setupTemplaterObject() in src/XF/App.php at line 1296
XF\App->XF{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 2961
XF\App->templater() in src/XF/Pub/App.php at line 424
XF\Pub\App->preRender() in src/XF/Mvc/Dispatcher.php at line 355
XF\Mvc\Dispatcher->render() in src/XF/Mvc/Dispatcher.php at line 53
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in index.php at line 20
Any thoughts on what is going on here? I have to restore from last nights backup to fix this.
 

Dnyan Deshmukh

Well-known member
Trying to upgrade to 2.1, installed the latest UI.X packages then upgraded to 2.1 and am greeted with this message on any page:
Code:
An exception occurred: [ErrorException] [E_WARNING] Declaration of ThemeHouse\Reactions\XF\Template\Templater::fnReaction($templater, &$escape, $reaction, $class = '') should be compatible with XF\Template\Templater::fnReaction($templater, &$escape, array $config) in src/addons/ThemeHouse/Reactions/XF/Template/Templater.php on line 0

XF::handlePhpError() in src/vendor/composer/ClassLoader.php at line 444
include() in src/vendor/composer/ClassLoader.php at line 444
Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
Composer\Autoload\ClassLoader->loadClass()
spl_autoload_call()
class_exists() in src/XF/Extension.php at line 172
XF\Extension->extendClass() in src/XF/App.php at line 2661
XF\App->extendClass() in src/XF/App.php at line 1665
XF\App->setupTemplaterObject() in src/XF/App.php at line 1296
XF\App->XF{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 2961
XF\App->templater() in src/XF/Pub/App.php at line 424
XF\Pub\App->preRender() in src/XF/Mvc/Dispatcher.php at line 355
XF\Mvc\Dispatcher->render() in src/XF/Mvc/Dispatcher.php at line 53
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2177
XF\App->run() in src/XF.php at line 390
XF::runApp() in index.php at line 20
Any thoughts on what is going on here? I have to restore from last nights backup to fix this.
do you use TH reaction addon on 2.1 when it had its own reactions.
 

Kent D

Active member
You can update this by navigating to Appearance -> Style Properties -> Discussion list -> Update the Title and Tile (unread) to your default settings.there.

Go ahead and start a ticket on our support portal on this as one of our staff will be in contact ;)
194896
no see login with social buttton and eror log

Code:
Stack trace
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Macro public:co...', '/home/wasavn.co...', 581, Array)
#1 src/XF/Template/Templater.php(581): trigger_error('Macro public:co...', 512)
#2 src/XF/Template/Templater.php(692): XF\Template\Templater->getTemplateMacro('public', 'connected_accou...', 'button')
#3 internal_data/code_cache/templates/l2/s15/public/login.php(140): XF\Template\Templater->callMacro('connected_accou...', 'button', Array, Array)
#4 src/XF/Template/Templater.php(1293): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array)
#5 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('login', Array)
#6 src/XF/Mvc/Renderer/Json.php(83): XF\Template\Template->render()
#7 src/XF/Mvc/Renderer/Json.php(67): XF\Mvc\Renderer\Json->renderHtmlFallback('XF:Login\\Form', 'public:login', Array)
#8 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Json->renderView('XF:Login\\Form', 'public:login', Array)
#9 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Json), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Json), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'json')
#12 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#13 src/XF.php(392): XF\App->run()
#14 index.php(20): XF::runApp('XF\\Pub\\App')
#15 {main}
 

Dalton Prock

Well-known member
View attachment 194896
no see login with social buttton and eror log

Code:
Stack trace
#0 [internal function]: XF\Template\Templater->handleTemplateError(512, 'Macro public:co...', '/home/wasavn.co...', 581, Array)
#1 src/XF/Template/Templater.php(581): trigger_error('Macro public:co...', 512)
#2 src/XF/Template/Templater.php(692): XF\Template\Templater->getTemplateMacro('public', 'connected_accou...', 'button')
#3 internal_data/code_cache/templates/l2/s15/public/login.php(140): XF\Template\Templater->callMacro('connected_accou...', 'button', Array, Array)
#4 src/XF/Template/Templater.php(1293): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array)
#5 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('login', Array)
#6 src/XF/Mvc/Renderer/Json.php(83): XF\Template\Template->render()
#7 src/XF/Mvc/Renderer/Json.php(67): XF\Mvc\Renderer\Json->renderHtmlFallback('XF:Login\\Form', 'public:login', Array)
#8 src/XF/Mvc/Dispatcher.php(418): XF\Mvc\Renderer\Json->renderView('XF:Login\\Form', 'public:login', Array)
#9 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Json), Object(XF\Mvc\Reply\View))
#10 src/XF/Mvc/Dispatcher.php(360): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Json), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(53): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'json')
#12 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#13 src/XF.php(392): XF\App->run()
#14 index.php(20): XF::runApp('XF\\Pub\\App')
#15 {main}
Could you go ahead and report this in a ticket, please? From there one of our staff will be able to help further ;)
 

requo

Active member
Make sure you are using the latest version of the UI.X add-on, which should be compatible with Beta 5 just fine. It just looks like your UI.X add-on is outdated is all.



You can set them to rems in Style Properties > Typography. We've simplified the base font size to 10px, so for example 14px is 1.4rem. No math required :)
Hello, i have similar problem. In Style Style Properties > Typography i have rem unit. But personal change font size does not work - any choice, still the same size. Do I have to do something else?
 

Ian Hitt

Well-known member
Hello, i have similar problem. In Style Style Properties > Typography i have rem unit. But personal change font size does not work - any choice, still the same size. Do I have to do something else?
Check to see if you have any outdated templates. Specifically, if PAGE_CONTAINER is outdated, then the change will not work.
 

Kent D

Active member
  1. can we make title bar same row ưith moderator bar and remove "reply" button
  2. can we remove scroll up and down button
195425
better design i think make avatar 1 row and bigger, name and title other row anf center
 
Last edited:
Top