• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
UI.X 2

UI.X 2 [Paid] 2.0.0.2

No permission to buy ($35.00)

ThemeHouse

Well-known member
#1
ThemeHouse submitted a new resource:

UI.X 2 - The Ultimate XenForo Framework

title-uix2.png

Introducing the fan favorite UI.X for XenForo 2. Based off of the tried true methodologies of its XenForo 1 predecessor, UI.X continues to push the boundaries of intelligent, performant, perfected design. Modern tools that increase user interactions, familiar user interface based on Google’s ever popular Material design, and the backing of a team well-versed in the XenForo software make UI.X a wise choice for any forum. ThemeHouse has been building products for XenForo since day one of the software’s release and we aren’t going anywhere.

Just a minute to install, a few clicks to easily change images and colors in line with your brand, and you’re off and running. And if you ever have a question, we’re here to help.
Read more about this resource...
 
Last edited:

katsulynx

Well-known member
#7
Looks good so far. Still exploring it.

Is there any sort of list of all icons that come with the Material Design Icons including their mapping inside the font file? Traversing through them to find the right icon is utterly painful.
 

Mike Creuzer

Well-known member
#8

Jake B.

Well-known member
#9
Forgot to mention in the resource listing, after you checkout you get a free license for [TH] Nodes automatically that will automatically renew with your UI.X 2 license (it is required that both of these are used on the same domain, however)
 

katsulynx

Well-known member
#10
For sure! We include MDI (https://materialdesignicons.com/) and tagging @Ian Hitt on a cheatsheet link.
Thanks! If it's not too much work, could you give me the hexcode for this icon? Really just if it's not too much work, I'm not in a hurry, just excited to see the navbar finished with all the icons.

Also is there a general place for bug reports? I've noticed that the phrase for the width toggle apparently seems to be missing and sub-forum popup links can turn out quite unreadable if a background color for the node grid is set.
 

Mike Creuzer

Well-known member
#11
Thanks! If it's not too much work, could you give me the hexcode for this icon? Really just if it's not too much work, I'm not in a hurry, just excited to see the navbar finished with all the icons.
For sure! I believe it is `f3eb` and the class is `mdi-pencil`
Also is there a general place for bug reports? I've noticed that the phrase for the width toggle apparently seems to be missing and sub-forum popup links can turn out quite unreadable if a background color for the node grid is set.
Wow, I thought we had the phrase added in sorry for that. And sure the bugs can be posted here: https://www.themehouse.com/xenforo/issues
 

Alien

Well-known member
#12
Hey really nice job here!

I noticed on the demo site, if I load up the dark version and click around the site it flashes white first before appearing properly dark on all pages...

Bug?
 
Last edited:

Alien

Well-known member
#13
Just an update.. Once I loaded the site without the extra themehouse top bar I didn't get any white flashing between pages. Interesting...

Latest Chrome, Win 10.
 

bart

Active member
#16
I have a faulty file-permission somewhere... But where?

ErrorException: [E_WARNING] mkdir(): Permission denied in src/XF/Util/File.php at line 192

  1. XF::handlePhpError()
  2. mkdir() in src/XF/Util/File.php at line 192
  3. XF\Util\File::createDirectory() in src/addons/ThemeHouse/UIX/Service/Style/Mover.php at line 119
  4. ThemeHouse\UIX\Service\Style\Mover->mkdir() in src/addons/ThemeHouse/UIX/Service/Style/Mover.php at line 59
  5. ThemeHouse\UIX\Service\Style\Mover->rmove() in src/addons/ThemeHouse/UIX/Service/Style/Mover.php at line 81
  6. ThemeHouse\UIX\Service\Style\Mover->rmove() in src/addons/ThemeHouse/UIX/Service/Style/Mover.php at line 81
  7. ThemeHouse\UIX\Service\Style\Mover->rmove() in src/addons/ThemeHouse/UIX/Service/Style/Mover.php at line 28
  8. ThemeHouse\UIX\Service\Style\Mover->move() in src/addons/ThemeHouse/UIX/XF/Admin/Controller/Style.php at line 132
  9. ThemeHouse\UIX\XF\Admin\Controller\Style->installUpgradeStyle() in src/addons/ThemeHouse/UIX/XF/Admin/Controller/Style.php at line 44
  10. ThemeHouse\UIX\XF\Admin\Controller\Style->actionThemehouseInstall() in src/XF/Mvc/Dispatcher.php at line 249
  11. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  12. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  13. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1879
  14. XF\App->run() in src/XF.php at line 328
  15. XF::runApp() in admin.php at line 13
I get this when I try to install the theme throught the admincp in the section "ThemeHouse Styles ".

To which directory does the script want to write?
 

Mike Creuzer

Well-known member
#20
Just an update.. Once I loaded the site without the extra themehouse top bar I didn't get any white flashing between pages. Interesting...

Latest Chrome, Win 10.
This is likely our demo picker, its somewhat new so Ill create an issue on this internally. Thanks for reporting!!