UI.X 2

UI.X 2 [Paid] 2.0.10.0.0

No permission to buy ($35.00)

Mike Creuzer

Well-known member
If I wanted to center my logo in the middle of my nav bar, how would I go ahead at doing so?
It depends, as if there are things such as navigation items or other items say on your right, then logo wont have anything to center to. If you think of it as a position, and you enable logo block to be on its own line, then there is a setting for this. Its worth a video explanation but all in all, for a use of space, its typically not best. A cheaper way is to say for desktop show it as a background image.
Hello, how can I make this setting?

My settings are these:

Thanks in advance :)
Its looking like you just need the 100% on that last property.
Wondering when UIX.2 is being updated for the latest XF version
I believe @Ian Hitt is working on this
 

Charlie J

Active member
It depends, as if there are things such as navigation items or other items say on your right, then logo wont have anything to center to. If you think of it as a position, and you enable logo block to be on its own line, then there is a setting for this. Its worth a video explanation but all in all, for a use of space, its typically not best. A cheaper way is to say for desktop show it as a background image.

Its looking like you just need the 100% on that last property.

I believe @Ian Hitt is working on this
Ty, i just wanna be able to do something like:

HOME FORUM <LOGO> BLAH BLAH2

all centered in nav bar, and the logo goes over a bit
 

oneobgyn

Member
Hi Guys
I have latest UI.X2 and latest X2. I am using latest Admanager, and want to place a background advert behind some of my forum node pages. It work, BUT the current UI.X2 has gaps in the page and between the boxes, thus my image shows in those gaps.

Is there a way to set the block (page column) in white, so the background image only shows left and right of the page column, which I have set to max 1240px wide?
 

Dalton Prock

Well-known member
Thank you! I have a last question: How can I make this effect on my Forum logo?
Thanks :)
We've received your ticket on this and hope to have a response for ya soon.
Hi Guys
I have latest UI.X2 and latest X2. I am using latest Admanager, and want to place a background advert behind some of my forum node pages. It work, BUT the current UI.X2 has gaps in the page and between the boxes, thus my image shows in those gaps.

Is there a way to set the block (page column) in white, so the background image only shows left and right of the page column, which I have set to max 1240px wide?
Not sure on this but go ahead and create a ticket so we can take a deeper look into it, please! :)
 

ThemeHouse

Well-known member
ThemeHouse updated UI.X 2 with a new update entry:

Version 2.0.10.0.0 Released

UI.X 2 2.0.10.0.0 Changelog:
  1. Fixed cookie notice alignment
  2. Fixed the issue that caused registration field names from not being aligned with the field boxes
  3. Improvements were made to the styling for the media column sidebar
  4. Improvements were made to button sizing
  5. Fixed scrolling notice display issues
  6. Removed the negative margin in the title bar
  7. Improvements synced styling on quick reply messages
  8. Social media links now open in a new tab
  9. Improved...
Read the rest of this update entry...
 
Hello, I am trying to update UI.X from the AdminCP > Styles > ThemeHouse styles, but when I try to upgrade it, give me this error:

LogicException: Class ThemeHouse\UIX\Service\UpdateCheck does not exist in src/XF/Container.php at line 267
  1. XF\Container->createObject() in src/XF/App.php at line 1359
  2. XF\App->XF\{closure}() in src/XF/Container.php at line 228
  3. XF\Container->create() in src/XF/App.php at line 2508
  4. XF\App->service() in src/XF.php at line 527
  5. XF::service() in src/addons/ThemeHouse/UIX/XF/Admin/Controller/Style.php at line 30
  6. ThemeHouse\UIX\XF\Admin\Controller\Style->preDispatch() in src/XF/Mvc/Dispatcher.php at line 248
  7. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  8. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  9. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1931
  10. XF\App->run() in src/XF.php at line 329
  11. XF::runApp() in admin.php at line 13

My server errors log:
1537473552404.png
 

JoyFreak

Formerly Zuse
Hello, I am trying to update UI.X from the AdminCP > Styles > ThemeHouse styles, but when I try to upgrade it, give me this error:

LogicException: Class ThemeHouse\UIX\Service\UpdateCheck does not exist in src/XF/Container.php at line 267
  1. XF\Container->createObject() in src/XF/App.php at line 1359
  2. XF\App->XF\{closure}() in src/XF/Container.php at line 228
  3. XF\Container->create() in src/XF/App.php at line 2508
  4. XF\App->service() in src/XF.php at line 527
  5. XF::service() in src/addons/ThemeHouse/UIX/XF/Admin/Controller/Style.php at line 30
  6. ThemeHouse\UIX\XF\Admin\Controller\Style->preDispatch() in src/XF/Mvc/Dispatcher.php at line 248
  7. XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 88
  8. XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 41
  9. XF\Mvc\Dispatcher->run() in src/XF/App.php at line 1931
  10. XF\App->run() in src/XF.php at line 329
  11. XF::runApp() in admin.php at line 13

My server errors log:
Always upgrade the add-ons first before upgrading the Theme. It's good practice.
 

Charlie J

Active member
Hey there, trying to setup custom node icons with [TH] Nodes, they don't seem to apply with UI.X 2.

1537522167858.png

I configured to have icons for those sub nodes, they haven't seemed to have changed.

Ty
 
Top