XF 2.2 Thumbnails show as links instead of images, ID's desynced?


Active member
Full disclosure, this is our test forum so I'm sure whatever is causing this is something we screwed up, but I noticed that when we insert attachments as thumbnails instead of full images, the result looks like this:


On the left of the post message, there's the link "fm_avatar2.jpg" which brings you to the full size image. The left is the "insert thumbnail" result. We're talking about small images too, I've tested as small as 50x50 and still no thumbnail is generated for it, so it doesn't appear to be a file size or dimension issue.

This is attachment ID 5192, but looking at the attachment data itself in /internal_data and /data, the IDs only go up to 5187, meaning there is an offset of 5 somehow. Not sure how this happened, but is this the cause, and if so can this be corrected? We have tried rebuilding media items, post embeds with attachments checked, and media thumbnails with no change.

Edit: Checked the database for attachments, they show the correct attachment ID to data ID. Don't know where or how the offset happened, but they are linked properly, it seems:1683875253156.png

EDIT 2: The offset does not appear to be the root cause. Went to an earlier image that also has an offset, those thumbnails generate just fine. It is a recent issue.
Last edited:
Top Bottom