Fixed Facebook Photo Posts displayed as links instead of embeds

Affected version
2.1.0

rfc0001

Well-known member
Many Facebook Page Posts have the following format:

https://www.facebook.com/WDWNewsToday/photos/a.441846857712/10156708925807713/

Instead of embedding these as a post (which they are) they are embedded as URLs, e.g.:

 

Chris D

XenForo developer
Staff member
I think this is the correct behaviour.

We only convert individual posts or videos - I'm not sure what Facebook would classify that as exactly, but it appears to be a page containing multiple posts so it's not actually something they support embedding from.
 

rfc0001

Well-known member
I think this is the correct behaviour.

We only convert individual posts or videos - I'm not sure what Facebook would classify that as exactly, but it appears to be a page containing multiple posts so it's not actually something they support embedding from.
The are listed under Posts on the Page. I think it's a technicality that their links are photos.

Here's an example of a Page where literally every Post has a link like the above:

Ctrl-click the "x min" under a post to get a link in the above format. There is no post link, making it literally impossible to embed a post from pages using Photos in posts. Am I to tell every Facebook page owner that creates Posts using Photos that they are doing it wrong? :p
 
Last edited:

Chris D

XenForo developer
Staff member
Turns out these are embeddable.

Links like this:
Code:
https://www.facebook.com/WDWNewsToday/photos/a.441846857712/10156711002317713/?type=3&permPage=1
Can be converted to:
Code:
https://www.facebook.com/WDWNewsToday/posts/10156711002317713/

I promise you I did try this last night but either my internet connection was playing up or Facebook was having an off day because I pasted that photos link into this page and nothing happened: https://developers.facebook.com/docs/plugins/embedded-posts/

🤷‍♂️
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue. It has now been resolved and we are aiming to include it in a future XF release (2.1.2).

Change log:
Support embedding Facebook "photos" URLs.
Any changes made as a result of this issue being resolved may not be rolled out here until later.
 

Ludachris

Well-known member
Is this only a function of 2.X, not 1.5? I ask because when I try to paste a link for a FB post in a reply it renders it as a link, not an embed. And I have FB listed as a BB Code Media Site in ACP. It just doesn't parse it and show it as a FB post.
 
Top